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Preface

Maple Software

MapleTM software is a powerful system that you can use to solve mathematical problems from simple to complex. You
can also create professional quality documents, presentations, and custom interactive computational tools in the Maple
environment.

You can access the power of the Maple computational engine through a variety of interfaces.

Interface Description

Standard (default) A full-featured graphical user interface that helps you create electronic documents to show all
your calculations, assumptions, and any margin of error in your results. You can also hide the
computations to allow your reader to focus on the problem setup and final results. The advanced
formatting features lets you create the customized document you need. Because the documents
are /ive, you can edit the parameters and, with the click of a button, compute the new results.
The Standard interface has two modes: Document mode and Worksheet mode.

An interactive version of this manual is available in the Standard Worksheet interface. From
the Help menu, select Manuals, Resources, and more — Manuals — User Manual.

Classic A basic worksheet environment for older computers with limited memory. The Classic interface
does not offer all of the graphical user interface features that are available in the Standard
interface. The Classic interface has only one mode, Worksheet mode.

Command-line version A command-line interface for solving very large complex problems or batch processing with
scripts. No graphical user interface features are available.

Graphical user interfaces containing windows, textbox regions, and other visual interfaces,
which gives you point-and-click access to the power of Maple. You can perform calculations
and plot functions without using the worksheet.

MapletTM Applications

Maplesoft™ Graphing Calculator|A graphical calculator interface to the Maple computational engine. Using it, you can perform

simple computations and create customizable, zoomable graphs. This is available on Microsoft®™

Windows® only.

This manual describes how to use the Standard interface. As mentioned, the Standard interface offers two modes:
Document mode and Worksheet mode. Using either mode, you can create high quality interactive mathematical docu-
ments. Each mode offers the same features and functionality, the only difference is the default input region of each
mode.

Shortcut Keys by Platform

This manual will frequently refer to context menus and command completion when entering expressions. The keyboard
keys used to invoke these features differ based on your operating system.

This manual will only refer to the keyboard keys needed for a Windows operating system. The shortcut keys for your
operating system can be viewed from the Help menu (Help — Manuals, Resources, and more — Shortcut Keys).

Context Menus
« Right-click, Windows and UNIX®
* Control-click, Macintosh®

That is, place the mouse over the input or output region and press the right button on the mouse or press and hold the
Control key and click the mouse key for Macintosh.

For more information on Context Menus, see Context Menus (page 32).

xiii
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Command Completion

¢ Esc, Macintosh, Windows, and UNIX
* Ctrl + Space, Windows

« Ctrl + Shift + Space, UNIX

Begin entering a command in a Maple document. Press the Esc key. Alternatively, use the platform-specific keys. For
Windows, press and hold the Ctrl key and then press the Space bar.

For more information on Command Completion, see Command Completion (page 39).

In This Manual

This manual provides an introduction to the following Maple features:
» FEase-of-use when entering and solving problems

» Point-and-click interaction with various interfaces to help you solve problems quickly
* Maple commands and standard math notation

* Clickable Calculus

* The help system

* Online resources

* Performing computations

* Creating plots and animations

* The Maple programming language

 Using and creating custom Maplet applications

+ File input and output, and using Maple with third party products

¢ Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft web site at
http://www.maplesoft.com

Audience

The information in this manual is intended for first-time Maple users and users looking for a little more information.

Conventions

This manual uses the following typographical conventions.

* bold font - Maple command, package name, option name, dialog, menu, or text field
* italics - new or important concept

* Note - additional information relevant to the section

* Important - information that must be read and followed

Customer Feedback

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact

doc@maplesoft.com.


http://www.maplesoft.com

1 Getting Started

Don't worry about your difficulties in Mathematics. I can assure you mine are still greater.
~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating the total cost of our purchases to the complex

calculations used to construct the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an accessible and complete form. That tool is Maple.

1.1 In This Chapter

Section

Topics

Introduction to Maple (page 2) - The main features of Maple's
Standard Interface

Starting the Standard Document Interface

* Entering commands and mathematical expressions
* Toolbars

» Context menus

* Copy and drag keys

* Saving Maple documents

Entering Expressions (page 15) - Methods of entering
expressions in 1-D and 2-D Math

» Execution groups

* Math Mode and Text Mode
* Palettes

* Symbol names

* Toolbar icons

Point-and-Click Interaction (page 26) - An introduction to the
point-and-click features in Maple

+ Assistants

» Tutors

* Context menus
* Task templates

» Exploration Assistant

Commands (page 37) - An introduction to the commands of the
Maple language

+ Using commands from the Maple library
+ Entering commands

* Document blocks

The Maple Help System (page 43) - Accessing help on
commands, packages, point-and-click features, and more

* How to access help for Maple features
* Interacting with help pages

+ Viewing and interacting with examples

Available Resources (page 46) - Both online and from within
Maple

New user resources, including the Maple Tour and the Maple
Portal

» Examples
¢ Online help

* Maple web site resources




2 1 Getting Started

1.2 Introduction to Maple

Working in Maple

With Maple, you can create powerful interactive documents. The Maple environment lets you start solving problems
right away by entering expressions in 2-D Math and solving these expressions using point-and-click interfaces. You
can combine text and math in the same line, add tables to organize the content of your work, or insert images, sketch
regions, and spreadsheets. You can visualize and animate problems in two and three dimensions, format text for aca-
demic papers or books, and insert hyperlinks to other Maple files, web sites, or email addresses. You can embed and
program graphical user interface components, as well as devise custom solutions using the Maple programming language.

) *Maple =Joks
File Edit “iew Insatt  Format Tools  wWindow  Help
D2BESS XMl 5¢ TP & MIOHe & BRXE 2
| w Favorites | 2 : Text Drawing Plot Animation Hide
L] ':\'_ C 20 Math V;:' ':\'_Times Mewe Roman V;:' |::_ 12 V;:' B g = = % = %E
dex 5T ® [
@ x2+2x—63+x2—4x+21:x2—6x+37 [log(x), x, 107] — -
:1* , Tk EE Tl 10l 5
T + @ E
. ]
W Expression I.2 i rin+1) . an & LH 100_:
] bl i=1 2 i
dex Ifdx z;cf 10 107t
i= f
¢ NE ]
- d o P = 10724
e ar w7 || ] _
. 3 — %
i foa+E a—b PP =r— 1 103-E
b Lo g 1 -4
“ b “ 3.5|[3T k:d 5.2[[ﬂ[ = 4.944444444 Hﬂl 10
. 5 k 5 1 =
“n @ iC -3 T T . .
n— et weFowe?owet owt !
Ja al Jex|
&7 In() X'+ 8x'+ 25x=200cos¢ + 520sins;, x(0)=52x'(0)=0
log, (@) log, (@ 2 left ancd
Bipl2) gy (a) (x—72=2(x—3)" 2B, 7P —g(x—3)2=0"B" 72 4+ Mx—23=0
sin(a) cos(e) tan(e)
54
7] =—x for y:;{fgr
[b] fla) fla8) Recall that x=l 4 x>0
F=a—y x xz0, 3
x| =
F=(a,d)—z -x x=<10 )
Flx) X x=a The graph of y = |x| consists of the right half of the line on y=x 1)
b=a X x=a the line 3 = x with the left half of the line y =—x as shown.
5 4 3 2 10 1 2 3 4 3 [w
vl 2] 2]
® Ready Memory: 0.37M Time: 0.03s Math Mode

Figure 1.1: The Maple Environment



1.2 Introduction to Maple « 3

Starting the Standard Document Interface

To start Maple on:

Windows From the Start menu, select All Programs — Maple 17 — Maple 17.
Alternatively:

Double-click the Maple 17 desktop icon.
Macintosh 1. From the Finder, select Applications and Maple 17.

2. Double-click Maple 17.

UNIX Enter the full path, for example, /usr/local/maple/bin/xmaple

Alternatively:
1. Add the Maple directory (for example, /usr/local/maple/bin) to your command search path.

2. Enter xmaple.

The first Maple session opens with a Startup dialog explaining the difference between Document Mode and Worksheet
Mode. Using either mode, you can create high quality interactive mathematical documents. Each mode offers the same
features and functionality; the only difference is the default input region of each mode.

Document Mode

Document mode uses Document Blocks as the default input region to hide Maple syntax. A Document Block region

is indicated by two triangles located in the vertical Markers column along the left pane of the Maple Document, 2< |. .
If the Markers column is not visible, open the View menu and select Markers. This allows you to focus on the problem
instead of the commands used to solve the problem. For example, when using context menus on Maple input in Document
mode (invoked by right-clicking or Control-clicking for Macintosh), input and output are connected using an arrow
or equal sign with self-documenting text indicating the calculation that had taken place. The command used to solve
this expression is hidden.

be . ;
Z FATr+ 10— {x=-=2}, {x=-5}
When starting Standard Maple, the default mode is Document mode.

Worksheet Mode

Worksheet mode uses a Maple prompt as the default input region. The Maple input prompt is a red angle bracket, [::-.
When using context menus on input in Worksheet mode, all commands are displayed.

[ #erspn
> solve( {24+ T*x+10=01})
{x=-=12}, {x=-5}

To work in Worksheet mode, select File — New — Worksheet Mode.

Document and Worksheet Modes

Regardless of which mode you are working in, you have the opportunity to show or hide your calculations. You can
hide commands in Worksheet Mode by adding a document block from the Format menu, Format — Create Document
Block (see Document Blocks (page 41)), or you can show commands in Document mode by adding a Maple prompt
from the Insert menu, Insert — Execution Group — Before / After Cursor (see Input Prompt (page 62)).

This chapter discusses features common to both modes. Specific aspects of Document mode are explained in Document
Mode (page 49), and aspects of Worksheet mode are explained in Worksheet Mode (page 61).
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The Startup dialog also contains links to items, such as various document options, help resources including updates
and other introductory help pages, and application resources on the Maplesoft web site. Subsequent sessions display
Tip of the Day information.

To start a Maple session:

1. In the Startup dialog, select Blank Document or Blank Worksheet. A blank document displays.

or
1. Close the Startup dialog.

2. From the File menu, select New, and then either Document Mode or Worksheet Mode. A blank document displays.

Every time you open a document, Maple displays a Quick Help pop-up list of important shortcut keys. To invoke
Quick Help at any time, press the F1 key.

Entering 2-D Math

In Maple, the default format for entering mathematical expressions is 2-D Math. This results in mathematical expressions
that are equivalent to the quality of math found in textbooks. Entering 2-D Math in Maple is done using common key
strokes or palette items. For more information on palettes, see Palettes (page 17). An example of entering an expression
using common key strokes is presented in the following section. An example of entering an expression using palette
items is presented in Example 3 - Enter an Expression Using Palettes (page 22).

Common Operations

Entering mathematical expressions, such as % + %, 2+ x, and x-y is natural in 2-D Math.

To enter a fraction:

1. Enter the numerator.

2. Press the forward slash (/) key.
3. Enter the denominator.

4. To leave the denominator, press the right arrow key.

To enter a power:

1. Enter the base.

2. Press the caret (") key.

3. Enter the exponent, which displays in math as a superscript.

4. To leave the exponent, press the right arrow key.

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in 2-D Math as a dot, -.

3. Enter the second factor.

Implied Multiplication:

In most cases, you do not need to include the multiplication operator, -. Insert a space character between two quantities
to multiply them.

Note: In some cases, you do not need to enter the multiplication operator or a space character. For example, Maple
interprets a number followed by a variable as multiplication.
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Important: Maple interprets a sequence of letters, for example, xy, as a single variable. To specify the product of two

variables, you must insert a space character (or multiplication operator), for example, x y or x-y. For more information,
refer to the 2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

Symbol/Formats

Key

Example

implicit multiplication

Space key

(x2 —7xy+3y2)xy

* (asterisk)

» Ctrl + Space, Windows
+ Ctrl + Shift + Space, UNIX

explicit multiplication 2-3
fraction / (forward slash) 1

4

N

exponent (superscript)? (Shift + 6 or caret key) 2
indexed subs cript2 Ctrl+ (Command+ , Macintosh) X,
literal subscript (subscripted ___(two underscores) x
variable name) max
navigating expressions Arrow keys
command / symbol completi on? |° Esc, Macintosh,Windows, and UNIX | g4

about {assumptions and properties)  abouf|expr |
ahreve 4

ahs 1x1
abs ahs
abselsol (first order  DETools [abelsol 1| ODE, 1)

square root

sqrt and then command completion

exponential function’

exp and then command completion

enter / exit 2-D Math

* F5key

* Math and Text icons in the toolbar

% versus 1/4

! required for products of numbers

3 for more information, see Command Completion (page 39).

2 use the right arrow key to leave a denominator, superscript, or subscript region

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints help page. To access this help
page in the Maple software, in Math mode enter MathShortcuts and then press Enter. For information on the Maple
Help System, see The Maple Help System (page 43).

Example 1 - Enter and Evaluate an Expression Using Keystrokes

Review the following example:

X 4y
2
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2 2
In this example, you will enter % and evaluate the expression.

Action

Result in Document

To enter the expression:

1. Enter x.

A

2. Press Shift + 6 (the * or caret key). The cursor moves to the superscript position.

A

3. Enter 2.

4

4. Press the right arrow key. The cursor moves right and out of the superscript position.

%

5. Enter the + symbol.

o 4]

6. Entery.

=+

7. Press Shift + 6 to move to the superscript position.

24y

8. Enter 2 and press the right arrow key.

2+

9. With the mouse, select the expression that will be the numerator of the fraction.

2y

10. Enter the / symbol. The cursor moves to the denominator, with the entire expression in
the numerator.

4y

|

11. Enter 2.

4y

El

12. Press the right arrow key to move right and out of the denominator position.

2
To evaluate the expression and display the result inline: 2+ y2 1 2,12
13. Press Ctrl + = (Command + =, Macintosh). 2 27 Y

To execute 2-D Math, you can use any of the following methods.

* Pressing Ctrl + = (Command + =, for Macintosh). That is, press and hold the Ctrl (or Command) key, and then

press the equal sign (=) key. This evaluates and displays results inline.

* Pressing the Enter key. This evaluates and displays results on the next line and centered.

+ Right-click (Control-click for Macintosh) the input to invoke a context menu item. From the context menu, select

Evaluate and Display Inline. See Context Menus (page 32) for more details.

» Using the Edit menu items Evaluate and Evaluate and Display Inline.

Toolbar Options

The Maple toolbar offers several buttons to assist you when interacting with Maple. See Table 1.2.

Table 1.2: Maple Toolbar Options

Basic Usage Icon Equivalent Menu Option or Command

Create a new Maple document B From the File menu, select New
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Basic Usage

Equivalent Menu Option or Command

Open an existing document or worksheet

From the File menu, select Open...

Save the active document or worksheet

From the File menu, select Save...

Print the active document or worksheet

From the File menu, select Print...

Print preview the active document or worksheet

From the File menu, select Print Preview...

Cut the selection to the clipboard

From the Edit menu, select Cut

Copy the selection to the clipboard

From the Edit menu, select Copy

Paste the clipboard contents into the current document
or worksheet

From the Edit menu, select Paste

Undo the last operation

From the Edit menu, select Undo

Redo the last operation

From the Edit menu, select Redo

Insert the Code Edit Region

From the Insert menu, select Code Edit Region

Inserts plain text after the current execution group.

From the Insert menu, select Text.

Inserts Maple Input after the current execution group.
For details, refer to Execution Groups (page 15).

From the Insert menu, select Execution Group and then
After Cursor.

Encloses the selection in a subsection. For details,
refer to Sections (page 231).

b
1]

il | w3l || 2 o< | | W (D8 |G |E

From the Format menu, select Indent.

Removes any section enclosing the selection.

N
I}

From the Format menu, select Qutdent.

Move backward to previous document in the hyperlink

history «

Move forward to next document in the hyperlink =

history.

Executes all commands in the worksheet or document m From the Edit menu, select Execute and then Worksheet.

Executes a selected area.

From the Edit menu, select Execute and then Selection.

Interrupt the current operation.

Debug the current operation

Clears Maple's internal memory. For details, refer to
the restart help page.

Enter restart.

Add and edit Maple code that is executed each time
the worksheet is opened. For details, refer to the
startupcode help page.

From the Edit menu, select Startup Code.

Adjusts the display size of document content. Note:
plots, spreadsheets, images, and sketches remain
unchanged.

From the View menu, select Zoom Factor and then a zoom
size.

Toggle entry of tab characters with Tab key
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Icon Equivalent Menu Option or Command
From the View menu, select/clear Clickable Math to
enable/disable Smart Popups and Drag-to-Solve.

Basic Usage
Enables or disables the Smart Popups and =
Drag-to-SolveTM features in Clickable Math™. For
details, refer to Clickable Math (page 160).

Opens the Maple help system. For details, refer to The ) From the Help menu, select Maple Help.

Maple Help System (page 43).

For 1-D Math and text regions, the Tab icon in the toolbar allows you to set the Tab key to move between placeholders
(or cells in a table) or to indent text.

Table 1.3: Tab Icon Description

Tab Icon Description
Tab icon off. Allows you to move between placeholders using the Tab key.

23

Tab icon on. Allows you to indent in the worksheet using the Tab key.

Text

The Tab icon is disabled when using 2-D Math (Math mode), and as such, the Tab key allows you to
move between placeholders.

Toolbar icons are controlled by the location of the cursor in the document. For example, place the cursor at an input
region and the Text and Math icons are accessible while the others are dimmed. See Table 1.4 for a list of the tools

available in each icon.

Table 1.4: Toolbar Icons and their Tools

Toolbar Icon Options
Text tools

Math Drawing Plat Animation

':\ [: Text Vf:' ':\ Tirmes Mewe Roman Vf:' ':\ 12 V’:' B I g = = % = EE
Math tools

Text Drawing Plot Animation
i N w Y [ — —_— 1
% [ 20 Input ¥ | Tirmes Mew Roman ol ¥ B I Q = = ‘ % =i

Drawing tools

Text Math Plot Animation
s 2T\0000 BHIGEEIE X
2-D Plot tools

Text Math Dirawing Animation

By - 1 [&C- N O HHE

3-D Plot tools

Text Math Dirawing Animation

9 = [ s Wl o f“v@'hl'@k@vﬂlh

Animation tools

Text Math Drawing Plot

I4 @ [» P[] CurrentFrame |1 Jiﬂbv = e Fps |10 ;@ ‘@ b*f\';v
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Table 1.5: Toolbar Icon Availability

Region Available Tools

Input region Text and Math icons

Plot region Drawing and Plot icons

Animation region Drawing, Plot, and Animation icons
Canvas and Image regions Drawing icon

The Text and Math icons allow you to enter text and math in the same line by choosing the appropriate input style at
each stage when entering the sentence.

The derivative of sin(x) is cos(x).

For an example, see Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons (page 25).

Using the tools available in these icons, you can customize the input style of the text and 2-D Math. For the Text and
Math icons, the icon that is selected remains in that state until prompted otherwise; therefore, if the Text icon is selected
and you press the Enter key, the new input region remains a Text region.

The Text and Math icons differ while at a Maple input prompt. The Math icon displays input as 2-D Math, whereas
the Text icon displays Maple input. For details, refer to Math Mode vs. Text Mode (page 15).

2
X
>_
2

> x72/2;

To access the tools available in the Plot and Drawing icons, click a plot region. These tools allow you to manipulate
the plot or draw shapes and enter text on the plot region. By clicking an animation region, you have the same features
available for a plot region, in addition to tools for playing the animation in the Animation icon. For details on plots
and animations, refer to Plots and Animations (page 187).

For the remaining icons, hover the mouse over the icon to display the icon description.
Context Menus and Copy & Drag

Context Menus

Maple dynamically generates a context menu of applicable options when you right-click an object, expression, or region.
The options available in the context menu depend on the selected input region. For example, you can manipulate and
graph expressions, enhance plots, format text, manage palettes, structure tables, and more. When using context menus
to perform an action on an expression, the input and output are connected with a self-documenting arrow or equal sign
indicating the action that had taken place. For more information, see Context Menus (page 32).

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new input region. This is done by highlighting
the input or selecting the curve and dragging it with your mouse into a new input region. Dragging the highlighted region
will cut or delete the original input. To prevent this, use the copy and drag feature.

* Ctrl + drag, Windows and UNIX

* Command + drag, Macintosh

That is, highlight the region you want to copy. Press and hold the Ctrl key while you drag the input to the new region
using the mouse. The steps are the same for Macintosh with the exception of pressing the Command key.
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Example 2 - Solve and Plot an Equation Using Context Menus and Copy & Drag

Review the following example:
S5x—7=3x+2

In this example, we will enter the equation and then solve and plot the equation using context menus and Maple's copy
& drag feature. This example will only refer to the keystrokes needed on a Windows operating system to invoke the
context menus and the copy & drag feature. For your operating system, refer to section Shortcut Keys by

Platform (page xiii) for the equivalent keystrokes.

To solve the equation:
1. Enter the equation.

2. Right-click the equation and select Move to Left.

Input:

Sx—T=3x+2

Copy Special ]
Paste Chrl+y

Ewvaluate and Display Inline Chrl4+=
Explore

Apply & Command

Differentiate ¥
Ewaluate at & Point

Integrate ]
Left-hand Side

Manipulate Equation

Map Command Onka

Mowe ko Left

Mave ka Right %
Megate Felation

Flots »
Right-hand Side

SinpliFy ]
Solve ¥

Tesk Relation

Canversions [
Integral Transforms »
Sequence ]
2-0 Math ]
Result:
move to left

5x—7=3x+2 —— 2x—9=0

A brief description, "move to left" is displayed above the arrow that connects the input and output.
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3. Right-click the output from the previous action, 2x — 9 =0, and select Solve — Isolate Expression for — x.

Input:
Sy—T=3y42 move to lett
Result:
move to left
5x—7=3x4+2 ———> 2x—9=

2x—9=0

0

isolate for x 9
_—

Copy Special

Mumeric Farmatting...
Explore

Apply a Command
Differentiate
Evaluate at a Paoint
Integrate

Left-hand Side
Manipulate Equation
Map Caormand Onto
Move bo Right
MNegate Relation
Plots

Right-hand Side
Simplify

Solve

Test Relation

Conwersions
Inkeqgral Transforms

Sequence

Isnolate Expression For » x
Mumerically Solve %
Murmerically Solve (wfcompla:)

Mumerically Solve From point

Dbkain Solutions Far ]

Solve

Solve (explicit)

Solve (general solution)

Solve For Variable ]
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Now that we have solved the equation, we can plot it. To do this, we will copy the equation 2x — 9 = 0 to a new document block
and use context menus again.

4. From the Format menu, select Create Document Block.

5. To copy the expression 2x — 9 = 0, highlight only this expression from the previous result. Press and hold the Ctrl key and
drag the expression to the new document block region.

Result:

to left 1s0late fi
Sx—T=3x4 grevelolefl o g okt forx 2

to left 1s0late fi
5x—7=3x+2%2x—9=0mx=%

to left 1z0late fi
5x—?=3x+2%2x—9=ﬂmx=%

> 2x—9=1

—=

PR 2
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To plot the expression:

6. Right-click the equation, and select Left-hand Side.

Input:
2x—9=0
Result:
2x—9=0

7. Right-click the expression and select Plots — 2-D Plot.

left hand side
_—

Copy Special
Paste

Evaluate and Display Inline Ctrl+=

Explore

Apply a Command
Differentiate
Evaluate at a Point
Integrate

Left-hand Side
Manipulate Equation
MMap Command Onko
Mave ka Right
Megate Felation
Flots

Right-hand Side
SinpliFy

Solve

Tesk Relation

Canversions
Integral Transforms
Sequence

2-D Math

2x—9

Chrl+y

s



14 + 1 Getting Started

Input:

2x—9

Copy Special »
Paste ChrlY

Evaluate and Display Inline Ctrl+=

Explore

Apply a Command
Assign bo a Marme
Coefficients ¥
Collect »
Differentiate ¥
Ewaluate at & Point

Factor

Integrate ]
Lirnit
Flots

Series

2-D Plat

3-D Plot (]
2-D Implicik Plat »
3-0 Implicit; Plot »
Plot Builder

SinpliFy

- v v v

Solve

Complex Maps
Canstructions
Canversians

Integer Functions
Integral Transforms
Language Conversions
Optimization

Sequence

Sorts

Urits

* T T T F T ¥ ¥ ¥ ¥

2-D Math ¥
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Result:
2x—9 —

10

Saving a Maple Document

To save these examples you created, from the File menu, select Save. Maple documents are saved as .mw files.

1.3 Entering Expressions

Execution Groups

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large
square bracket, called a group boundary, at the left. An execution group may also contain any or all of the following:
a plot, a spreadsheet, text, embedded components, and a drawing canvas.

Execution groups are the fundamental computation and documentation elements in the document. If you place the
cursor in an input command and press the Enter or Return key, Maple executes all of the input commands in the
current execution group.

Math Mode vs. Text Mode

The default mode of entry in Document or Worksheet mode is Math Mode, which displays input in 2-D Math. In
earlier releases of Maple, commands and expressions were entered using Maple Input or 1-D Math.

Important: With Maple input, you must terminate commands with a semicolon or colon.

> cos (alpha)“*2+sin(alpha)*2;

cos(on)2 + sin(oc)2
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> a*int (exp(sqrt(2) *x) ,x) ;

Safz el

> limit (f(x) ,x=infinity) ;

lim_ f(x

X— 00

)

> sum(al[k]*x*k, k=0..m)=product(b[j]*x*j, j=0..n);

In Document Mode, to enter input using Maple Input mode, insert a Maple prompt by clicking [* in the toolbar, and
then click the Text button in the toolbar. In Worksheet Mode, simply click the Text button. See Figure 1.2.

Plot Animation

Drawing

[ C 2pmath

) (1 *)

¥ | | Times Mew Roman

Figure 1.2: Text and Math Buttons on the Toolbar

Table 1.6: Math Mode vs. Text Mode

Math Mode

Text Mode

Maple's default setting. Executable standard math notation.
This is also referred to as 2-D Math Input.

>Jx2+2x+ldx

%XS +x2+x

Executable Maple notation. This is also referred to as 1-D
Math Input or Maple Input.

>int (x*2+2*x+1, x);

%x3 -|—x2 +x

Access from the Insert — 2-D Math menu.

Access from the Insert — Maple Input menu.

When using 2-D Math, the Math mode icon is highlighted in the

toolbar, Text

When entering Maple Input or text in a text region, the Text mode

icon is highlighted in the toolbar, Math

In Document Mode (or a document block), input is entered in a

document block with a slanted cursor, < L

In Document Mode (or a document block), input is entered with
a vertical cursor, as plain text, | >< Enter some text .

In Worksheet Mode, input is made at an input prompt with a

slanted cursor, |:> [ .

In Worksheet Mode, input is made at an input prompt with a

vertical cursor, I::’ | .

To convert a 2-D Math expression to 1-D Math, right-click the
expression (Command-click, Macintosh) and select 2-D Math
— Convert To — 1-D Math Input.

To convert a 1-D Math expression to 2-D Math, right-click the
expression (Command-click, Macintosh) and select Convert To
— 2-D Math Input.

No termination symbol is required.

All input must end with a semi-colon ( ; ) or a colon ( : ).

Palettes make entering expressions in familiar notation easier
than entering foreign syntax and reduces the possibility of
introducing typing errors.

W Expression
b

[fdx—]%f-cbr——?'[fdx

Using palettes while in 1-D Math teaches you the related Maple
command syntax.

W Expression

b

[fd.x ._]Lf-gor——’[} int{f, x);
@

If you prefer 1-D Math input, you can change the default math input notation.
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To change math input notation for a session or globally across all documents:
1. From the Tools menu, select Options. The Options Dialog opens.

2. Click the Display tab.

3. In the Input Display drop-down list, select Maple Notation.

4. Click the Apply to Session or Apply Globally button.

Important: The new input display becomes the default setting after pressing the Enter key.

Palettes

Palettes are collections of related items that you can insert into a document by clicking or drag-and-dropping. The

Maple environment provides access to over 30 palettes containing items such as symbols ( ), layouts (Ab ), mathem-
b
atical operations U f de, and much more.

a

By default, palettes are displayed in the left pane of the Maple environment when you launch Maple. If the palettes
are not displayed,

1. From the View menu, select Palettes.
2. Select Expand Docks.
3. Right-click (Control-click, Macintosh) the palette dock. From the context menu, select Show All Palettes.

Alternatively, from the main menu, select View — Palettes — Arrange Palettes to display specific palettes.

You can create a Favorites palette of the expressions and entities you use often by right-clicking (Control-click,
Macintosh) the palette template you want to add and selecting Add To Favorites Palette from the context menu.
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Table 1.7: Palette Categories

Palette Category

Palette Description

Expression Palettes

W Matriz
Rowas: 2
Calurnins: 7

| Choose... |

Type: | Custom valuss * |

Shape: (Any v
Datatype: (Any ¥ )
| Insert Matrix

MapleCloud - view worksheets shared by other users and share your worksheets.
Variables - manage all of your assigned variables in your current Maple session.
b
Fdx

Expression - construct expressions such as integrals -z

Matrix - enter the number of rows and columns required, designate type, such as zero-filled,
and designate shape, such as diagonal.

Layout - add math content that has specific layout, such as expressions with one or more

h
superscripts and subscripts

Components - embed graphical interface components such as a button into your document
or worksheet. Components can be programmed to perform an action when selected such as

executing a command when a button is clicked .

Handwriting - an easy way to find a desired symbol.

Units (SI) - insert a unit from the International System of Units (SI), or any general unit
[x2] .

Units (FPS) - insert a unit from the Foot-Pound-Second System (FPS), or any general unit
2]

——
Accents - insert decorated names, such as an x with an arrow over it to denote a vector 4 .

Favorites - add templates that you use most often from other palettes.
Live Data Plots - templates for visual representation of your data.

eBook Metadata - markup tags for use when creating eBooks from Maple worksheets
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Palette Category

Palette Description

Mathematical Palettes

W Comman Symbals

Palettes for constructing expressions

Common Symbols,

Relational = "

Teij I w
3! I d NU Relational Round =,
e A Operators =,
£ jé B Large Operators %,
= a=s 2 Negated 7,
N@ 3dJV - A Fenced {{ ,
Vyy=CRN Arrows 7>,
QF R 5= | Constants and Symbols <0 .
4 — x f 4 Punctuation - insert punctuation symbols, such as inserting the registered trademark and
F o 5 V copyright symbols © into text regions
' X b ? Miscellaneous - insert miscellaneous math and other symbols outside the above categories
7.
Alphabetical Palettes Greek,
Script A,
W Greek 9
ABTAE Z Fraktur l,[:
Open F ,
He I KAM pen a;;
o Cyrillic A\,
NZOMNPZX Y
e an Diacritical Marks *
I TY & X V¥
5 Roman Extended Upper Case A,
Q o B v & Roman Extended Lower Case & .
e N oo 1
K x A uv g
O mwwpoeao
STV O Y
VoW

Viewing and Arranging Palettes

By default, palettes display in palette docks at the right and left sides of the Maple window. To view and manage
palettes and palette docks, see Table 1.8.



20 + 1 Getting Started

Table 1.8: Managing Palettes

To view palette docks: Migw  Insert  Format
+ From the View menu, select Palettes, and then Expand || Mext Tab ¢ TI>
Docks. There are docks on the far right and left of the Previous Tah
i Animation
window. v Toalbar
v Context Bar an v)lz~) B
v Status Bar
Markers

Task Elements

Slideshiow

Palettes » Arrange Palettes. .,
Zoom Fackor p Show Palette 3
Typesetting Rules. ., Show all Palettes
Show/Hide Contents. ., Shows Defaulk Palettes

Header Fodter... Expand All Palettes

Collapse all Palettes

Expand Docks
Expand All Sections Collapse Dacks
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To add a palette: Remove Palethe |

1. Right-click the palette dock. Maple displays a context Showi Palette j Favorites
menu near the palette. Showe All Palettes MaplaCloud
‘Variables
2. From the context menu, select Show Palette and then Show Default Palettes _
Expression
select the palette. Expand all Palettes :
I Pl Matrix
C All Palekt
ollapse &ll Palettes Lavout
Expand Docks Compaonents
Collapse Docks Handwriting
Units {30}
Arrange Palettes. ., ,
Units (FPS)
In(a)
Accents
a) cosla)
Roman Extended Upper Case
. Roman Extended Lower Case
| fla,b)
Diacritical Marks
h] — Greek
Cyrillic
r=a 1 Setipk
t=a 1 Open Face
Fraktur

Common Symbals
Relational
Relational Round
Operators

Large Operators
Megated

Fenced

Arrows
Constants and Symbals
Punctuation
Miscellaneous

puppy
DocBook Metadata
Dataset Plaks

test
Tasks

LLEEEREREELL

To expand or collapse a palette in the palette dock:

LEBSE Xl o

* Click the triangle at the left of the palette title.

'Tl:aavor_ites_ | [1:
A
DB e
—
o® 4 ' -
| W Expression
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To move a palette in the palette dock:

palette to the new location.

* Move the palette by clicking the title and dragging the

T 4

W Favarites | el

A

Sfdx o

TEE e

—

oe® 4 ' -

i[bExpression |

[b Zommon Symbols . |

To expand or collapse the palette docks:

side of the palette region.

 Select the appropriate triangle at the top right or top left

OL2BaS&S «& 2¢
: | W Favorites \

[ro %
e ®

W Expression

1A
v
jj

o

g

Example 3 - Enter an Expression Using Palettes

Review the following example:

10

> (72 —5i) = 2420
i=1

10

In this example, we will enter Z (7 2 —5i ) and evaluate the expression.

i=0

Action

Result in Document

1. Place the cursor in a new document block. In the Expression palette,

n

2

click the summation template =k . Maple inserts the summation
symbol with the range variable placeholder highlighted.

>
=k

2. Enter i and then press Tab. The left endpoint placeholder is selected. s
Notice that the color of the range placeholder has changed to black. E f

Each placeholder must have an assigned value before you execute the

expression. The Tab key advances you through the placeholders of an|j = f

inserted palette item.

3. Enter 1 and then press Tab. The right endpoint placeholder is selected.

4. Enter 10 and then press Tab. The expression placeholder is selected. | 10
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Action Result in Document

5. Enter (7 iP—5s i). For instructions on entering this type of expression, 10
see Example I - Enter and Evaluate an Expression Using E ( 7 1.2 — 5 I)

Keystrokes (page 5). i
E =
6. Press Ctrl + = (Command + = for Macintosh) to evaluate the 10

summation. 2
2(71' — 5i> = 2420

i=1

Handwriting Palette

The Handwriting palette provides another way to find and insert desired symbols easily.
1. Draw the symbol with your mouse in the space provided.

T
2. Click the recognize button, =

See Figure 1.3.

|. Maple matches your input against symbols available in the system.

3. To view more symbols (where indicated with a box around the result), click the displayed symbol and choose one
of the selections from the drop-down menu.

4. To insert a symbol, click the displayed symbol.

W Handwriting

| Input Window... |

Figure 1.3: Handwriting Palette
For more information, refer to the handwritingpalette help page.

Snippets Palettes

You can create your own custom Snippets palettes for tasks that you find most useful. Details on how to create and
customize Snippets palettes can be found on the createpalette help page.

Symbol Names

Each symbol has a name and some have aliases. By entering its name (or an alias) in Math mode, you can insert the

symbol in your document. All common mathematical symbols, including all Greek characters, &, and the square root

symbol (\/_ ), are recognized by Maple.

Note: If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.
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To insert a symbol, enter the first few characters of a symbol name using a keyword that is familiar to you and then
press the completion shortcut key, Esc (see Shortcut Keys by Platform (page xiii)). Symbol completion works in the
same way as command completion (see Command Completion (page 39)).

 Ifaunique symbol name matches the characters entered, Maple inserts the corresponding symbol.

 If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches,
including commands. To select an item, click its name or symbol.

Example 4 - Square Root

To find the square root of 603729:

Action Result in Document
1. In a new document block, enter sgrt. S_fld

2. Press the symbol completion shortcut key, Ese. Maple |
displays a pop-up list of exact matches.
sqrk: agrt
<] [»

3. In the completion list, select . Jr

Maple inserts the symbol with the x placeholder selected.

4. Enter 603729. V 603729
5. Press Ctrl + = (Command + =, Macintosh). 603720 = 777

Example 5 - Complex Numbers

When you simply type the letter i in Math mode, it is in italics. This letter is just a variable, and is not the same as the

imaginary unit y/ -1, denoted by I or i in Maple.

Multiply two complex numbers, -0.123 + 0.7451 and 4.2 — i:

Action Result in Document

1. Inanew document block, enter (-0.123 + 0.745i.| ( -0.123 + 0_745;51'

2. Press the symbol completion shortcut key, Esc. (-0.123 + 0.745 3

Maple displays a pop-up list of partial and exact i {imaginary) i
matches, including symbols and commands. acute il
ic i
icir i
icontent feonfent(p)
iconkent irontett
icnsahedran {location ploffools [Icosahedron | [x, 0, 2])
icosahedron location, scale)  ploffosls [icosahedron (1,1, 21 1) .V
£ i | [

3. Select the imaginary unit, [EiliEEiEE] (-0.123 + 0,745 ll

4. Close the parentheses, enter a space (for implicit | (-0.123 + 0.7451) (4.2 — i)
multiplication), and type the second expression in
parentheses, using symbol completion for the
second imaginary number.

5. Press Ctrl + = (Command + =, Macintosh) to | (-0.123 + 0.7451) (4.2 — i) = 0.2284 + 3.25201
evaluate the product.

For more information on entering complex numbers, refer to the HowDol help page.
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Toolbar Icons

In the introduction section, you learned about the toolbar icons and context toolbars available in Maple (see Toolbar
Options (page 6)). The toolbar can be used to format your document, alter plots and animations, draw in a canvas,
write in both Math and Text modes in one line and much more. The last of these is demonstrated in the next example.

Example 6 - Enter Text and 2-D Math in the Same Line Using Toolbar Icons

Enter the following sentence:

5

3
Evaluate J (3 2+ 2\/? + 3\/? ) dx and write in simplest terms.

1

Action Result in Document
To enter this sentence: : ) Math  Dra
1. Select the Text icon and enter Evaluate. (T — )
Z Evalﬁaté[
2. Select the Math icon. S C) _
3. From the Expression palette, select the definite { C 20 math -
. . 4 L Ewaluate [ Fdx
integration template, "z . The expression is Al e
displayed with the first placeholder highlighted.
4. With the first placeholder highlighted, enter 1, thenpress | 1.4 T
Tab.
(_ C 2o math )
5. Enter 5 and press Tab to highlight the integrand region. V — :
Evaluate [ Fdx
Al 'l
6. Enter (3x”2 and press the right arrow to leave the Text e
superscript position. r— = . com
7. Enter + 2. V — =i e
Evaluate [ iR+ 2 dx
et 1
8. Press the Space bar for implicit multiplication. Enter S pramna Biat
sqrt and press Esc to show the command completion | _
options. Maple displays a pop-up list of exact matches. | & 22 Math S/ Nl Aol
Select the square root symbol, Jx. Maple inserts the
symbol with the x placeholder selected. Alternatively, A Esthiate L 3+ 2 de =
select the square root symbol from the Expression
pa]ette_
9. Enter x, then press the right arrow to leave the square T Drawing. | Blat -
root region. .
[ C 2o math ¥ | [ Times New Roman ¥
10. Enter + 3, and then press the Space bar. V o e e e
11. Select the n-th root symbol from the Expression palette, Ewahiate [ G324 2 Jr + 3”5 da
= 1
Va
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Action Result in Document
12. Enter 3, then press Tab. o DG i e
13. Enter x), then press Tab. I:\. C 20 Math Times Mew Roman )

b -

14. Enter x for the integration variable. 5""'3'
Evaluate[ (3X2+ 2z + 3\.!?} dx
Al 1
15. Click the Text icon in the toolbar, then enter the rest of Math  Drawing  Plot  Animation
the sentence: "and write in simplest terms." p w pp—
b L Text ¥ )| _Times Mew Roman v/l v B ru
Y 5
Ewaluate I+ 2y x + 3 x ) dx and wnite in simplest terms.
Fay 1

1.4 Point-and-Click Interaction
Maple contains many built-in features that allow you to solve problems quickly without having to know any commands.

Assistants

Maple offers a set of assistants in the form of graphical user interfaces to perform many tasks without the need to use
any syntax. An example of an assistant is shown in Figure 1.4.

Optimization Assistant
Solhver Problem
() Local Defaut Objectivs Furetion
-
X -y
) Honlneas
Constrants and Bounds
[xe[0,3]
ye[05]
RORCE x+y=<é
" Minimize (2) Maximize
Feashiity Tolerance defauk

v [ )

Ohjective valus: 134.491161539748162
Cptimalkty Tolerance dei 2k % = 4.53559292539129

¥ = 1.46440707460871

Tteration Limk defouk
Infinite Bound defaut
On Quk, Return | Sokution ] [ Heip [ Sobve || Por | qut |

Figure 1.4: Optimization Assistant

Using the Tools — Assistants menu, you can access tools to help you accomplish various tasks. See Figure 1.5. In
some cases, you can launch an assistant by entering an expression and selecting the assistant from the context menu
that displays.
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Tools  Window  Help
fssistants
Tutors
Tasks
Dermonstrations

Load Package
Unload Package

Spellcheck, .
Carmplete Command

Help Database

Options...

Figure 1.5: Accessing the Assistants from the Tools Menu

F7
Chrl+Space

r

Back-Solver...
Curve Fitting...

Daka Analysis, .,

Equation Manipulatar. .,

Import Data...
DocBoak. ..
Installer Builder...
Library Browser. ..
MMaplet Builder. ..
ODE Analvzer...
Optimizatian. ..
Plot Builder. ..

Scientific Constants, ..

Special Functions. ..

Units Calculator, .

Waorksheet Migration, ..

CAD Link. ..
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Example 7 - Curve Fitting Assistant

Enter a data sample and use the Curve Fitting Assistant to find the best approximation of a function to fit the data.

Action Result in Document

1. From the Tools menu, select Assistants — Curve Fitting.
The first dialog in the Curve Fitting Assistant appears. M| Curve Fitting Assistant @

Enter data points below

Independent Values (x) Dependent Values (f{x]))

Current Page (1 Previous Page Mext Page

[ Fit H Clear H Import J I Help H Cancel I

2. Enter data as Independent Values and Dependent Values.
Alternatively, you could import a file containing data. If you M Curve Fitting Assistant =]
have more data than the space provided, click the Next Page
button for more space. For this example, enter the data as
shown.

Enter data points below
Independent Values (x) Dependent Values (f(x))
-1 -0.176777

-0.0494194

a

-0.44194

-0.176777

-0,397743

-0.707107

-1,104854

L= BT, R - i FC R R =]

Current Page (1 Previous Page Mext Page

[ Fit H Clear H Import J I Help H Cancel I
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Action Result in Document
3. Once you have entered the data, click the Fit button. The | (G cmermngamn =
second dialog of the Curve Fitting Assistant appears.
s ° e e e [
04 [e]
e}
] spi
os ’j Plot
o X +b Plot
Done EditPoints | On Done'retun Inerpolant Help. Cancel
4. In this dialog, you can plot the data and several types of 3 Curve Fiting Assistat =)
interpolations, including Polynomial, Spline, and Least |
Squares. For example, click the Plot button in the
quynomlal lnterpolat.lon secthn. The po.lyn(.)mlgl is plotted i~ [Loent ]
with the data, and the interpolating function is displayed
below.
Degree of the spline: U Plot
N e
Enter an expressioninx: |2 +b [Lpot ]
(Cene__| [ EdEPons ] on Done'returm [ipaant . (Crep] (o)
5. You can choose to return either the interpolating function 0.002762122808 %7 + 0.04971820957 x5 — 0.3259304755 15
or the plot to your document. When finished, click Done. ’ * ’ * ’ *
+0.8949276991 x* — 0.665671371 x> — 0.9888404085 x* + 1.082752470;
—0.044194

Descriptions of Assistants

The remaining assistants are described below. Some of the assistants are interfaces to package commands. For more
information on package commands, see Package Commands (page 38).

Back-Solver - an interface that allows you to take a mathematical formula, involving multiple parameters, enter
values for all but one of the parameters and solve for the remaining value. You can also plot the behavior of the
formula as one of the parameters change.

Curve Fitting - an interface to commands in the CurveFitting package. Data points can be entered as independent
and dependent values, and interpolated with polynomials, rational functions, or splines.

Data Analysis - an interface to the data analysis commands in the Statistics package.

Equation Manipulator - an interface for interactively performing a sequence of operations on an equation. You
can group terms, apply an operation to both sides of the equation, complete the square, and so on.

Import Data - an interface to read data from an external file into Maple.
eBook Publisher- an interface to the eBook Publisher tools.

Installer Builder - an interface to the InstallerBuilder package in which you can create installers for your Maple
toolboxes.

For information on toolboxes, go to http://www.maplesoft.com/developers/index.aspx.
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* Library Browser - an interface to manipulate the libraries in a specified directory.

* Maplet Builder - an interface to the Maplets package. The Maplets package contains commands for creating and
displaying Maplet applications (point-and-click interfaces). Using the Maplet Builder, you can define the layout of
a Maplet, drag-and-drop elements (visual and functional components of Maplets), set actions associated with elements,
and directly run a Maplet application. The Maplet Builder is available in the Standard interface only.

* ODE Analyzer - an interface to obtain numeric or symbolic solutions to a single ordinary differential equation
(ODE) or a system of ODEs and plot a solution of the result.

* Optimization - an interface to the solver commands in the Optimization package. The Optimization package is a
collection of commands for numerically solving optimization problems, which involves finding the minimum or
maximum of an objective function possibly subject to constraints.

* Plot Builder - an interface for creating two and three-dimensional plots, animations, and interactive plots.

* Scientific Constants - an interface to over 20 000 values of physical constants and properties of chemical elements.
All of these constants come with the corresponding unit and, if applicable, with the uncertainty or error, that is, how
precisely the value of this constant is known.

* Special Functions - an interface to the properties of over 200 special functions, including the Hypergeometric,
Bessel, Mathieu, Heun and Legendre families of functions.

« Units Calculator - an interface to convert between 500 units of measurement.

* Worksheet Migration - an interface to convert worksheets from Classic Maple (.mws files) to Standard Maple
(.mw files)

* CAD Link - an interface to explore the properties of models from supported CAD applications (available on Microsoft
Windows only)

Tutors

Maple provides over 40 interactive tutors to aid in the learning of
* Precalculus

* Calculus

* Multivariate Calculus

* Vector Calculus

* Differential Equations

* Linear Algebra

* Complex Variables

These tutors are easily accessible in the Tools menu by selecting Tutors. See Figure 1.6.
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Tools “Window  Help

Assistants L PP - [ - @
Tutars p  Calculus - Mulkivariate  »
Tasks b Zaleulus - Single Yariable »
i Complex variabl b = = = 1—
Demonstrations omplex wariables = = g] = EZ
Pk Differential Equations  »
L P ] -
DT dac E: Linear Algebra ¥ Eigenweckar Plot...
L P ] )
ninarl PAckage Murnerical Analysis y  Eigervalues...
Spellcheck, . F7 Precalculus ¥ Eigenweckors,..
Complete Command veckor Calculus p|  Gauss-Jordan Elimination. ..
Help Database » Gaussian Elimination...
Linear Syskem Flat...
Options...

Linear Transform Plat...
Matriz Builder. ..
Matrix Inverse. ..

Linear Syskem Solving. ..
Figure 1.6: Accessing Tutors from the Tools Menu

Some of the tutors can also be accessed through the Student package. The Differential Equations tutor, DE Plots, is
accessible through the DEtools package. For a definition of the term package, see Package Commands (page 38).

The Student package is a collection of subpackages designed to assist with the teaching and learning of standard un-
dergraduate mathematics. The subpackages contain many commands for displaying functions, computations, and the-
orems in various ways, and include support for stepping through important computations.

The interactive commands help you explore concepts and solve problems using a point-and-click interface. These
commands launch tutors that provide a graphical interface to some of the visualization and computation commands
described above. See for an example of one of the tutors.
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alcuius - inrrerentiation Methods o~
%] Calculus 1 - Differentiation Method 3
File Edit Rule Definition Apply Rule  Understood Rules  Help
Enter a function
Funckion | 2%:x+cos(x))sindx) Variable | x
d [ cos(x) W]
dx sin(x) )
d d
By g c?s(x) W
dx dx | sim(x) )
= d d [ cosi(x) ]
=2 [Ex] el 7] shows s
gy i ( costa) )
dx | sie(x)
%cos(x)] sini(x) -cos(x) [Esm(xﬂ
= o = [ Constant ][ Identity ]
iRX
: AR
-5in°x - cas(x) [—sz’n(x) _
= dx [ Sum ][ Cifference ]
szx [ Product ][ Quatient l
el 2
_g oy SSx-cosTx [ Power |[  chainkue |
.S‘mzx [ Integral ” Resrite l
[ Exponential ][ Makural Logarithm ]
| =trig= | <hyperbalic= _'v
-<arctrig> '.v_czarch\,fperbnliczb i
[ Undo ] [ Mext Skep ] [ All Skeps ] [ Close ]

Figure 1.7: Calculus - Single Variable — Differentiation Methods Tutor

Math Apps

Maple provides Math Apps that offer interactive, entertaining ways to explore precalculus concepts. The demonstrations
are accessible in the Tools menu by selecting Math Apps.

For more information on the tutors, demonstrations, and related resources for mathematics education, see Teaching
and Learning with Maple (page 148).

Context Menus

A context menu is a dynamically generated menu of actions that are applicable for the region upon which it is invoked.
Context menus allow you to perform calculations and manipulations on expressions without using Maple syntax. To
display a context menu, right-click an object, expression, or region. Context menus are available for many input regions,
including:

* expressions to perform calculations, manipulations, or plotting
* plot regions to apply plot options and manipulate the plot

« tables to modify the table properties

* palette regions to add or remove palettes and palette regions

* text regions to add annotations and format text

* spreadsheets to manipulate the spreadsheet
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When performing calculations or manipulations on an expression, a self-documenting arrow or equal sign connects
the input and output, indicating the action that took place. See Figures 1.8 and 1.9 for two examples of context menus.

Copy Special ]
Paste Chrl4Y

Evaluate and Display Inline  Ctrl+=
Explore

Apply & Command

Assign ko a Mame

Coefficients »
Collect »
Combine »
Differentiste 3
Evaluate at a Paoint cut Chrleie
Fackar
Copy e+
Inkeqgrate ] .
o Copy full precision
Limik:
Plats ]
. Paste Chrl+Y
Series 4
Sirnplify ] Skyle » Lins
Solve »  Isolake Expression for » Symbal s Faint %
Mumerically Solve ) P,
Complete Squars » _ Line p| # Surface with Line
Mumerically Solve {wfcomplex) surf
Complex Maps b ) ) Color 4 urrace
Mumerically Solve from point ;
Constructions » Transparency »  Surface with Contour
Obtain Solutions For ] )
Conversions b Glossiness »  Conbour
Solve % Hidd
Inkeger Functi » ientati idden
! egerl unc |Fons Salve (explict) Orientation ]
Ink T ] ighti
reegral franstorms Solve {general solution) Lighting '
L C i ]
SngUAgS Lomversions Solwe For Yariable 4 Aves »
Optimization ]
Sequence ] Title ’
Sorke » Scaling Constrained
Hnits » Manipulator »
2-D Math » Expart ,
Figure 1.8: Right-click the expression to see a menu of Figure 1.9: Right-click the plot to see a menu of plot options

applicable operations

Task Templates

Task templates help you perform specific tasks in Maple, such as:

» performing a mathematical computation such as solving an equation symbolically or numerically, or determining
the Taylor approximation of a function of one variable

* constructing a Maple object such as a function

* creating a document such as an application

Each task contains a description along with a collection of content that you can insert directly into your document.
Content consists of 2-D mathematics, commands, embedded components (for example, buttons), and plots. You specify
the parameters of your problem and then execute the commands in the document. See Figure 1.10 for an example of
a Task Template.
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@ Browse Tasks

=)

File  Wiew

-3 Algebra

[#-{5) Calculus - Differential

=i Caleulus - Inkegral

1[5 Inkegration

E}E} Approzimate Integration

Approximate Definite Integral of a Function
Murneric Inkegration

{7 Methods of Integration

I Applications

|7 Seties

[#+{7) Caleulus - Multivariate

[F-{T) Caleulus - Vectar

----- Convert Expression ko Funckion

[#-{7) Curve Fitting
[#-+{=) Differential Equations
[#+{=) DacBook Metadata
[#+7=) Dacument Templates
[#-{7) Evaluating
[+ 7) Geometry
#-{7) Integers
[#-{_7) Linear Algebra
(-3 Lists

F-{7) Maple T.4.
[#-{_7) Plots

[#-{_2) Polynomials
[+ 7) Statistics
[#-{_2) Transformations

[#-{7) Units, Constants, and Errors

4
)[ Copy Task to Clipboard ][ Insert Default Content ]

[ Insert Minimal Content ] [] Insert into Mew Worksheet

[] Display task markers

Y Approximate Definite
Integral of a Function

Description

Approximate the definite integral of a
univariate function using a Riemann sum or
a Newton-Cotes method.

Enter the function as an expression.

2
>x +2
P42 (L
Specify the range of integration and the method

of approximation, and then approximate the
integral

> Student| Calculus 1| Approximateint|( (1),
x=0 2 7, method= trapezoid)

L r(100+677) 2
55 T T 2)

>

Alternatively, you can use the Approximate
Integrals tutor, a point-and-click interface.
There are two ways to launch this tutor.
* From the Tools menu, select Tutors,
Calculus - Single-Variable and then
Approximate Integrals. [+

< i | [#]

Task, ApproxDefIntegrallnivariateFon

Figure 1.10: Browse Tasks Dialog

Previewing Tasks

To preview Maple tasks,

* From the Tools menu, select Tasks, and then Browse. The Browse Tasks dialog opens and displays the list of tasks.

The tasks are sorted by subject to help you quickly find the desired task. In the Browse Tasks dialog, you can view
tasks without inserting them into your document.

Inserting a Task into the Document

To insert a task into your document,
1. Select the Insert into New Worksheet check box to insert the task into a new document.

2. Click one of the insert buttons.
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* Click the Insert Default Content button. Maple inserts the default content. The default content level is set using
the Options dialog. For instructions, see the usingtasks help page.

* Click the Insert Minimal Content button. Maple inserts only the commands and embedded components, for example,
a button to launch the related assistant or tutor.

* Click the Copy Task to Clipboard button. Place the cursor where you want to insert the task, and then paste the
task. Maple inserts the default content. Use this method to quickly insert a task multiple times.

Note: You can view the history of previously inserted tasks. From the Tools menu, select Tasks. Previously selected
task names are displayed below the Browse menu item.

Before inserting a task, Maple checks whether the task variables have assigned values in your document. If any task
variable is assigned, the Task Variables dialog opens to allow you to modify the names. Maple uses the edited variable
names for all variable instances in the inserted task.

By default, the Task Variables dialog is displayed only if there is a naming conflict. You can set it to display every
time you insert a task.

To specify that the Task Variables dialog be displayed every time you insert a task:
1. From the Tools menu, select Options.

2. Click the Display tab.

3. In the Show task variables on insert drop-down list, select Always.

4. Click Apply to Session or Apply Globally, as necessary.

Updating Parameters and Executing the Commands

In inserted Task Templates, parameters are marked as placeholders (in purple text) or specified using sliders or other
embedded components.

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the
next placeholder by pressing Tab.

2. Execute all commands in the task by:

Placing the cursor in the first task command, and then pressing Enter repeatedly to execute each command.

Selecting all the template commands, and then clicking the execute toolbar icon [ .

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the tasks help page.

Exploration Assistant

The Exploration Assistant allows you to interactively make parameter changes to expressions and view the result. The
assistant can be used with almost any Maple expression or command that has at least one variable or parameter.

To launch the Exploration Assistant:
1. Enter an expression or command.
2. Right-click (Control-click, Macintosh) the expression or command. From the context menu, select Explore.

3. The Explore parameter selection dialog appears, where you can select the parameters to explore and the range for
each parameter.

If you enter integer ranges, only integer values are allowed for parameters. To allow floating-point values, enter floating-
point ranges.

Select skip for any of the parameters to leave that parameter as a variable.
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4. Click Explore to continue to the Exploration Assistant. The assistant creates a table in the document . You can
use the slider or sliders to vary the parameters and see your changes as the expression output is updated.

5. Once you are finished interacting with the assistant, you can copy and paste the results into your document, or save
the interactive document for later use.

Example 8 - Use the Exploration Assistant to Explore a Plot

sin(ax) — bcos(x)

In this example, we will explore how the plot of changes as we vary the parameters a and b.

X
Action Result in Document
1. Enter the plot command shown. i —
p plot[ sin(ax) - b cos(x) x=1 ..IOJ
2. Right-click (Control-click for Macintosh) . y
the expression and select Explore. ;?.for[ sin(ax) — b-cos(x) e=1 __10]
1 " :

Copy Special »
Paste Chrl+y

Evaluate and Display Inline Chrl+=

Explore %

Apply a Command

Assign ko a Name

Conwersions ]

Language Conwversions ]
Help on Command

2-0 Math ]

3. Inthe Explore parameter selection dialog,
set the ranges a =0..10.0 and b =-5.0..5.0. 3 Explore
Select floating-point computation.

a: 0 . (10,0 [ skip
b: 50 .. |5.0 [ skip

Floating-poink computation
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Action Result in Document

4. Click Explore. The Exploration Assistant =
creates a table in the document. Move the " [
sliders to see the plot as the parameters . |I ||
change. N || | ,‘ﬂ'u Il

A WA f\\

1.5 Commands

Even though Maple comes with many features to solve problems and manipulate results without entering any commands,
you may find that you prefer greater control and flexibility by using the set of commands and programming language

that Maple offers.

The Maple Library

Commands are contained in the Maple library, which is divided into two groups: the main library and packages.

The main library contains the most frequently used Maple commands.

Packages contain related commands for performing tasks from disciplines such as Student Calculus, Statistics, or
Differential Geometry. For example, the Optimization package contains commands for numerically solving optimiz-

ation problems.

For details on top-level and package commands, see Commands (page 63).

Entering Commands

If you want to interact with Maple using commands, simply enter the command using 2-D math. Notice that commands
and variable names display in italics. Maple commands are constructed in a format similar to command(arguments),

based on the command you are using.

For example, to factor an expression, enter:

factor(x2 +2x+ 1)
(x + 1)

To differentiate an expression, enter:

diff (sin(x), x)

cos(x)
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To integrate an expression on the interval [0,2 7], enter:
int(2x + cos(x),x=0.27)

4 n2
To plot an expression, enter:
plot( sin(x) xz,x =-10 ..10)

60
40

20 A

_20 -

_40 -

-60 -

For a list of the top commands in Maple, see Top Commands (page 64).

Package Commands

There are two ways to access commands within a package, using the long form of the package command or the short
form.

Long Form of Accessing Package Commands:

The long form specifies both the package and command names using the syntax package|command](arguments).

LinearAlgebra[ RandomMatrix](2)

92 67

44 —31]

Short Form of Accessing Package Commands:

The short form makes all of the commands in the package available using the with command, with(package). If you
are using a number of commands in a package, loading the entire package is recommended. When you execute the
with command, a list of all commands in the package displays. To suppress the display of all command names, end
the with(package) command with a colon. Alternatively, you can load packages through the Tools menu, by selecting
Load Package, and then the package name.
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with( Optimization)
[ ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve ]

After loading a package, you can use the short-form names, that is, the command names, without the package name.

LSSolve([x —2,x — 6,x — 9])
[12.3333333333333322, [x = 5.66666666666666696] ]

For a list of the top packages in Maple, see Top Packages (page 66).

Command Completion

To help with syntax and reduce the amount of typing when entering Maple commands, you can use command completion.
Command completion displays a list of all Maple packages, commands, and functions that match the entered text. If
there are multiple ways to call a command, then the command completion list contains each one, with appropriate
placeholders.

To use command completion:

1. Begin entering a command or package name.

2. Select Tools — Complete Command or use the shortcut key Esc (see Shortcut Keys by Platform (page xiii)). If
there is a unique completion, it is inserted. Otherwise, a list of possible matches is displayed.

3. Select the correct completion from the list.

Linear,

Linearalgebra A [l
Linearalgebraladd] {inear combination) Linaar Algabra [Add |(Mul, Mul)
LinearalgebralAdd] (inear combination, with scalars and constructor options)  DinearAlgebra [Add (v, v2, x1, x2
Linearalgebraladd] {inear combination, with scalars) Lineardlgabra | Add (Mol Mol xi, 22
Linearalgebraladd] {inear combination, with scalars, construckor options, and overnwrite) Trneardlgabra | Add (v
LinearAlgebralAdjoint] {square Matrix) IinearAlgabra | Adicinf 1 M)
LinearAlgebralAdjoint] {square Matrix, with constructor options) Lineay Algabra [ Adicing | M, oufpufopfions = s
LinearAlgebra[Backwardsubstituke] (upper rov-echelon) Linaar Algabra | BackwardSuhstada (M)
LinearAlgebra[Backwardsubstituke] (upper rov-echelon) Linaay Algabra | BackwardSuhstisada | (M, M)
LinearAlgebra[Backwardsubstituke] (upper rov-echelon, with options and overwrite) Iineardlgabra | Backwardiy
LinearAlgebra[Backwardsubstituke] (upper rov-echelon, with options) Irneardlgabra | Backwardiubsifute |00, v, |
| inearalnehral FandMatriz1 (From sralarsh Tinsardicahral Bondifamiv i fel v2 11 [

4. Some inserted commands have placeholders, denoted by purple text. The first placeholder is highlighted after you
insert it into the document. Replace it with your parameter, then move to the next placeholder by pressing the Tab

key.
Equation Labels
Equation labels help to save time entering expressions by referencing Maple output. See Figure 1.11.

By default, equation labels are displayed. If equation labels are not displayed,

1. From the Tools menu, select Options, and click the Display tab. Ensure that the Show equation labels check box
is selected.

2. From the Format menu, select Equation Labels. Ensure that both Execution Group and Worksheet are selected.
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] '\‘sin(x) i ]

% —cos(x) I
—sm(x) (5]

[

Figure 1.11: Equation Label

To apply equation labels:

1. Enter an expression and press Enter. Note that the equation label is displayed to the right of the answer in the doc-
ument.

2. In a new execution group, enter another expression that will reference the output of the previous execution group.

3. From the Insert menu, select Label. Alternatively, press Ctrl+L (Command+L, for Macintosh) to open the Insert
Label dialog. Enter the label number in the Insert Label dialog and click OK. The item is now a label. See
Figure 1.12.

‘sin(x) dr ]
% ) - cos(x) (L)
N ‘ fdx

Insert Label
Type: Equation v
Identifier: |1
I OF l [ Cancel

Figure 1.12: Inserting an Equation Label

4. Press Enter to obtain the result.

To change the format of equation labels:

* Select Format — Equation Labels — Label Display. In the Format Labels dialog, select one of the numbering
schemes.

» Optionally, enter an appropriate numbering prefix.
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b T
sin(x) dx ct
A —cos(x) {(Answerl)
]
[(Answerl) dx
e
—sm(x) (Answerl)
Format Labels
Label Mumbering Prefiz | Answer|
Label Mumbering Scheme | Flat Mumeric w
[ oK ] [ Cancel

Figure 1.13: Format Labels Dialog: Adding a Prefix

The Label Reference menu item allows you to switch between the label name and its reference content. Place the
cursor on the referenced equation label and select Format — Equation Labels — Label Reference.

~ IFE A
- —cos(x) I

)
Z _[—cns(x) dx

—sm(x) (4]

Figure 1.14: Label Reference

The label is associated with the last output within an execution group.

You cannot apply equation labels to the following:
* Error, warning, and information messages

» Tables, images, plots, sketches, or spreadsheets

Document Blocks

In Document mode, content is created as a series of document blocks. Document blocks allow you to hide the syntax
used to perform calculations, which in turn lets you focus on the concept presented instead of the command used to
manipulate or solve the problem. You can also create document blocks in Worksheet mode to perform the same function.
Document blocks are typically collapsed to hide the Maple code, but these regions can also be expanded to reveal this
code.

To create a document block:

From the Format menu, select Create Document Block. If text or math in one or more execution groups is selected,
then a document block is created that contains those execution groups. If not, a new document block is created after
the current execution group. For more information, see the next example.

Document block regions are identified using markers that are located in a vertical bar along the left pane of the document.
See Figure 1.15. In addition to document block boundaries, these markers (icons) indicate the presence of hidden at-
tributes in the document such as annotations, bookmarks, and numeric formatting.
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To activate markers:

From the View menu, select Markers. See Figure 1.15.

L C 20math * | | Times Iew Roman ) (12

e -
AP+ 10x+ 21 = fx=—3), {x=—T)

Figure 1.15: Document Block Markers

To view code in a document block:
1. Place the cursor in a document block to be expanded.

2. From the View menu, select Expand Document Block.

‘ k G 20 math ¥ | | Times [Mew Roman .20 e '.J.' B H

v[} 4+ 10x+ 21

2 L0 B L

)

Figure 1.16: Expanded Document Block

With the Document Block expanded, you can see the Maple command that was used to perform this calculation. In
Figure 1.16, the solve command was used.

Also notice a red prompt (>) before the original expression and the solve command. Entering commands outside of a
document block region is done at this input region. To insert an input region, click the [> button in the toolbar menu.

In Figure 1.16, an equation label was used to refer to the expression. For more information, see Equation
Labels (page 39).

To collapse a Document Block:

* With your cursor inside the document block, select View — Collapse Document Block.
You can use this process of expanding document blocks to view and edit Maple commands within a document block.
Changing the Display:

You can specify which parts of the input and output are displayed when the document block is collapsed. For each
execution group in the block, you can choose to display either the input or the output.

* Place the cursor in the execution group.

* From the View menu, select Toggle Input/Output Display.

Also, you can choose to display output either inline or centered on a new line.

* From the View menu, select Inline Document Qutput.

Example 9 - Creating a Document Block in Worksheet Mode

In Worksheet mode, you can create the content using commands, and then use a document block to choose how much
information to display.
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Enter the following sentence using text and 2-D Math input and output:
The answer to Jsin(x) dx is -cos(x).
1. At an input prompt, click the text icon, 25 , to enter plain text. |:The answer to
Enter "The answer to ". Note: these instructions are for Worksheet
mode.
2. Click the input prompt icon, [>, to enter Maple commands. Enter [The answer to
Jsin(x) dx, and then press Enter to execute the command. > “sjn(x] dx
L _ —coz(x) (1.3
| >
3. Again, click the text icon to insert the rest of the text, "is", and [The answer to
then enter another input prompt icon. Make sure to put spaces . ix
around all of the text, so the sentence displays properly. = ) sin(x)
L —coz(x) (1.3
| is
g
4. To display the same output again, use the value command and an [The answer ta
equation label. This allows you to insert text between the input ror. ix
and output of a single command: there are really two commands. > ‘ sin(x)
L —cos(x) (1.3)
Enter and execute the command, as shown. s
> vake((1.3))
L —coz(x) {1.4)
| =
5. To finish the sentence, click the text icon in the last execution The answer to
group and enter a period. =} (. (x) dr
sinx
L - —cos(x) (1.3
| is
> vale((1.3))
L —coz(x) {(1.4)
6. Select the entire sentence, then from the Format menu, select, | =7
The answer to
Create Document Block. By default, only the text and output
. . . —cos(x) {1.3)
remains visible, and output is centered on a new line. s
—cos(x) (1.4)
A. .
7. To display the text and output on one line, place the cursor in the| % The answer to — cos(x) is —cos(x).
document block. From the View menu, select Inline Document ' '
Output.
8. To dlsplay.lnput instead of ot}tput for the ﬁrsf expression, place The answer to J sin(x) d is -cos(x) .
the cursor in the first expression. From the View menu, select
Toggle Input/Output Display. Only the first region displays
input.

1.6 The Maple Help System

The Maple program provides a custom help system consisting of almost 5000 reference pages. The help system is a

convenient resource for determining the syntax of Maple commands and for learning about Maple features.
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Accessing the Help System

There are several ways to access the Maple help system:

* From the Help menu, select Maple Help

+ Click BB in the toolbar

To get help on a specific word:

* In a document, place the insertion point in a word for which you want to obtain help. From the Help menu, select
Help on .... Alternatively, press F2 (Control + ?, for Macintosh) to access context-sensitive help.

* In a document, execute the command ?topic, for example, enter ?LinearAlgebra and press Enter

The Maple help system opens in a separate window with two panes. The left pane contains the Help Navigator where
you initiate searches and browse the table of contents, and the right pane displays the final search result, such as a

specific help page.
@itaple 14 Help - [hate] =okd
Fie 0@ Yew FHetory Help
CI R -
y A

Forl (%) Tager () Test
fwiha

l‘wﬂiﬂ
Table of Corterts | Seach Bieilts.
& Gty Rarted
L What's N
# Creats Magle Wortshesty
& ) Thare Maple WorkaPeets
& Cumtorze i Mapls Wirdos
& T Cusbornze B Maple Syileen
# ) Correcty
= I Maheeabey

B ) igetes

& ) Banic Maiematoy

& ) Caouka

& ) Caloul of Waritons

Search |

W

~

w»

»

Figure 1.17: Sample Help Page

fsolv

¥ Calling Sequence
fsolvel oquations variables, complex )

¥ Parameters
equations ANIOR, S {igudnion, E(EreLiion, I8V Epednion, [unapuanion), prochdre, [ procaduedl
wariables - (optional ) mawe of sarvncwer, unlmonns for which 1o solve
complex - {eptional) Bieral nows, search for complex. solotions

4

¥

Y Basic Information

'€ . selve one of mere equations eiag Noating polst arithm etic

Description

* The fsolve command memerically comgutes the zerees of ene or more equations, expressions of procedures

Output

* The selunions 1 3 eagle equaton We retumed i i expreision soquence

* The selutions te 2 set or list of equations are rerarned 28 sets of equation sequences.

+For asisgle polynomial equasion of one variable with real coefSicients, by default the {solve command computes afl real (non-complex)
reats. [t may ned return alll roots for exceptionally il -cenditioned pelymemials

*For a siagle polynomlal equation of sne vaniable with some (son-real) complex coefficiants, the fuolve command computes ol real and
complex roots. It may not returs Al rocts for excepsonally il -conditioned polvmemials

*For a geeaal eqeation or sysiom of equasons, the fsolve command computes 2 sngle real root

¥ Examples

4

|

A Polynomial Equation in One Variable
For aumivariate real pohmomial equaticon, the (solve command computes all real solutiona
[> pobmomial =26 = 112" = 14 + 126 = 4x=0

> foodviel podymomial)

=1334383488 0, 5929212004 L)

Other Equations

For mere comphicaned equations, the (selve command compuies one real solusicn

L= polnomials = (3 =17, Py = sy = 2y=1)
> frolvel polynominls)
(x= 2108200038 y= 0 3303328603 | (4.2.1)
F> Joodve tan | sin(x) ) = 1)
08033391108 (423
- &l

LA S [ - .

Every help page in Maple lists the command's calling sequence, parameters, and a description, with examples of the
command at the end of the page. Some help pages also contain hyperlinks to related help pages and hyperlinks to dic-
tionary definitions. Hyperlinks to help pages display in green, while hyperlinks to dictionary definitions display in dark

red.
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Using the Help Navigator

The Help Navigator contains a field for topic or text-based searches. The Table of Contents tab provides a structured
list of all topics in the help system.

To search the help system:
1. In the left pane, enter a string in the search field.
2. By default, a topic search is performed. To perform a text search, select the Text radio button.

3. Enter the term and click Search.

» Topic searches reveal a list of matching topics sorted by the precision of the match.
» Text searches reveal a list of topics based on keyword frequency.

* You can search all of the help system or specific Resources such as Help Pages, Tasks, Tutorials, and Manuals by
selecting the Resources drop-down menu.

Search results are displayed as a list in the Search Results tab of the left pane. Click the Table of Contents tab to
view a structured list of all topics in the help system.

To display potential matches in the right pane, click a topic preceded by an icon. Table 1.9 describes the different
icons.

Table 1.9: Help Page Icons

Icon Description

A folder icon in the Table of Contents tab indicates that a topic can be expanded into subtopics.

Question mark icon indicates a help page and displays the associated help page in the right pane when selected.

WS icon indicates an example worksheet. Example worksheets open in a new tab in the Maple document.

D icon indicates a definition and displays the associated dictionary definition in the right pane when selected.

T icon indicates a Task template and displays the associated Task Template in the right pane when selected.

M icon indicates a manual. Manuals open in a new tab in the Maple document.

=== |# =L

Viewing Help Pages as Documents
In the help system, examples are not executable.
The Maple help system allows you to open help pages as documents that you can execute.

To open a help page as a document or worksheet:

» With the help page displayed in the right pane of the help system, from the View menu, select Open Page as
Worksheet. A new worksheet tab opens and displays the help page as an executable document.

ﬁ Alternatively, in the help system toolbar, click the open current help page in a worksheet window icon.

Viewing Examples in 2-D Math

You can choose to view the examples in most help pages in either 1-D Math (Maple input) or 2-D Math mode. The
default is 1-D Math.
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To change the math mode:

In the Maple help system:

* From the View menu, select or clear the Display Examples with 2D math check box.

X"2
¢ Click the 2-D Math icon, ¥x 2.

Note: Some input in help pages displays as 1-D Math, no matter which option you have chosen. This is for Maple
procedures and other code that is best input in 1-D Math. For more information, see the helpnavigator help page.

Copying Examples

Instead of opening the entire page as a document, you can copy the Examples section only.

To copy examples:

1. With the help page displayed in the right pane of the help system, from the Edit menu, select Copy Examples.
. Close or minimize the Help Navigator and return to your document.

2
3. In your document, place the cursor at the location where you want to paste the examples.
4

. From the Edit menu, select Paste. The Examples section of the help page is inserted as executable content in your
document.

1.7 Available Resources

Your work with Maple is supported by numerous resources.
Resources Available through the Maple Help System

Help Pages

Use the help system to find information about a specific topic, command, package, or feature. For more information,
see The Maple Help System (page 43).

Dictionary

More than 5000 mathematical and engineering terms with over 300 figures and plots.

1. From the Help menu, select Maple Help.

2. Enter a search term. Dictionary entries that match your query are displayed in the left pane with a (o] icon.

Tutorials and the Maple Portal

The Maple Portal includes material designed for all Maple users, from new users to users who want more advanced
tutorials. The Maple Portal also includes specific sections for students, math educators, and engineers. The Maple
Portal includes:

* How Do I... topics that give quick answers to essential questions

* Tutorials that provide an overview of topics from getting started to plotting, data manipulation, and interactive ap-
plication development

» Navigation to portals with specialized information for students, math educators, and engineers

Access the portal from the Help menu (Help — Manuals, Resources, and More — Maple Portal).
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Applications and Example Worksheets
Applications

Sample applications demonstrate how Maple can be used to find and document a solution to a specific problem. Some
applications allow for input or contain animations that you can run; however, their primary use is for demonstrations.
Topics include DC Motor Control Design, Digital Filter Design, Frequency Domain System Identification, Harmonic
Oscillator, Image Processing, and Radiator Design with CAD Systems.

Examples

Example worksheets are executable documents covering topics that demonstrate syntax or invoke a user interface to
make complex problems easy to solve and visualize. You can copy and modify the examples as needed. Topics include
Algebra, Calculus, Connectivity, Discrete Mathematics, General Numerics and Symbolics, and Integral Transforms.

* From the Help menu, select Manuals, Resources, and more, and then Applications and Examples.
Manuals

You can access all of Maple's manuals from within Maple, including the Maple Programming Guide and this manual.
You can execute examples, copy content into other documents, and search the contents using the Maple Help System.

* From the Help menu, select Manuals, Resources, and more and then Manuals.

Task Templates

Set of commands with placeholders that you can use to quickly perform a task. For details, see Task Templates (page 33).
¢ From the Tools menu, select Tasks, and then Browse.

Maple Tour and Quick Resources

Maple Tour

The Maple Tour consists of interactive sessions on several of the following topics: Ten Minute Tour, Numeric and
Symbolic Computations, Matrix Computations, Differential Equations, Statistics, Programming and Code Generation,

Units and Tolerances, and Education Assessment with Maple TA™
* From the Help menu, select Take a Tour of Maple.
Quick Help and Quick References

The Quick Help dialog is a list of key commands and concepts.

* From the Help menu, select Quick Help. Alternatively, press F1. For additional information, click an item in the
Quick Help.

The Quick Reference is a table of commands and information for new users that opens in a new window. It contains
hyperlinks to help pages for more information.

* From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2 (Command + F2, for Macintosh).
Web Site Resources

Welcome Center

A Maple web site offering all of Maplesoft's key user resources in one central location. In the Welcome Center, you
can view sample applications, participate in user forums, access exclusive premium content, and listen to podcasts.
You can also access our support services, view training videos, download user manuals, and more.

http://www.maplesoft.com/welcome
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Student Help Center

The Student Help Center offers a Maple student forum, online math Oracles, training videos, and a math homework
resource guide.

http://www.maplesoft.com/studentcenter
Teacher Resource Center

The Teacher Resource Center is designed to ensure you get the most out of your Maple teaching experience. It provides
sample applications, course material, training videos, white papers, e-books, podcasts, and tips.

http://www.maplesoft.com/teachercenter
Application Center

Maple web site resource for free applications related to mathematics, education, science, engineering, computer science,
statistics and data analysis, finance, communications, and graphics. Many applications are available in translations
(French, Spanish, and German).

You can also search for Education and Research PowerTools, which provide free course curricula and are available
as add-on Maple packages and courses. PowerTools are developed by experts in their fields to help users configure
Maple for research in specific application areas.

http://www.maplesoft.com/applications
Training

Maplesoft offers a comprehensive set of complementary training materials. From complete training videos to recorded
training seminars to downloadable documentation, you have many options to get familiar with Maplesoft products. In
addition, whether you are an expert or someone who is considering a new license purchase, a custom training session
that is right for you and/or your organization can be created.

http://www.maplesoft.com/support/training
MaplePrimes

A web community dedicated to sharing experiences, techniques, and opinions about Maple and related products, as
well as general interest topics in math and computing.

http://www.mapleprimes.com

Online Help

All of Maple's help pages are available online.
http://www.maplesoft.com/support/help
Technical Support

A Maple web site containing FAQs, downloads and service packs, links to discussion groups, and a form for requesting
technical support.

http://www.maplesoft.com/support

For a complete list of resources, refer to the MapleResources help page.
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2 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems
in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-
modify interactive documents. You can also devise custom solutions using the Maple programming language. While
you work, you can document your process, providing text descriptions.

2.1 In This Chapter

Section Topics

Introduction (page 49) * Comparison of Document and Worksheet Modes

Entering Expressions (page 50) - Overview of tools for creating |* Palettes

complex mathematical expressions « Symbol Names

¢ Mathematical Functions

Evaluating Expressions (page 52) - How to evaluate expressions |* Displaying the Value Inline

 Displaying the Value on the Following Line

Editing Expressions and Updating Output (page 53) - How to  |* Updating a Single Computation

update expressions and regenerate results + Updating a Group of Computations

» Updating All Computations in a Document

Performing Computations (page 53)- Overview of tools for * Computing with Palettes

performing computations and solving problems « Context Menus

¢ Assistants and Tutors

2.2 Introduction

Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then
evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of
Document mode.

Document mode sample:

Find the value of the derivative of ln(x2 + 1) at x=4.

differentiate w.r.t. x 2x evaluate at point 8
In(x* 4 1) : 8
x +1 17

Integrate sin( ij over the interval [0, 7].
X

rsin(ich dr = sin(;Jn—Ci(;]

0

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The
Worksheet mode supports the features available in Document mode described in this chapter. For information on using
Worksheet mode, see Chapter 3, Worksheet Mode (page 61). Note: To enter a Maple input prompt while in Document

mode, click [* in the Maple toolbar.

49
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Important: In any Maple document, you can use Document mode and Worksheet mode.

Interactive document features include:

» Embedded graphical interface components, like buttons, sliders, and check boxes
* Automatic execution of marked regions when a file is opened

 Tables

 Character and paragraph formatting styles

* Hyperlinks
These features are described in Chapter 7, Creating Mathematical Documents (page 221).

Note: This chapter and Chapter 1 were created using Document mode. All of the other chapters were created using
Worksheet mode.

2.3 Entering Expressions

Chapter 1 provided an introduction to entering simple expressions in 2-D Math (see Entering Expressions (page 15)).
It is also easy to enter mathematical expressions, such as:

-x x<0
» Piecewise-continuous functions: [x{=4{ 0 x=0

x 0<x
* Limits: 6(x) = limoelxl6 -1

€ —
* Continued fractions: \/7 =1+ ! 1
2+ "
2
+ 24 ..

and more complex expressions.
Mathematical expressions can contain the following objects.

* Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, i, o, ...

0
. . - | . 1 _—
Operators: +, -, ./, -, J, thna, FRRRE

* Constants: T,e, ...
» Mathematical functions: sin(x), cos( %), r(2), ..

* Names (variables): x,y,z, o, f, ...
 Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding
key, for example, 9, =, >, or x. Most symbols are not available on the keyboard, but you can insert them easily using
two methods, palettes and symbol names.

Example 1 - Enter a Partial Derivative

To insert a symbol, you can use palettes or symbol names.
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o 2
Enter the partial derivative o C * using palettes.

Action

Result in Document

1. In the Expression palette, click the partial
d

derivative. The variable placeholder is selected.

ad

differentiation item @z ! . Maple inserts the partial dx

2. Enter t, and then press Tab. The expression
placeholder is selected.

ﬁf

3. Enter eﬁ2 . Note: To enter the exponential e, use
the expression palette or command completion.

o -7

—e
ot

To evaluate the integral and display the result inline, press Ctrl+= (Command-+=, for Macintosh) or Enter. For more

information, see Computing with Palettes (page

53).

You can enter any expression using symbol names and the symbol completion list.

Action Result in

Document

1. Begin typing the name of the symbol, | 7.4
diff, and press the symbol completion
key (see Shortcut Keys by

Platform (page xiii)). [—

diff@@

diffalg

<

diff {inline partial)

diff _table (Function and derivatives)
diff_table (representation of function and derivatives)  DETools [dff table |(expr |

diffop2de (differentisl operatar)

PDEfols [dff table ](expr)

DETools [diffop2de |1 oper, » | V:
>

AFEE

diffalz

2. Select the partial differentiation item,

a 6x

diff {inline partial) W

3. Replace the placeholder with t. Use the tz
right arrow to move out of the 0 -

denominator. Enter c{t2 as in the 01
previous example.

Example 2 - Define a Mathematical Function

Define the function twice, which doubles its input.

Action

Result in Document

1. In the Expression palette, click the single variable

function definition item, fma—y

f=a—y

2. Replace the placeholder f with the function name,
twice. Press Tab to move to the next placeholder.

twicg =@ — ¥

3. Replace the parameter placeholder, a, with the
independent variable x. Press Tab.

twice == x — ¥

4. Replace the output placeholder, y, with the desired
output, 2 x.

twice '= x = 2x

x—2x




52 + 2 Document Mode

twice(1342) = 2684
twice(y —z) =2y —2z

Note: To insert the right arrow symbol — , you can also enter the characters -> in Math mode. In this case, symbol
completion is automatic.

Important: The expression 2 x is different from the function x — 2 x.

For more information on functions, see Functional Operators (page 266).

2.4 Evaluating Expressions

To evaluate a mathematical expression, place the cursor in the expression and press Ctrl + = (Command + =, for
Macintosh). That is, press and hold the Ctrl (or Command) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.

27 _8

9 " 11 99
You can replace the inserted equal sign with text or mathematical content.

To replace the equal sign:
1. Select the equal sign. Press Delete.

2. Enter the replacement text or mathematical content.

For example, you can replace the equal sign with the text "is equal to".

2 7 . 85
9 + T is equal to 99

In mathematical content, pressing Enter evaluates the expression and displays it centered on the following line. The
cursor moves to a new line below the output.

T

2
9+11

85

% @.1)

By default, Maple labels output that is generated by pressing Enter. For information on equation labels, see Equation
Labels (page 75). In this manual, labels are generally not displayed.

In text, pressing Enter inserts a line break.

You can use the basic algebraic operators, such as + and —, with most expressions, including polynomials—see
Polynomial Algebra (page 113)—and matrices and vectors—see Matrix Arithmetic (page 127).

2 —x+1) = (P +2x+12) =¥ —3x—11

—4 8 99
27 69 29

-12 24 297
81 207 87
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2.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are /ive. That is, you can edit expressions and quickly recalculate
results.

To update one computation:
1. Edit the expression.

2. Press Ctrl + = (Command + =, for Macintosh) or Enter.
The result is updated.

To update a group of computations:
1. Edit the expressions.

2. Select all edited expressions and the results to recalculate.
3. Click the Execute toolbar icon [ .

All selected results are updated.

To update all output in a Maple document:

* Click the Execute All toolbar icon IIf.

All results in the document are updated.

2.6 Performing Computations

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning
Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:
* Palettes
» Context menus

¢ Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also supports Maple commands. For information
on commands, see Commands (page 63) in Chapter 3, Worksheet Mode (page 61).

Important: In Document mode, you can execute a statement only if you enter it in Math mode. To use a Maple command,
you must enter it in Math mode.

Computing with Palettes

As discussed in Entering Expressions (page 50), some palettes contain mathematical operations.
To perform a computation using a palette mathematical operation:

1. In a palette that contains operators, such as the Expression palette, click an operator item.

2. In the inserted item, specify values in the placeholders.

3. To execute the operation and display the result, press Ctrl+= (Command+=, for Macintosh) or Enter.
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0 _p2
For example, to evaluate o C * inline:

1. Using the Expression palette, enter the partial derivative. See Example 1 - Enter a Partial Derivative (page 50).
2. Press Ctrl+= (Command+=, for Macintosh).

0 2

2
¢
——e

ot

=-2te

Context Menus

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See
Figure 2.1.

11
+TI

o |2

Copy Special ]
Paste Chrl+Y

Evaluate and Display Inline Chrl+=

Explore

Apply a Command

Approximate ]
Assign ko a Name

Drenaominator

Mumerator
Mare... ]
2-D Math ]

Figure 2.1: Context Menu

To display the context menu for an expression:

* Right-click (Control-click, for Macintosh) the expression.
The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus. The Evaluate and Display Inline operation (see Figure 2.1) is
equivalent to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an equal sign (=) and then the value
of the expression.

Alternatively, press Enter to evaluate the expression and display the result centered on the following line.
For more information on evaluation, see Evaluating Expressions (page 52).

From the context menu, you can also select operations different from evaluation. To the right of the expression, Maple
inserts a right arrow symbol (—) and then the result.

t 10 digit
For example, use the Approximate operation to approximate a fraction: % L, 0.6666666667

You can perform a sequence of operations by repeatedly using context menus. For example, to compute the derivative

of cos(x2 ), use the Differentiate operation on the expression, and then to evaluate the result at a point, use the Evaluate
at a Point operation on the output and enter 10:

7\ differentiate w.r.t. x evaluate at point
cos(x ) ) x—

-2 sin(x2

-20sin(100)
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The following subsections provide detailed instructions on performing a few of the numerous operations available using
context menus. Figures in the subsections show related context menus or palettes.

Approximating the Value of an Expression

To approximate a fraction numerically:
1. Enter a fraction.
2. Display the context menu. See Figure 2.2.

3. From the context menu, select Approximate, and then the number of significant digits to use: 5, 10, 20, 50, or 100.

| b2

Copy Special »
Paste Chrl+y

Evaluate and Display Inline Chrl+=
Explore

Apply a Command

Approzimate P =
Assign ko a MName

Cienominator 2
Murnaratar 50
More... p| 100
2-0 Math ]

Figure 2.2: Approximating the Value of a Fraction

2 at 10 digits
it N

3 0.6666666667

You can replace the inserted right arrow with text or mathematical content.

To replace the right arrow ( — ):
1. Select the arrow and text. Press Delete.

2. Enter the replacement text or mathematical content.
Note: To replace the right arrow with text, you must first press F5 to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol ~=.

is approximately equal to 0.6666666667

w o

= 0.6666666667

W

Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information
on symbolic and numeric computations, see Symbolic and Numeric Computation (page 80).
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To solve an equation:
1. Enter an equation.
2. Display the context menu. See Figure 2.3.

3. From the context menu, select Solve or Numerically Solve in the Solve menu item.

Tx° X

—_ =12

3 n
Copy Special »
Paste ChrlY

Evaluate and Display Inline Ctrl+=

Explore

Apply a Command

Approxirmate ]
Combine ¥
Cross Multiply

Differentiate ¥
Ewaluate at & Point

Integrate ]
Left-hand Side

Manipulate Equation

Map Command Onka

Mowe ko Left

Mave ka Right

Megate Felation

Flots »
Right-hand Side
SinpliFy ]
Solve p  Isolate Expression For »
Test Relation Murmerjcally Solve
Mare... ¥ Turmeritally Solve From poink
Dbtain Solutions For »
2-0 Math ]
Solve

Solve (explicit)
Solve (general solution)
Solve For Wariable »

Figure 2.3: Finding the Approximate Solution to an Equation

12 x solve 3 1+ J1+1127° 3 14141120
Rt EE b x= -

14 T ’ 14 oL

7 xz X solve

— — =12 — -2.200603126, 2.337021648
T

For more information on solving equations, including solving inequations, differential equations, and other types of
equations, see Solving Equations (page 86).

Using Units

You can create expressions with units. To specify a unit for an expression, use the Units palettes. The Units (FPS)
palette (Figure 2.4) contains important units from the foot-pound-second (FPS) system of units used in the United
States. The Units (SI) palette (Figure 2.5) contains important units from the international system (SI) of units.
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w Urits (FPS)
[zrit] 2]
[s] [powundal]
[
ﬂpoundfome‘ [

inch®
[HP] [[poundal ]
[rad] [sr]1

Figure 2.4: FPS Units Palette

W Units (51}
[zerit] [ ] [s1
[~ [kegl [P=]

I#1 [71 [£]
I71 [A] [¥]
[c1 [« 7]

[#] [rad] [sr]
[moi] [x]  [im]
[s1 [#e] [Ap] |

Figure 2.5: SI Units Palette

To insert an expression with a unit:
1. Enter the expression.

2. In a unit palette, click a unit symbol.
Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:
1. Enter the expression using the units palettes to insert units.
2. Right-click (Control-click, for Macintosh) the expression.

3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.

590[C]  simplify units
2.9[s]

203.4482759 [A]

For more information on using units, see Units (page 99).

Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. For details on as-
sistants and tutors, see Point-and-Click Interaction (page 26).

Assistants and tutors can be launched from the Tools menu or the context menu for an expression. For example, you
can use the Linear System Solving tutor to solve a linear system, specified by a matrix or a set of equations.
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Example 3 - Using a Context Menu to Open the Linear System Solving Tutor

Use the Linear System Solving tutor to solve t

he following system of linear equations, written in matrix

1 3 0 -2 -1
4 2 -1 5 7
form:
0-3 5 4 -7
1 -1 3 6 5
Action Result in Document

1. In a new document block, create the matrix or set
of linear equations to be solved.

1 3 0 -2 -1
4 2 -1 5 7
0-35 4 -7
1 -13 6 5

2. Load the Student[LinearAlgebra] package. From
the Tools menu, select Load Package — Student
Linear Algebra. This makes the tutors in that
package available. For details, see Package
Commands (page 38).

Loading Student:-LinearAlgebra

3. Right-click the matrix and select Tutors — Linear
Algebra — Linear System Solving.... The Linear
System Solving dialog appears, where you can
choose the solving method. Gaussian Elimination
reduces the matrix to row-echelon form, then
performs back-substitution to solve the system.
Gauss Jordan Elimination reduces the matrix to
reduced row-echelon form, where the equations
are already solved. For this example, choose
Gaussian Elimination.

(%] Linear Algebra - Linear System Solving

[ Gaussian Elimination |[ Gauss Jordan Elimination ]

Cancel

4. The Gaussian Elimination dialog opens. You can
specify the Gaussian elimination step-by-step, or
you can use the Next Step or All Steps buttons to
have Maple perform the steps for you.

5. Once the matrix is in row-echelon
(upper-triangular) form, click the Solve System
button to move to the next step.

iz "t
E Linear Algebra - Gaussian Elimination
Fil= Edit Help
1 -8 67 3|4 - System Solver -
14 5 34 10| 2 Click on any button to
apply a row operation
;10 8 23(-10
Add multiple
4 2 17 13/ -5 ¢ .
1 il timas
row 1 V add to
raw 2 v
Add
Multiphy
2 v times
row 1 v
[ Mulkiphy
Swap
row 1 v with
" Edit Matrix | Solve System row 2 ]
[ Undao ” MNexkt Step ][ All Steps ” Close ] [ Swap
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Action Result in Document

6. The Solve the system of equations in —— o8
Row-Echelon Form dialog appears. Click the %] Solve the system of equations in Row-Echelon Form .

buttons on the right to calculate the solution: first||| | Linear System of Equations Solve

find the Equations, then solve for each variable. 130 -2]1 ths b
Click the Solution button to display the solution matrix
in the tutor. 42 -1 507 . has =
035 4(7] been
113 6ls reduced
to ramw
1 3 0 2 1 2
N P RS B
m 10 10
145 | 435
"0 53 53
[ Close ] [ Change the matrix ] [ Cancel
7. Click the Close button to return the solution to 13 0 -2 -1 4
your document.
4 2 -1 5 7 linear solve tutor 3
_—
0-35 4 -7 -2
1 -1 3 6 5 3

For more information on linear systems and matrices, see Linear Algebra (page 119).
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3 Worksheet Mode

The Worksheet mode of the Standard Worksheet interface is designed for:

* Interactive use through Maple commands, which offers advanced functionality and customized control not available

using context menus or other syntax-free methods

* Programming using the powerful Maple language

Using Worksheet mode, you have access to all of the Maple features described in Chapter 1, and most of those described

in Chapter 2, including:
* Math and Text modes
 Palettes

» Context menus

¢ Assistants and tutors

For information on these features, see Chapter 1, Getting Started (page 1) and Chapter 2, Document Mode (page 49).

Note: Using a document block, you can use all Document mode features in Worksheet mode. For information on

document blocks, see Document Blocks (page 41).

Note: This chapter and the following chapters except Chapter 7 were created using Worksheet mode.

3.1 In This Chapter

Section Topics
Input Prompt (page 62) - Where you enter input * The Input Prompt (>)
* Suppressing Output

2-D and 1-D Math Input

Input Separators

Commands (page 63) - Thousands of routines for performing
computations and other operations

The Maple Library
Top-Level Commands
Package Commands

Lists of Common Commands and Packages

Palettes (page 67) - Items that you can insert by clicking or » Using Palettes
dragging
Context Menus (page 69)- Pop-up menus of common operations|* Using Context Menus

Assistants and Tutors (page 70)- Graphical interfaces with buttons
and sliders

.

Launching Assistants and Tutors

Task Templates (page 71) - Sets of commands with placeholders
that you can insert and use to perform a task

Viewing Task Templates
Inserting a Task Template
Performing the Task

Text Regions (page 72) - Areas in the document in which you
can enter text

Inserting a Text Region

Formatting Text

Names (page 73) - References to the expressions you assign to
them

Assigning to Names
Unassigning Names

Valid Names

61
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Section Topics

Equation Labels (page 75) - Automatically generated labels that
you can use to refer to expressions

Displaying Equation Labels

» Referring to a Previous Result

* Execution Groups with Multiple Outputs
» Label Numbering Schemes

» Features of Equation Labels

3.2 Input Prompt

In Worksheet mode, you enter input at the Maple input prompt ( > ). The default mode for input is Math mode (2-D
Math).

To evaluate input:

¢ Press Enter.

Maple displays the result (output) below the input.

. yis .
For example, to find the value of sin’ ( 3 ] , enter the expression, and then press Enter.

s m
s (3]
%\/3 G.1)

For example, compute the sum of two fractions.

) (3.2)

Suppressing Output

To suppress the output, enter a colon (:) at the end of the input.

2 7
> = 4+ —
9+11

A set of Maple input and its output are referred to as an execution group.

1-D Math Input

You can also insert input using Text mode (/-D Math). The input is entered as a one-dimensional sequence of characters.
1-D Math input is red.

To enter input using 1-D Math:

At the input prompt, press F5 or click the Text button in the toolbar, Math | to switch from 2-D Math to 1-
D Math.
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> 12372 - 29857/120;

1785623
120

Important: 1-D Math input must end with a semicolon or colon. If you use a semicolon, Maple displays the output;
if you use a colon, Maple suppresses the output.

> 12372 - 29857/120:

To set the default input mode to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.

2. On the Display tab, in the Input display drop-down list, select Maple Notation.

3. Click Apply to Session (to set for only the current session) or Apply Globally (to set for all Maple sessions).

To convert 2-D Math input to 1-D Math input:
1. Select the 2-D Math input.

2. From the Format menu, select Convert To, and then 1-D Math Input.

Important: In Document mode, you can execute a statement only if you enter it in Math mode.

Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

>,/ 4.4 ;tan(3.2)
2.097617696
0.05847385446

If you do not specify a semicolon or colon, Maple interprets it as a single input. This can either give unexpected results,
as below, or an error.

>/ 4.4 tan(3.2)
0.1226557919

3.3 Commands

Maple contains a large set of commands and a powerful programming language. Most Maple commands are written
using the Maple programming language.

You can enter commands using 1-D or 2-D Math. You must use 1-D Math input when programming in Maple. Basic
Programming (page 285) provides an introduction to Maple programming.

To learn how to use Maple commands, see the appropriate help page, or use task templates. For more information, see
The Maple Help System (page 43) and Task Templates (page 71).

The Maple Library

Maple's commands are contained in the Maple library. There are two types of commands: top-level commands and
package commands.

* The top-level commands are the most frequently used Maple commands.
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» Packages contain related specialized commands in areas such as calculus, linear algebra, vector calculus, and code
generation.

For a complete list of packages and commands, refer to the index help pages. To access the index overview help page,
enter ?index, and then press Enter. For information on the Maple Help System, see The Maple Help System (page 43).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (( )) containing any parameters. This is referred
to as a calling sequence for the command.

| command (arguments)

Note: In 1-D Math input, include a semicolon or colon at the end of the calling sequence.

For example, to differentiate an expression, use the diff command. The required parameters are the expression to dif-
ferentiate, which must be specified first, and the independent variable.

> diff (tan(x) sin(x), x)
(1 + tan(x)z) sin(x) + tan(x) cos(x)

For a complete list of functions (commands that implement mathematical functions), such as Bessell and AiryAli,
available in the library, refer to the initialfunctions help page.

Bessell (0.1, 1)
AiryAi(2.2)

47.53037086

For detailed information on the properties of a function, use the FunctionAdvisor command.

> FunctionAdvisor('definition', Bessell)

£ hypergeom([ 1, [1+al, %zzj

(1 +a)2¢

Bessell(a, z) = , With no restrictions on (a, z)

For detailed information on how to use a function in Maple, refer to its help page.
For example:
> ?Bessel

Note: In 1-D and 2-D Math input, when accessing a help page using ?, you do not need to include a trailing semicolon
or colon.

Top Commands

Here are a few of the most frequently used Maple commands. A complete list of top-level commands is available at
Help — Manuals, Resources, and more — List of Commands.

Table 3.1: Top Commands

Command Name Description

plot and plot3d Create a two-dimensional and three-dimensional plot of functions.
solve Solve one or more equations or inequalities for their unknowns.
fsolve Solve one or more equations using floating-point arithmetic.
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Command Name Description

eval Evaluate an expression at a given point.

evalf Numerically evaluate expressions.

dsolve Solve ordinary differential equations (ODEs).

int Compute an indefinite or definite integral.

diff Compute an ordinary or partial derivative, as the context dictates.

limit Calculate the limiting value of a function.

sum For symbolic summation. It is used to compute a closed form for an indefinite or definite sum.

assume/is Set variable properties and relationships between variables. Similar functionality is provided by the
assuming command.

assuming Compute the value of an expression under assumptions.

simplify Apply simplification rules to an expression.

factor Factor a polynomial.

expand Distribute products over sums.

normal Normalize a rational expression.

convert Convert an expression to a different type or form.

type Type-checking command. In many contexts, it is not necessary to know the exact value of an

expression; it suffices to know that an expression belongs to a broad class, or group, of expressions
that share some common properties. These classes or groups are known as types.

series Generalized series expansion.

map Apply a procedure to each operand of an expression.

Package Commands

To use a package command, the calling sequence must include the package name, and the command name enclosed
in square brackets ([ |).

|package [command] (arguments)

If you are frequently using the commands in a package, load the package.

To load a package:

+ Use the with command, specifying the package as an argument.

The with command displays a list of the package commands loaded (unless you suppress the output by entering a colon
at the end of the calling sequence).

After loading a package, you can use the short form names of its commands. That is, you can enter the commands
without specifying the package name.
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For example, use the NLPSolve command from the Optimization package to find a local minimum of an expression
and the value of the independent variable at which the minimum occurs.

> Optimization| NLPSolve] ( Smxﬂ,x= 1 ..15)

[ -0.0913252028230576718, [x=10.9041216700744900]]

> with(Optimization);

[ ImportMPS, Interactive, LPSolve, LSSolve, Maximize, Minimize, NLPSolve, QPSolve]

x)

>NLPSolve(%,x:1..15]

[-0.0913252028230576718, [x = 10.9041216700744900]]
For more information on optimization, see Optimization (page 140).
To unload a package:
» Use the unwith command, specifying the package as an argument.
> unwith( Optimization)

Alternatively, use the restart command. The restart command clears Maple's internal memory. The effects include
unassigning all names and unloading all packages. For more information, refer to the restart help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between
examples.

Some packages contain commands that have the same name as a top-level command. For example, the plots package
contains a changecoords command. Maple also contains a top-level changecoords command.

> with(plots) :

After the plots package is loaded, the name changecoords refers to the plots|changecoords] command. To use the
top-level changecoords command, unload the package or use the restart command. (For alternative methods of accessing
the top-level command, see the rebound help page.)

Top Packages

Here are a few of the most frequently used Maple packages. A complete list of packages is available in the Maple help
system at Help — Manuals, Resources, and more — List of Packages.

Table 3.2: Top Packages

Package Name Description

CodeGeneration The Code Generation package is a collection of commands and subpackages that enable the
translation of Maple code to other programming languages, such as C, C#, Fortran, MATLAB®,
Visual Basic®, and Java™.

LinearAlgebra The Linear Algebra package contains commands to construct and manipulate Matrices and

Vectors, and solve linear algebra problems. LinearAlgebra routines operate on three principal
data structures: Matrices, Vectors, and scalars.

Optimization The Optimization package is a collection of commands for numerically solving optimization
problems, which involve finding the minimum or maximum of an objective function possibly
subject to constraints.
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Package Name Description

Physics The Physics package implements computational representations and related operations for most
of the objects used in mathematical physics computations.

RealDomain The Real Domain package provides an environment in which Maple assumes that the basic
underlying number system is the field of real numbers instead of the complex number field.

ScientificConstants The Scientific Constants package provides access to the values of various physical constants,

for example, the velocity of light and the atomic weight of sodium. This package provides the
units for each of the constant values, allowing for greater understanding of an equation. The
package also provides units-matching for error checking of the solution.

ScientificErrorAnalysis

The Scientific Error Analysis package provides representation and construction of numerical
quantities that have a central value and an associated uncertainty (or error), which is a measure
of the degree of precision to which the quantity's value is known. Various first-order calculations
of error analysis can be performed with these quantities.

Statistics

The Statistics package is a collection of tools for mathematical statistics and data analysis. The
package supports a wide range of common statistical tasks such as quantitative and graphical
data analysis, simulation, and curve fitting.

Student

The Student package is a collection of subpackages designed to assist with teaching and learning
standard undergraduate mathematics. The many commands display functions, computations, and
theorems in various ways, including stepping through important computations.

The Student package contains the following subpackages:
» Calculusl - single-variable calculus

* LinearAlgebra - linear algebra

* MultivariateCalculus - multivariate calculus

* NumericalAnalysis - numerical analysis

* Precalculus - precalculus

¢ VectorCalculus - multivariate vector calculus

Units

The Units package contains commands for unit conversion and provides environments for
performing calculations with units. It accepts approximately 300 distinct unit names (for example,
meters and grams) and over 550 units with various contexts (for example, standard miles and
U.S. survey miles). Maple also contains two Units palettes that allow you to enter the unit for
an expression quickly.

VectorCalculus

The Vector Calculus package is a collection of commands that perform multivariate and vector
calculus operations. A large set of predefined orthogonal coordinate systems is available. All
computations in the package can be performed in any of these coordinate systems. It contains a
facility for adding a custom but orthogonal coordinate system and using that new coordinate
system for your computations.

3.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. For example, see Figure 3.1.
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W Expression

[re J N z H % P2

i)

lim f a+h a—5b ab — a

B b
:I.“ :Iv 'J'_I I;j—! :!! |:I|
g’ In(a) log,,(a) log,(a) sin(a) cos(a)

an@) (3] f@) flab) rea—y

Figure 3.1: Expression Palette
You can use palettes to enter input.
b
Fdx
For example, evaluate a definite integral using the definite integration item "= in the Expression palette.
In 2-D Math, clicking the definite integration item inserts:
b
> J fdx
a

1. Enter values in the placeholders. To move to the next placeholder, press Tab. Note: If pressing the Tab key inserts
a tab, click the Tab icon |# | in the toolbar.

2. evaluate the integral, press Enter.

1
>J tanh(x) dx
0

-In(2) + ln(ef1 +e)
In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.
> int(f,x=a..b);
Specify the problem values (using the Tab to move to the next placeholder), and then press Enter.
> int(tanh(x), x = 0..1);
-In(2) + ln(e_l +e)

Note: Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When
the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on viewing and using palettes, see Palettes (page 17) in Chapter 1.
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3.5 Context Menus

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See
Figure 3.2.

> 946929
946929

Copy Special ]
Mumeric Farmatting...
Explore

Apply a Command

Assign ko a Name

Integer Fackars

Mexk Prime

Test Primality

Mare... ]

Mumber Theory Functions b Divisors
Murnber of Positive Divisors

Mumber of Primes
Surn of Divisors

Totient Function
Figure 3.2: Integer Context Menu

In Worksheet mode, you can use context menus to perform operations on 2-D Math and output.

To use a context menu:
1. Right-click (Control-click, for Macintosh) the expression. The context menu is displayed.

2. From the context menu, select an operation.

Maple inserts a new execution group containing:
 The calling sequence that performs the operation

* The result of the operation
Example - Using Context Menus

Determine the rational expression (fraction) that approximates the floating-point number 0.3463678 + 1.7643.

Action Result in Document

1. Enter and execute the expression. > 0.3463678 + 1.7643

2.1106678 (33)
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Action

Result in Document

2. Right-click (Control-click, for Macintosh) the output
floating-point number.

2.1106678

Copy Special

Explore

Apply a Command
Assign bo a Marme
Mextk Float
Prewious Float

Conversions
Integer Functions
Urits

Murneric Farmatking. ..

]
4
¥

Zonkinued Fraction

Exact Rational

R.akional %

3. From the context menu, select Conversions — Rational. The
inserted calling sequence includes an equation label reference
to the number you are converting.

> convert( (3.3),'rational')

32270
15289

Notice that an equation label reference has been used. For information on equation labels and equation label references,

see Equation Labels (page 75).

For more information on context menus, see Context Menus (page 54) in Chapter 2.

3.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders. See Figure 3.3.

(%] oDE Analyzer Assistant
Differential Equations Conditions
- ¢ () =1

Ey(-ﬂ - ?y(ﬂ =y(1)

I Solve Numerically l[ Solve Symbalically ][ Classify ]

Paramekers

Figure 3.3: ODE Analyzer Assistant

Launching an Assistant or Tutor

To launch an assistant or tutor:
1. Open the Tools menu.
2. Select Assistants or Tutors.

3. Navigate to and select one of the assistants or tutors.

For more information on assistants and tutors, see Assistants (page 26) in Chapter 1.
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3.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands
required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the com-
mands, or click a button.

The Task Browser (Figure 3.4) organizes task templates by subject.

To launch the Task Browser:

¢ From the Tools menu, select Tasks, and then Browse.

You can also browse the task templates in the Table of Contents of the Maple Help System.
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@ Browse Tasks

M=%

File:

Viesta

#-{7) Caleulus - Differential
=475 Caleulus - Integral
-5 Integration
[h Approximate Integration
-2 Methods of Inkeqration
E\\L'f} Applications

=455 Solids of Revalution
L [1] Surface Area
Lo [1] Melume
-5 Series
H-{T) Caleulus - Mulkivariate
T Caleulus - Yectar
----- Canvert Expression to Function
1) Curwe Fitting
1) Differential Equations
-1 Document Templates

b Arc Length of a Univariake Fun

4
)[ Copy Task to Clipboard ][ Insert Default Content ][ Insert Minimal Content ]

[] Insert into Mew Worksheet

[] Display task markers

¥ Volume of Revolution

Description

Calculate the volume of revelution for a solid of revolution
when a function is rotated about the horizontal or vertical axis.

Enter the function as an expression and specify the range:

> sinfx) cos(x) + 1, 0..;

[

E
E
g 1
#+5) Evaluating sin(x) cos(x) + 1,0 . —m (1)
H{T) Geometry 2
#-{C7) Integers
(#-{3) Linear Algebra Calculate the volume of revolution:
{3 Lists
[H-2) Maple T.4. B . g _
E]--g Plats > Studeni| Calewdus 1| Fosume?ﬁw&swron][ (1)
[F-) Palynomials T+ —m (2)
({03 Statistics 16
[#-|3) Transformations -
- Units, Constants, and Errors Display the floating-point value using the evalf command:
B evalf( (2) )
§.693245131 (3)
Display a plot using the owpur=plot option:
> Student| Calculus 11| VolumeOfRevolution]( (1), output
= plot, scaling = constrained title =" ":I
(2]

< Il | =] 2] i [#]

Task, YolumeOFRevUnivariateFon

Figure 3.4: Task Browser

For details on inserting and using task templates, see Task Templates (page 33). You can also create your own task

templates for performing common tasks. For details, refer to the creatingtasks help page.

3.8 Text Regions

To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

* In the toolbar, click the Text region icon T'.

The default mode in a text region is Text mode.
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In a text region, you can:

» Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text

mode and Math mode, press F5 or click the Math and Text toolbar icons, Math
Note: The mathematical content in a text region is not evaluated. To enter mathematical content that is evaluated,
enter it at an Input Prompt (page 62).

* Insert any palette item. Palette items are inserted in Math mode (2-D Math). Note: After you insert a palette item,
you must press F5 or click the toolbar icon to return to Text mode.

You can format text in a text region. Features include:
* Character styles

» Paragraph styles

» Sections and subsections

e Tables

For more information on formatting documents, see Creating Mathematical Documents (page 221).

3.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a name or add an equation label to it.
Then you can quickly refer to the expression using the name or an equation label reference. For information on labels,
see the following section, Equation Labels (page 75).

Note: Through the Variable Manager you can manage the top-level assigned variables currently active in your Maple
Session. For more information about the Variable Manager, see the Variable Manager help page.

Assigning to Names

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program),
and other Maple objects.

Initially, the value of a name is itself.
>a
a
The assignment operator (:=) associates an expression with a name.
>a =T
a=m
Recall that you can enter & using the following two methods.

* Use the Common Symbols palette

* In 2-D Math enter pi, and then press the symbol completion shortcut key. See Shortcuts for Entering Mathematical
Expressions (page 5).

When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:

> cos(a)
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For information on Maple evaluation rules, see Evaluating Expressions (page 277).
Mathematical Functions

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

3
> cube =x —x:

For information on creating functions, see Example 2 - Define a Mathematical Function (page 51).
> cube(3); cube(1.666)
27
4.624076296

Note: To insert the right arrow, enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol —.
In 1-D Math, the characters are not replaced.

For example, define a function that squares its argument.
> square := x -> x"2:
> square(32) ;
1024
For more information on functions, see Functional Operators (page 266).
Protected Names
Protected names are valid names that are predefined or reserved.
If you attempt to assign to a protected name, Maple returns an error.
> sin =2
Error, attempting to assign to “sin’ which is protected

For more information, refer to the type/protected and protect help pages.

Unassighing Names

The unassign command resets the value of a name to itself. Note: You must enclose the name in right single quotes

(' ').
> unassign('a')
>a
a

Right single quotes (unevaluation quotes) prevent Maple from evaluating the name. For more information on unevaluation
quotes, see Delaying Evaluation (page 282) or refer to the uneval help page.

See also Unassigning a Name Using Unevaluation Quotes (page 284).
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Unassigning all names:

The restart command clears Maple's internal memory. The effects include unassigning all names. For more information,
refer to the restart help page.

Note: To execute the examples in this manual, you may be required to use the unassign or restart command between
examples.

Valid Names

A Maple name must be one of the following.
* A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character.

» A sequence of characters enclosed in left single quotes (" °).

Important: Do not begin a name with an underscore character. Maple reserves names that begin with an underscore
for use by the Maple library.

Examples of valid names:

ca

« al

* polynomial

* polynomiall_divided by polynomial2
e 2a

Cxy
3.10 Equation Labels

Maple marks the output of each execution group with a unique equation label.

Note: The equation label is displayed to the right of the output.
> Jsin(x) dx
-cos(x) (34
Using equation labels, you can refer to the result in other computations.
> J (3.4) dx
-sin(x) (3.5)

Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display is turned off, complete both of the
following operations.
* From the Format menu, select Equation Labels, and then ensure that Worksheet is selected.

* In the Options dialog (Tools—Options), on the Display tab, ensure that Show equation labels is selected.

Referring to a Previous Result

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to
refer to a previous result, insert an equation label reference.
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To insert an equation label reference:

1. From the Insert menu, select Label. (Alternatively, press Ctrl+L; Command+L, Macintosh.)

2. In the Insert Label dialog (see Figure 3.5), enter the label value, and then click OK.

Insert Label
Type: Equation v
Identifier:

I QK l l Cancel

Figure 3.5: Insert Label Dialog
Maple inserts the reference.
For example:

To integrate the product of (3.4) and (3.5):

. Press Ctrl+L (Command+L, for Macintosh).
. In the Insert Label dialog, enter 3.5. Click OK.

Action Result in Document
1. In the Expression palette, click the indefinite integration item r
N = | fdx
frae oo , , _
. The item is inserted and the integrand placeholder is
highlighted.
2. Press Ctrl+L (Command+L, for Macintosh). - [ - de
3. In the Insert Label dialog, enter 3.4. Click OK. Insert Label
Tvpe: Equation v
Tdentifier: | 3.4|
[ oK ] [ Cancel
. Press *. r
ress > (6.9 35

. Enter x.

O 0 N & w»n b

. To evaluate the integral, press Enter.

. To move to the variable of integration placeholder, press Tab.

>J(3.4)-(3.5)dx

—% cos(x)2

(3.6)

Execution Groups with Multiple Outputs

An equation label is associated with the last output within an execution group.
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CNE
N—

> ( S ]2' C()S[
3.5 ’

% J3 (3.7)

> (3.7)2

= (3.8)

Label Numbering Schemes

You can number equation labels in two ways:
 Flat - Each label is a single number, for example, 1, 2, or 3.

* Sections - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation
in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

* From the Format menu, select Equation Labels — Label Display. In the Format Labels dialog (Figure 3.6), select
one of the formats.

» Optionally, enter a prefix.

> [sm(xj dx
- —cos(x) (Question1)
|:> ’.j'( Questionl) dx
Format Labels
Label Mumbering Prefix | Queskion
Label Mumbering Scheme | Flat Mumeric V
I OF ] [ Cancel

Figure 3.6: Format Labels Dialog: Adding a Prefix

Features of Equation Labels

Although equation labels are not descriptive names, labels offer other important features.
» Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.

* Maple labels the output values sequentially. If you remove or insert an output, Maple automatically re-numbers all
equation labels and updates the label references.

 Ifyou change the equation label format (see Label Numbering Schemes (page 77)), Maple automatically updates
all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 73).

For more information on equation labels, refer to the equationlabel help page.
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The following chapters describe how to use Maple to perform tasks such as solving equations, producing plots and
animations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where
noted, all features are available in both Worksheet mode and Document mode.



4 Basic Computations

This chapter discusses key concepts related to performing basic computations with Maple. It discusses important features
that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve

problems in specific mathematical disciplines in the following chapter.

4.1 In This Chapter

Section

Topics

Symbolic and Numeric Computation (page 80)- An overview of
exact and floating-point computation

* Exact Computations
* Floating-Point Computations
» Converting Exact Quantities to Floating-Point Values

* Sources of Error

Integer Operations (page 82) - How to perform integer
computations

* Important Integer Commands
* Non-Base 10 Numbers
* Finite Rings and Fields

* Gaussian Integers

Solving Equations (page 86) - How to solve standard
mathematical equations

» Equations and Inequations

* Ordinary Differential Equations

* Partial Differential Equations

* Integer Equations

 Integer Equations in a Finite Field
* Linear Systems

¢ Recurrence Relations

Units, Scientific Constants, and Uncertainty (page 99) - How to
construct and compute with expressions that have units, scientific
constants, or uncertainty

Units

» Conversions

* Applying Units to an Expression

* Performing Computations with Units
* Changing the Current System of Units
 Extensibility

Scientific Constants

* Scientific Constants

» Element and Isotope Properties
¢ Value, Units, and Uncertainty

* Performing Computations

* Modification and Extensibility

Uncertainty Propagation

* Quantities with Uncertainty

» Performing Computations with Quantities with Uncertainty

79
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Section Topics

Restricting the Domain (page 109) - How to restrict the domain |« Real Number Domain

for computations » Assumptions on Variables

4.2 Symbolic and Numeric Computation

Symbolic computation is the mathematical manipulation of expressions involving symbolic or abstract quantities, such

as variables, functions, and operators; and exact numbers, such as integers, rationals, 7, and ¢*. The goal of such ma-
nipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood
formulas.

Numeric computation is the manipulation of expressions in the context of finite-precision arithmetic. Expressions in-

volving exact numbers, for example, \/ 2 , are replaced by close approximations using floating-point numbers, for example
1.41421. These computations generally involve some error. Understanding and controlling this error is often of as
much importance as the computed result.

In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a
decimal point) or the evalf command. The plot command (see Plots and Animations (page 187)) uses numeric compu-
tation, while commands such as int, limit, and ged (see Integer Operations (page 82) and Mathematical Problem
Solving (page 113)) generally use only symbolic computation to achieve their results.

Exact Computations

In Maple, integers, rational numbers, mathematical constants such as w and o, and mathematical structures such as
matrices with these as entries are treated as exact quantities. Names, such as x, y, my variable, and mathematical

functions, such as sin(x) and LambertW(%, z), are symbolic objects. Names can be assigned exact quantities as their
values, and functions can be evaluated at symbolic or exact arguments.

> +

3 1 T
= 71 -
2 3’+2

11 1
71 I
6 1T T

Important: Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact
quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approx-
imations, as you normally obtain from a standard hand-held calculator.
> sin(1), sin( ), sin(x)

sin(1), 0, sin(x)
> J tan(7) dr

-In(cos(?))

>32
42
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Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required. For example, the plot command requires
the expression it is plotting to evaluate to numeric values that can be rendered on the screen: m cannot be so rendered,

but 3.14159 can be. Maple distinguishes approximate from exact quantities by the presence or absence of a decimal

point: 1.9 is approximate, while % is exact.

Note: An alternative representation of floating-point numbers, called e-notation, may not include an explicit decimal
point: Je5 =100000., 3e-2 =.03.

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric
approximations. Arithmetic involving mixed exact and floating-point quantities results in a floating-point result.

2
>15+ —
+ 3
2.166666667

If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approx-
imation of the result.

1.0
> sin(l.S),J e dx
0.0

0.9974949866, 1.718281828

Converting Exact Quantities to Floating-Point Values

To convert an exact quantity to a numeric approximation of that quantity, use the evalf command or the Approximate
context menu operation (see Approximating the Value of an Expression (page 55)).

1

> evalf(n),evalf(sin(3)),evalf(%+§)

3.141592654,0.1411200081, 1.833333333

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

* Locally, you can pass the precision as an index to the evalf call.

- ova20)exp(2), e 7 2 )

7.3890560989306502272, 1.354117939

* Globally, you can set the value of the Digits environment variable.

> Digits = 25 :
> evalf(tan( g ] ]

For more information, see the evalf and Digits help pages.

1.732050807568877293527446
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Note: When appropriate, Maple performs floating-point computations directly using your computer's underlying
hardware.

Sources of Error

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject
of active research in Numerical Analysis. Some sources of error are:

. . . 1
* An exact quantity may not be exactly representable in decimal form: 3 and 7 are examples.

* Small errors can accumulate after many arithmetic operations.
» Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the

computation x — sin(x) for x = 0.

> (x—sin(x))
Lc: .00001

0.

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a represent-
ation that is more accurate for small values of x, a fully accurate 10-digit result can be obtained.

> t :=taylor(x—sin(x),x)

>t
x =0.00001

1.666666667 107'°

For information on evaluating an expression at a point, see Substituting a Value for a Subexpression (page 277). For
information on creating a series approximation, see Series (page 136). For more information on floating-point numbers,
refer to the float and type/float help pages.

4.3 Integer Operations

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated
integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the
greatest common divisor (GCD) of a pair of integers.

Note: Many integer operations are available as task templates (Tools—Tasks—Browse, under Integer Operations).

You can quickly perform many integer operations using context menus. Selecting an integer, and then right-clicking
(for Macintosh, Control-clicking) displays a context menu with integer commands. For example, the context menu
item Integer Factors applies the ifactor command to compute the prime factorization of the given integer. See
Figure 4.1.
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9469629
9469629

Figure 4.1: Context Menu for an Integer

Copy Special

Murneric Farmatking. ..

Explore

Apply a Command
Assign bo a Marme
Integer Factars
Mexk Prime

Plots

Test Primality

Integer Functions
Lnits

tumber Theory Functions

The result of applying Integer Factors is shown:

> 9469629

> ifactor((4.1))

9469629

(3)* (13) (17) (23)?

@.1)

4.2)

Maple inserts the command ifactor, using an equation label reference to the integer 946929. For more information on
equation labels, see Equation Labels (page 75).

For more information on using context menus in Worksheet mode, see Context Menus (page 69). For information on

using context menus in Document mode, see Context Menus (page 54).

Maple has many other integer commands, including those listed in Table 4.1.

Table 4.1: Select Integer Commands

Command Description

abs absolute value (displays in 2-D math as |a|)
factorial factorial (displays in 2-D math as a!)
ifactor prime factorization

iged greatest common divisor

iquo quotient of integer division

irem remainder of integer division

iroot integer approximation of nth root

isprime test primality

isqrt integer approximation of square root

max, min maximum and minimum of a set

mod modular arithmetic (See Finite Rings and Fields (page 84).)
numtheory[divisors| set of positive divisors
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> iquo(209,17)

12
> jrem(209,17)

5
> iged(2024, 4862)

22
> jroot(982523, 4)

31

For information on finding integer solutions to equations, see Integer Equations (page 97).

Non-Base 10 Numbers and Other Number Systems

Maple supports:
* Non-base 10 numbers
* Finite ring and field arithmetic

* Gaussian integers
Non-Base 10 Numbers
To represent an expression in another base, use the convert command.
> convert(6000, 'binary')
1011101110000

> convert(34271, 'hex)

85DF
For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 282).
You can also use the convert/base command.
> convert(34271, 'base, 16)

[15,13,5,8]

Note: The convert/base command returns a list of digit values in order of increasing significance.
Finite Rings and Fields
Maple supports computations over the integers modulo m.

The mod operator evaluates an expression over the integers modulo m.
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> 27 mod 4
3

By default, the mod operator uses positive representation (modp command). Symmetric representation is available
using the mods command.

> modp(27, 4)

> mods(27, 4)

-1
For information on setting symmetric representation as the default, refer to the mod help page.
The modular arithmetic operators are listed in Table 4.2.

Table 4.2: Modular Arithmetic Operators

Operation Operator |Example
Addition + > 7+ 6mod 5
3
Subtraction - > mods(3 — 16, 11)
-2
Multiplication (displays in 2-D Math as - ) * > 13-5mod 3
2
. - — va ~
Multlph?atlve inverse (displays in 2-D Math as a (-1) >3 "V mod 5
superscript)
2
o . . a / 2
Division (displays in 2-D Math as b ) > 3 mod 5
4
NN | &N A
Exponentiation > (100&"100)mod 7
2
'To enter a caret (™) in 2-D Math, enter a backslash character followed by a caret, that is, \.

For information on solving an equation modulo an integer, see Integer Equations in a Finite Field (page 98).

The mod operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information,
refer to the mod help page.

Gaussian Integers
Gaussian integers are complex numbers in which the real and imaginary parts are integers.
The GaussInt package contains commands that perform Gaussian integer operations.

The GIfactor command returns the Gaussian integer factorization.
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> Gaussint| Glfactor](173 + 16 1)
(1+21) (41 —661)

In Maple, complex numbers are represented as a+b*I, where the uppercase I represents the imaginary unit / -1 .
You can also enter the imaginary unit using the following two methods.

* In the Common Symbols palette, click the I, i or j item. See Palettes (page 17).
* Enter i or j, and then press the symbol completion key. See Symbol Names (page 23).

Note that the output will still be displayed with I, no matter what symbol was used for input. You can customize Maple's

settings to use a different symbol for y -1 . For more information on entering complex numbers, including how to
customize this setting, refer to the HowDol help page.

The GIsqrt command approximates the square root in the Gaussian integers.
> Gaussnt[ GIsqrt](9 — 5j)
31

For more information on Gaussian integers including a list of GaussInt package commands, refer to the GaussInt
help page.

4.4 Solving Equations
You can solve a variety of equation types, including those described in Table 4.3.

Table 4.3: Overview of Solution Methods for Important Equation Types

Equation Type Solution Method

Equations and inequations solve and fsolve commands

Ordinary differential equations ODE Analyzer Assistant (and dsolve command)
Partial differential equations pdsolve command

Integer equations isolve command

Integer equations in a finite field msolve command

Linear integral equations intsolve command

Linear systems LinearAlgebra|LinearSolve] command
Recurrence relations rsolve command

Note: Many solve operations are available in context menus and as task templates (Tools—Tasks— Browse). Most
of this section focuses on other methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.

To solve an equation or set of equations using context menus:
1. Right-click (for Macintosh, Control-click) the equations.

2. From the context menu, select Solve (or Solve Numerically). See Figure 4.2.



4.4 Solving Equations <+ 87
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Figure 4.2: Context Menu for an Equation
In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.
If you select Solve, Maple computes exact solutions.

2
>7Tx—x=12

L@ —x=12 (4.3)
> solve( {(4.3)})

{x:i+im],{x:i— 313 (44)

14 ' 14 14 14

If you select Solve Numerically, Maple computes floating-point solutions.

s _
> 3 —x=12
%xz —x=12 4.5)
> fsolve( {(4.5)})

{x=-2.063602674}, {x=2.492174103} (4.6)
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For information on solving equations and inequations symbolically using the solve command, see the following section.
For information on solving equations numerically using the fsolve command, see Numerically Solving
Equations (page 90).

Symbolically Solving Equations and Inequations

The solve command is a general solver that determines exact symbolic solutions to equations or inequations. The
solutions to a single equation or inequation are returned as an expression sequence. For details, see Creating and Using
Data Structures (page 261). If Maple does not find any solutions, the solve command returns the empty expression se-
quence.

> solve(x2 +3x+ 14= O)

3 1
2+2

1\/47,—3—%1\/47

2

In general, solve computes solutions in the field of complex numbers. To restrict the problem to only real solutions,
see Restricting the Domain (page 109).

It is recommended that you verify the solutions returned by the solve command. For details, see Working with
Solutions (page 91).

To return the solutions as a list, enclose the calling sequence in brackets (] |).
> [solve(x2 +x= 256y,x) ]
—% + %\/ 1+1024y, —% — %\/ 1+1024y

Expressions: You can specify expressions instead of equations. The solve command automatically equates them to
zero.

> solve(& + z)

-LambertW(1)

Multiple Equations: To solve multiple equations or inequations, specify them as a Creating and Using Data
Structures (page 261).

> solve( [xy2 —y=5x> 0])

_y+5 y+5 y+5 _y+5 y+5 y+5
X=T s Ty Ty 0y =T e =
y y y y Yy Y

, =5 <y’y<0

> solve( {xy2 —y=5x< 0})

_y+S5 y+5 y+5S B
[x_ > T T s y<S
Y Y Y

Solving for Specific Unknowns: By default, the solve command returns solutions for all unknowns. You can specify
the unknowns for which to solve.
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> solve[q2 —rs+ L= 5, qj

7

1 -1+ 1+4°5+207 1 1+ 1+4°5+207
2 r >2 r

To solve for multiple unknowns, specify them as a list.

q __r . 49_ =
>solve[{s 1 + - 5,rs 1},[q,r]j

r=
2’ S

5S¢ +1+5s 1
9= 3 5 —
s+1+s5 +5

Transcendental Equations: In general, the solve command returns one solution to transcendental equations.
> equationl = sin(x) = cos(x) :
> solve(equationl)
1 T
4
To produce all solutions, use the allsolutions option.

> solve(equationl, allsolutions = true)
1 n+n ZI~
4 _

Maple uses variables of the form _ZN~, where N is a positive integer, to represent arbitrary integers. The tilde (~) in-
dicates that it is a quantity with an assumption. For information about names with assumptions, see Assumptions on
Variables (page 110).

RootOf Structure: The solve command may return solutions, for example, to higher order polynomial equations, in
an implicit form using RootOf structures.

> [Solve(x5 —2xt 3 — 2)]
[1L,RootOf (2 — 22 +2 22 +2 Z+2 index=1),Ro0t0f( ' — 22 +2 22 +2 Z+2,index=2),
RootOf (2 — 22 +2 2 +2 742 index=3),RootOf( ! — 22 +2 Z +2 Z+2, index=4)]
These RootOf structures are placeholders for the roots of the equation 2 —2 422 +22+2. The index parameter
numbers and orders the four solutions.

Like any symbolic expression, you can convert RootOf structures to a floating-point value using the evalf command.

> evalf((4.7))

[1.,0.984001051867989 + 1.52659083388421 L, -0.484001051867989 + 0.6099471404862311,
-0.484001051867989 — 0.6099471404862311, 0.984001051867989 — 1.52659083388421 1]

Some equations are difficult to solve symbolically. For example, polynomial equations of order five and greater do
not in general have a solution in terms of radicals. If the solve command does not find any solutions, it is recommended
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that you use the Maple numerical solver, fsolve. For information, see the following section, Numerically Solving
Equations.

For more information on the solve command, including how to solve equations defined as procedures and how to find
parametric solutions, refer to the solve/details help page.

For information on verifying and using solutions returned by the solve command, see Working with Solutions (page 91).

Numerically Solving Equations

The fsolve command solves equations numerically. The behavior of the fsolve command is similar to that of the solve
command.

> equation2 =z cos(z) = 2:
> fsolve(equation2,z)
23.64662473 (4.8)

Note: You can also numerically solve equations using the context menus. See Solving Equations and
Inequations (page 86).

It is recommended that you verify the solutions returned by the fsolve command. For details, see Working with
Solutions (page 91).

Multiple Equations: To solve multiple equations, specify them as a set. For more information, see Creating and Using
Data Structures (page 261). The fsolve command solves for all unknowns.

>fsolve({ln(x) =y2 + l,xy=ey})
{x=3.396618823, y=0.4719962637}

Univariate Polynomial Equations: In general, the fsolve command finds one real solution. However, for a univariate
polynomial equation, the fsolve command returns all real roots.

> equation3 ::y4 — 3y2 —2y+1L:
> fsolve(equation3, y)

0.3365322739, 1.940392664
Controlling the Number of Solutions: To limit the number of roots returned, specify the maxsols option.
> fsolve(equation3, y,maxsols'= 1)
0.3365322739
To find additional solutions to a general equation, use the avoid option to ignore known solutions.
> fsolve(equation2, z,'avoid = {z= (4.8) })
-2.498755763

Complex Solutions: To search for a complex solution or find all complex and real roots for a univariate polynomial,
specify the complex option for the fsolve command.
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> fsolve(equation3,y,'complex’)

-1.13846246879373 — 0.4850624940594351, -1.13846246879373 + 0.4850624940594351, 0.336532273926790,
1.94039266366067

If the fsolve command does not find any solutions, it is recommended that you specify a range in which to search for
solutions, or specify an initial value.

Range: To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.

> fsolve(equation2,z, {z=100..200})
149.2390528

The syntax for specifying a region in the complex plane is lower-left point..upper-right point.

> fsolve(equation3,y, {y= -2 — 1..0},'complex');
-1.13846246879373 — 0.4850624940594351

Initial Values: You can specify a value for each unknown. The fsolve command uses these as initial values for the
unknowns in the numerical method.

> fsolve(equation2, {z=100})
(z=98.98037599} 4.9)

For more information and examples, refer to the fsolve/details help page.

For information on verifying and using solutions returned by the fsolve command, see the following section, Working
with Solutions.

Working with Solutions

Verifying: It is recommended that you always verify solutions (that the solve and fsolve commands return) using the
eval command.

> equationd :=sin(x) = —cos(x):
> solve(equation4)

T (4.10)

> eval(equation4,x = (4.10))

J2 @.11)

> equation5 :=cos(z) = 2:
z
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> fsolve(equation5)

-2.498755763 (4.12)
> eval(equation5, {z= (4.12)})
-0.8003983544 = -0.8003983540 (4.13)

For more information, see Substituting a Value for a Subexpression (page 277).

Assigning the Value of a Solution to a Variable: To assign the value of a solution to the corresponding variable as
an expression, use theassign command.

For example, consider the numeric solution in (4.9), {z=98.98037599}, found using the starting value z= 100.
> assign((4.9))
>z

98.98037599

Creating a Function from a Solution: The assign command assigns a value as an expression to a name. It does not
define a function. To convert a solution to a function, use the unapply command.

Consider one of the solutions for q to the equation q2 —rs+ L =5
r

> solutions :=

solve(c]2 —rs—+ % =5, q”

1 -1+ 1+4°54+207 1 1+ 1+4°75+207
2 r T2 r

solutions := [

> f:=unapply(solutions[1] ,r,s)

B I -1+ 1+47s+20/°
f=(rs) > :

Here, solutions[1] selects the first element of the list of solutions. For more information on selecting elements, see
Accessing Elements (page 261).

You can evaluate this function at symbolic or numeric values.
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> flx, y)

1 -1+ 1+45y+202
2 x

S/ y2)

1
2

> f(5.7,2.1)
4.032680522

For more information on defining and using functions, see Functional Operators (page 266).

Other Specialized Solvers

In addition to equations and inequations, Maple can solve other equations including:
* Ordinary differential equations (ODEs)

* Partial differential equations (PDEs)

* Integer equations

* Integer equations in a finite field

* Linear systems

* Recurrence relations

Ordinary Differential Equations (ODEs)

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and nu-
merically.

ODE Analyzer Assistant The ODE Analyzer Assistant is a point-and-click interface to the Maple ODE solving
routines.

To open the ODE Analyzer:

* From the Tools menu, select Assistants, and then ODE Analyzer.

Maple inserts the dsolve[interactive]() calling sequence in the document. The ODE Analyzer Assistant (Figure 4.3)
is displayed.
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(%] oDE Analyzer Assistant
Differential Equations Conditions Parameters
& gle) _ 7(0)=0 o=
L=1
=2

I Solve Numerically l[ Solve Symbalically ][ Classify

Figure 4.3: ODE Analyzer Assistant

In the main ODE Analyzer Assistant window, you can define ODEs, initial or boundary value conditions, and para-

meters. To define derivatives, use the diff command. For example, diff (x (t) , t) corresponds to , and

dt

&x(1)
ar

diff(x(t), t, t) correspondsto . For more information on the diff command, see The diff’

Command (page 133).
After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:
1. Ensure that the conditions guarantee uniqueness of the solution.

2. Ensure that all parameters have fixed values.

3. Click the Solve Numerically button.
4

. In the Solve Numerically window (Figure 4.4), you can specify the numeric method and relevant parameters and
error tolerances to use for solving the problem.

5. To compute solution values at a point, click the Solve button.
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Figure 4.4: ODE Analyzer Assistant: Solve Numerically Dialog

To solve a system symbolically using the ODE Analyzer Assistant:
1. Click the Solve Symbolically button.

2. In the Solve Symbolically window (Figure 4.5), you can specify the method and relevant method-specific options
to use for solving the problem.

3. To compute the solution, click the Solve button.
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%] Solve Symbolically
Method Cutput
@ Defaut timelimit (s) = &0
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Use Lie Methads q(f]=?605(1]-?605'(2£]
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Figure 4.5: ODE Analyzer Assistant: Solve Symbolically Dialog

When solving numerically or symbolically, you can view a plot of the solution by clicking the Plot button.
* To plot the solution to a symbolic problem, all conditions and parameters must be set.

* To customize the plot, click the Plot Options button to open the Plot Options window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the Show Maple
commands check box.

You can control the return value of the ODE Analyzer using the On Quit, Return drop-down list. You can select to
return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic
solutions), or the Maple commands needed to produce the solution values and the displayed plot.

For more information, refer to the ODEAnalyzer help page.
The dsolve Command
The ODE Analyzer provides a point-and-click interface to the Maple dsolve command.

For ODEs or systems of ODEs, the dsolve command can find:
* Closed form solutions

¢ Numerical solutions



4.4 Solving Equations * 97

¢ Series solutions

In addition, the dsolve command can find:
» Formal power series solutions to linear ODEs with polynomial coefficients

» Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the dsolve command directly. For more information, refer to the dsolve help
page.

Partial Differential Equations (PDEs)

To solve a PDE or PDE system symbolically or numerically, use the pdsolve command. PDE systems can contain
ODEzs, algebraic equations, and inequations.

For example, solve the following PDE symbolically. For help entering a partial derivative, see Example I - Enter a
Partial Derivative (page 50).

0 0
>y e o ften | =0
0 0
£y ) =y e ftns | =0 @14
> pdsolve((4.14))
floy) = _FI(* +)7)

The solution is an arbitrary univariate function applied to ©+ y2.

Maple generally prints only the return value, errors, and warnings during a computation. To print information about
the techniques Maple uses, increase the infolevel setting for the command.

To return all information, set infolevel to 5.
> infolevel[ pdsolve] :==5 :

> pdsolve((4.14))

Checking arguments ...

First set of solution methods (general or quase general solution)
Second set of solution methods (complete solutions)

Trying methods for first order PDEs

Second set of solution methods successful

f(x,y) =_FI(x* +57)

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the pdsolve
help page.

Integer Equations

To find only integer solutions to an equation, use the isolve command. The isolve command finds solutions for all
variables. For more information, refer to the isolve help page.
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> isolve( {xz +y= 13})
{x=_z1,y=- 71> + 13}

Integer Equations in a Finite Field
To solve an equation modulo an integer, use the msolve command. The msolve command finds solutions for all variables.
For more information, refer to the msolve help page.
> msolve( {x2 = 1}, 13)
{x=1} {x=12}

Solving Linear Systems

To solve a linear system, use the LinearAlgebra[LinearSolve] command. The LinearSolve command returns the
vector x that satisfies A . x = B. For more information, refer to the LinearAlgebra[LinearSolve] help page.

For example, construct an augmented matrix using the Matrix palette (see Creating Matrices and Vectors (page 119))
in which the first four columns contain the entries of A and the final column contains the entries of B.

(59 44 17 11
10 25 2 100 2
533 6l
o 100 50
> linearsystem := :
g 2L 3 2178
10 10 25
51 786
23 9 12 10 25

> LinearAlgebra[ LinearSolve|(linearsystem)

[ 31753441047 |
41858667400

16991806239
8371733480

1489266217
1674346696

262603866
209293337

For more information on using Maple to solve linear algebra problems, see Linear Algebra (page 119).

Solving Recurrence Relations

To solve a recurrence relation, use the rsolve command. The rsolve command finds the general term of the function.
For more information, refer to the rsolve help page.

> rsolvel{fln)=fn- 1)+ fln-2), f0)= 1, )= 1}{fn)))
po=(e s 3) 1 (4 1) (33
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4.5 Units, Scientific Constants, and Uncertainty

In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and
uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom
units.

Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

Units

The Units package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible
so that you can add units and unit systems as required.

Note: Some unit operations are available as task templates (see Tools—Tasks—Browse) and through context menus.

Overview of Units

A dimension is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and
independent are known as base dimensions.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of
substance, luminous intensity, information, and currency. For a complete list, enter and execute Units[ GetDimensions]().

Complex dimensions (or composite dimensions) measure other quantities in terms of a combination of base dimensions.
. . . mass -length
For example, the complex dimension force is a measurement of —2g
time

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure
a complex dimension.) Maple supports over 40 units of length, including feet, miles, meters, angstroms, microns, and
astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.

Table 4.4 lists some dimensions, their corresponding base dimensions, and example units.

Table 4.4: Sample Dimensions

Dimension Base Dimensions Example Units

Time time second, minute, hour, day, week, month, year,
millennium, blink, lune

Energy joule, electron volt, erg, watt hour, calorie,

2
length” -mass . . .
Lengih Tass Calorie, British thermal unit

time2

Electric potential volt, abvolt, statvolt

lengl‘h2 -mass

.3 .
time’ -electric current

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding
help page, for example, the Units/length help page for the units of length.

Each unit has a context. The context differentiates between different definitions of the unit. For example, the standard
and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the
context for a unit by appending the context as an index to the unit, for example, mile[US_survey]. If you do not specify
a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or systéme
international, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound,
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and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI,
the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed,
magnetic flux, and power are the meter/second, weber, and watt, respectively.

Unit Conversions

To convert a value measured in a unit to the corresponding value in a different unit, use the Units Calculator.

¢ From the Tools— Assistants menu, select Units Calculator.

The Units Calculator application (Figure 4.6) opens.

__‘r .
) Inanlesott Units Calculator

[ —

Convert between over 500 urts of measurement. See Units help mdex for details.

First, select a dimension from the drop-down box. Then select the umits to convert from and to. Clck the
"Perform Unit Conversion” button. The "Convert Back" button converts in the opposite direction.

Convert; |100 Result: |2.831684859
From; |cubic feet (ft~3) adl To- | cubic meters (m~3) |
Dimension: | volume v

[ Perfarm Unit Conversion ] [ Converk Back ]

Figure 4.6: Units Calculator Assistant

To perform a conversion:

1. In the Convert text field, enter the numeric value to convert.

2. In the Dimension drop-down list, select the dimensions of the unit.

3. In the From and To drop-down lists, select the original unit and the unit to which to convert.

4. Click Perform Unit Conversion.
The same conversion can be done with the convert/units command.
> convert(1.0, 'units', ' Ibfft(radius)', ' N m(radius))

1.355817948

Using the Units Calculator, you can convert temperatures and temperature changes.
* To perform a temperature conversion, in the Dimension drop-down list, select temperature(absolute).

 To perform a temperature change conversion, in the Dimension drop-down list, select temperature(relative).

To convert temperature changes, the Units Calculator uses the convert/units command. For example, an increase of
32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.
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> convert(32.0, 'units', ' degF, ' degC")
1777777778

To convert absolute temperatures, the Unit Converter uses the convert/temperature command. For example, 32 degrees
Fahrenheit corresponds to 0 degrees Celsius.

> convert(32, 'temperature', ' degF’, ' degC')

Applying Units to an Expression

To insert a unit, use the Units palettes. The Units (FPS) palette (Figure 4.7) contains important units from the foot-
pound-second system of units. The Units (SI) palette (Figure 4.8) contains important units from the international
system of units.

w Units (FPS) w Units {SI)

Teerit] 21 [zerit] [ ] [s1
[s] [poundal] [¥] [kgl [Pzl
[&] [#1 071 [&T
poundforce [T1 [41 [*1

| =] [l [el 171
[HP] [[poundal ] [H] [rad] [sr]
[rad]l [sr] _ [mai]l [Ex]  [k]

Figure 4.7: Units (FPS) Palette [s1 [#e] [Ap] |

Figure 4.8: Units (SI) Palette

To insert a unit:

* In a Units palette, click a unit symbol.

> 3[If]
3[4
To insert a unit that is unavailable in the palettes:
1. In a Units palette, click the unit symbol [z#it]] . Maple inserts a Unit object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol).
For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.
> 0.01[[mile]
0.01 [mi]
The context of a unit is displayed only if it is not the default context.

Important: In 1-D Math input, the quantity and unit (entered using the top-level Unit command) are a product, not a
single entity. The following calling sequences define different expressions.
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> 1*Unit (m)/ (2*Unit(s)); > 1*Unit (m) /2*Unit(s) ;
1 [m] 1
it > [nl 5]

Some units support prefixes. For example, SI units support prefixes to names and symbols. You can specify 1000
meters using kilometer or km. For more information, refer to the Units/prefixes help page.

> l.5[[kmS[]]
1.5 [km]

Performing Computations with Units

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform
only unit conversions. For more information about the default environment, refer to the Units/default help page.

To compute with expressions that have units, you must load a Units environment, Natural or Standard. It is recommended
that you use the Standard environment.

> with(Units| Standard]) :

In the Standard Units environment, commands that support expressions with units return results with the correct units.

> area =3[ ft] %[[mile]]

_ 14370939 [[1112 ]]

78125
_ (=125in(x) +°)[m]
[s]
(-12sin(x) + %) H%H (4.15)
> int( (4.15),x[s])
[12cos(x) + %9) [m] (4.16)

> diff ((4.16),x[[s])
(-12sin(x) + %) Hﬂn

s
For information on differentiation and integration, see Calculus (page 131).
Changing the Current System of Units
If a computation includes multiple units, all units are expressed using units from the current system of units.
> 132.25[[ mile]]
132.25 [mi] (4.17)

By default, Maple uses the SI system of units, in which length is measured in meters and time is measured in seconds.
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- (4.17)
3[ hour]

19.70701333 ”%H

To view the name of the default system of units, use the Units[UsingSystem] command.
> with(Units) :
> UsingSystem( )

N

To change the system of units, use the Units[UseSystem] command.
> UseSystem(FPS) :
> (4.17) -3[m] - 1.1[kg]

1.666720741 10" [ /7 b ]

Extensibility

You can extend the set of:

» Base dimensions and units
* Complex dimensions

e Complex units

» Systems of units

For more information, refer to the Units|AddBaseUnit], Units|AddDimension], Units|AddUnit], and
Units[AddSystem] help pages.

For more information about units, refer to the Units help page.

Scientific Constants and Element Properties

Computations often require not only units (see Units (page 99)), but also the values of scientific constants, including
properties of elements and their isotopes. Maple supports computations with scientific constants. You can use the built-
in constants and add custom constants.

Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical quantities, for example, the velocity of light
and the atomic weight of sodium. The ScientificConstants package also provides the units for the constant values,
allowing for greater understanding of the equation as well as unit-matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into two distinct categories.
* Physical constants

* Chemical element (and isotope) properties
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Scientific Constants

List of Scientific Constants

You have access to scientific constants important in engineering, physics, chemistry, and other fields. Table 4.5 lists
some of the supported constants. For a complete list of scientific constants, refer to the ScientificConstants/Physical-
Constants help page.

Table 4.5: Scientific Constants

Name Symbol
Newtonian_constant_of gravitation G
Planck constant h
elementary_charge e
Bohr radius a[0]
deuteron_magnetic_moment mu[d]
Avogadro_constant N[A]
Faraday constant F

You can specify a constant using either its name or symbol.

Accessing Constant Definition
The GetConstant command in the ScientificConstants package returns the complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the symbol G (or its name) in a call to the
GetConstant command.

> with(ScientificConstants):

> GetConstant('G")

Newtonian_constant_of gravitation, symbol = G, value = 6.673 107! 1, uncertainty = 1.0 10'13, units = 5
kg s

For information on accessing a constant's value, units, or uncertainty, see Value, Units, and Uncertainty (page 105).
Element Properties

Maple also contains element properties and isotope properties.

Elements

Maple supports all 117 elements of the periodic table. Each element has a unique name, atomic number, and chemical
symbol. You can specify an element using any of these labels. For a complete list of supported elements, refer to the
ScientificConstants/elements help page.

Maple supports key element properties, including atomic weight (atomicweight), electron affinity (electronaffinity),
and density. For a complete list of element properties, refer to the ScientificConstants/properties help page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons but a different number of neutrons, exist
for many elements.

To see the list of supported isotopes for an element, use the GetIsotopes command.
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> Getlsotopes('element' ="Li")

L14, L15, L16, L17, L18, L19, Lllo, L11 i’ L112

Maple supports isotopes and has a distinct set of properties for isotopes, including abundance, binding energy
(bindingenergy), and mass excess (massexcess). For a complete list of isotope properties, refer to the ScientificCon-
stants/properties help page.

Accessing an Element or Isotope Property Definition
The GetElement command in the ScientificConstants package returns the complete definition of an element or isotope.
> GetElement('LY)

3, symbol = Li, name = lithium, names = {lithium}, electronaffinity = [ value = 0.6180, uncertainty = 0.0005, units

= eV, atomicweight = [value = 6.941, uncertainty = 0.002, units = amu, boilingpoint = [ value = 1615., uncertainty

= undefined, units = K1, ionizationenergy = [ value = 5.3917, uncertainty = undefined, units = eV, density = | value

= 0.534, uncertainty = undefined, units = , electronegativity = [ value = 0.98, uncertainty = undefined, units

g

em’
= 1], meltingpoint = [ value = 453.65, uncertainty = undefined, units = K|

> GetElement('Li[4])

Li4, massexcess = [ value = 25320.173, uncertainty = 212.132, units = keV', bindingenergy = [ value = 4618.058,
uncertainty = 212.132, units = keV'], atomicmass = [value =4.027182329 106, uncertainty = 227.733, units = uamu]

Value, Units, and Uncertainty

To use constants or element properties, you must first construct a ScientificConstants object.

To construct a scientific constant, use the Constant command.

> G := Constant('G") :

To construct an element (or isotope) property, use the Element command.

> LiAtomicWeight := Element('Li', atomicweight)

LiAtomicWeight := Element(Li, atomicweight)
Value

To obtain the value of a ScientificConstants object, use the evalf command.
> evalf(G)

1.068912061 10”
> evalf(LiAtomicWeighi)

2.541006042 1072°

Note: The value returned depends on the current system of units.
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Units

To obtain the units for a ScientificConstants object, use the GetUnit command.

e ]
Ibs

(]

For information on changing the default system of units, for example, from SI to foot-pound-second, see Changing
the Current System of Units (page 102).

> GetUnit(G)

> GetUnif(LiAtomicWeight)

Value and Units

If you are performing computations with units, you can access the value and units for a ScientificConstants object by
specifying the units option when constructing the object, and then evaluating the object.

> evalf( Constant('G", units))

Ibs

3
1.068912061 107 HLH

> evalf (Element('Li[ 5], atomicmass, units) )
1.835022162 1020 [ 5]

Uncertainty

The value of a constant is often determined by direct measurement or derived from measured values. Hence, it has an
associated uncertainty. To obtain the uncertainty in the value of a ScientificConstants object, use the GetError
command.

> GetError(G)

1.0107"13

> GetError(LiAtomicWeight)

3.321080400 107°

Performing Computations

You can use constant values in any computation. To use constant values with units, use a Units environment as described
in Performing Computations with Units (page 102). For information on computing with quantities that have an uncertainty,
see the following section.

Modification and Extensibility
You can change the definition of a scientific constant or element (or isotope) property.

For more information, refer to the ScientificConstants[ModifyConstant] and ScientificConstants[ModifyElement]
help pages.
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You can extend the set of:
¢ Constants
» FElements (and isotopes)

* Element (or isotope) properties

For more information, refer to the ScientificConstants|AddConstant], ScientificConstants|AddElement], and Sci-
entificConstants[AddProperty] help pages.

For more information about constants, refer to the ScientificConstants help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the ScientificError Analysis package, you can propagate
the uncertainty in these values through the computation to indicate the possible error in the final result.

The ScientificErrorAnalysis package does not perform interval arithmetic. That is, the error of an object does not
represent an interval in which possible values must be contained. (To perform interval arithmetic, use the Tolerances
package. For more information, refer to the Tolerances help page..) The quantities represent unknown values with a
central tendency. For more information on central tendency, refer to any text on error analysis for the physical sciences
or engineering.

Quantities with Uncertainty

Creating: To construct quantities with uncertainty, use the Quantity command. You must specify the value and un-
certainty. The uncertainty can be defined absolutely, relatively, or in units of the last digit. For more information on
uncertainty specification, refer to the ScientificErrorAnalysis[Quantity] help page.

The output displays the value and uncertainty of the quantity.
> with(ScientificConstants): with(ScientificErrorAnalysis):
> Quantity(105, 1.2)

Quantity(105,1.2)
> Quantity(105, 0.03, 'relative)

Quantity(105,3.15) (4.18)
To specify the error in units of the last digit, the value must be of floating-point type.
> Quantity(105.0, 12,'uld)

Quantity(105.0, 1.2)

To access the value and uncertainty of a quantity with uncertainty, use the evalf and ScientificError Analysis|GetError]
commands.
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> evalf((4.18))
105.

> GetError((4.18))
3.15

Rounding: To round the error of a quantity with uncertainty, use the ApplyRule command. For a description of the
predefined rounding rules, refer to the ScientificErrorAnalysis/rules help page.

> GetError(ApplyRule( (4.18), round[2]'))
3.2

Units: Quantities with errors can have units. For example, the scientific constants and element (and isotope) properties
in the ScientificConstants packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in the Quantity calling sequence.

For an absolute error, you must specify the units in both the value and error.
> with(Units| Standard)) : with(ScientificErrorAnalysis) :
> Quantity(3.5[m], 0.1[[m])

Quantity(3.5 [m], 0.1 [m])

For a relative error, you can specify the units in only the value.
> Quantity(3.5[m]], 0.1, 'relative')

Quantity(3.5 [m]], 0.35 [m]))

For information on the correlation between, variance of, and covariance between quantities with uncertainty, refer to
the ScientificErrorAnalysis help page.

Performing Computations with Quantities with Uncertainty

Many Maple commands support quantities with uncertainty.
> g1 :=Quantity(31.,2.):
> g2 := Quantity(20., 1.):
Compute the value of the derivative of g -x* + sin(¢q2-x) at x=sin(4).
. 2, .
>dl .—dtﬁ‘(ql X~ + sin(g2-x) ,x)
dl :=2 Quantity(31.,2.) x + cos(Quantity(20., 1.) x) Quantity(20., 1.)
(=
>d2 :=eval[d],x=s1n[ s J J:

To convert the solution to a single quantity with uncertainty, use the combine/errors command.

> result = combine(d2, 'errors'):
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The value of the result is:
> evalf (result)

43.74124725
The uncertainty of the result is:

> GetError(result)

14.42690612

Additional Information

For information on topics including:
 Creating new rounding rules,
* Setting the default rounding rule, and

+ Creating a new interface to quantities with uncertainty,

refer to the ScientificErrorAnalysis help page.

4.6 Restricting the Domain

By default, Maple computes in the complex number system. Most computations are performed without any restrictions
or assumptions on the variables. Maple often returns results that are extraneous or unsimplified when computing in
the field of complex numbers. Using restrictions, you can more easily and efficiently perform computations in a
smaller domain.

Maple has facilities for performing computations in the real number system and for applying assumptions to variables.
Real Number Domain

To force Maple to perform computations in the field of real numbers, use the RealDomain package.

The RealDomain package contains a small subset of Maple commands related to basic precalculus and calculus
mathematics, for example, arccos, limit, and log, and the symbolic manipulation of expressions and formulae, for ex-
ample, expand, eval, and solve. For a complete list of commands, refer to the RealDomain help page.

After you load the RealDomain package, Maple assumes that all variables are real. Commands return simplified results
appropriate to the field of real numbers.

> with(RealDomain):

> simplify( )

> In(¢&")
x

Some commands that generally return NULL instead return a numeric result when you use the RealDomain package.



110 < 4 Basic Computations

(5)
> (—32)
-2
Complex return values are excluded or replaced by undefined.

> solve()c2 =— 1)

> arcsin(ez)

undefined

Assumptions on Variables

To simplify problem solving, it is recommended that you always apply any known assumptions to variables. You can
impose assumptions using the assume command. To apply assumptions for a single computation, use the assuming
command.

Note: The assume and assuming commands are not supported by the RealDomain package.
The assume Command

You can use the assume command to set variable properties, for example, x::real, and relationships between variables,
for example, x <0 or x <y. For information on valid properties, refer to the assume help page. For information on the
double colon (::) operator, refer to the type help page.

The assume command allows improved simplification of symbolic expressions, especially multiple-valued functions,
for example, computing the square root.

To assume that x is a positive real number, use the following calling sequence. Then compute the square root of 2.

> assume(0 < x): +/ °
X~
The trailing tilde (~) on the name x indicates that it carries assumptions.

When you use the assume command to place another assumption on x, all previous assumptions are removed.

> assume(x < 0): / P
—x~
Displaying Assumptions: To view the assumptions on an expression, use the about command.

> about(x)

Originally x, renamed x~:
is assumed to be: RealRange (-infinity,Open (0))

Imposing Multiple Assumptions: To simultaneously impose multiple conditions on an expression, specify multiple
arguments in the assume calling sequence.

> assume(0 < x,x < 2)
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To specify additional assumptions without replacing previous assumptions, use the additionally command. The syntax
of the additionally calling sequence is the same as that of the assume command.

> additionally(x :: integer): about(x)

Originally x, renamed x~:
is assumed to be: 1

The only integer in the open interval (0, 2) is 1.
Testing Properties: To test whether an expression always satisfies a condition, use the is command.
> assume(15 <x,7 <y): is(100 < xy)

true

The following test returns false because there are values of x and y (x =0, y = 10) that satisfy the assumptions, but do
not satisfy the relation in the is calling sequence.

> assume(x :: nonnegint, 10 < y): is(10 <x +y)
false
To test whether an expression can satisfy a condition, use the coulditbe command.
> coulditbe(10 < x + )
true
Removing Assumptions: To remove all assumptions on a variable, unassign its name.
> unassign ('x','y")
For more information, see Unassigning Names (page 74).
For more information on the assume command, refer to the assume help page.
The assuming Command
To perform a single evaluation under assumptions on the names in an expression, use the assuming command.

The syntax of the assuming command is <expression> assuming <property or relation>. Properties and relations are
introduced in The assume Command (page 110).

The frac command returns the fractional part of an expression.
> frac(x) assumingx :: integer
0

Using the assuming command is equivalent to imposing assumptions with the assume command, evaluating the ex-
pression, and then removing the assumptions.

> about(x)

X3

nothing known about this object

If you do not specify the names to which to apply a property, it is applied to all names.



112 < 4 Basic Computations

2
a . ..
> ( Z ) assuming positive

Assumptions placed on names using the assume command are ignored by the assuming command, unless you include
the additionally option.

> assume(x < 1)
> is(l - > O) assumingx > -1

false
> z's(l - > 0) assuming additionally, x > -1

true

The assuming command does not affect variables inside procedures. (For information on procedures, see
Procedures (page 295).) You must use the assume command.

> f := proc(x) sqgrt(a”2) + x end proc;

f=proc(x) sqrt(a"2) + x end proc
> f(1) assuminga > 0
N; @ +1

> assume(a > 0): (1)
a~+1

For more information on the assuming command, refer to the assuming help page.
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This chapter focuses on solving problems in specific mathematical disciplines. The areas described below are not all
that Maple provides, but represent the most commonly used packages. Examples are provided to teach you how to use
the different methods of calculation available in Maple, including tutors, assistants, commands, task templates, plotting,
and context menus.

The examples in this chapter assume knowledge of entering commands and mathematical symbols. For information,
see Entering Expressions (page 15). For information on basic computations, including integer operations and solving
equations, see Basic Computations (page 79).

5.1 In This Chapter

Section Topics

Algebra (page 113) - Performing algebra computations * Polynomial Algebra

Linear Algebra (page 119) - Performing linear algebra » Creating Matrices and Vectors
computations

» Accessing Entries in Matrices and Vectors
» Linear Algebra Computations

* Student LinearAlgebra Package

Calculus (page 131) - Performing calculus computations e Limits

« Differentiation

* Series

* Integration

« Differential Equations

* Calculus Packages

Optimization (page 140) - Performing optimization computations |* Point-and-Click Interface

using the Optimization package « Efficient Computation

* MPS(X) File Support

Statistics (page 144) - Performing statistics computations using |* Probability Distributions and Random Variables

the Statistics package « Statistical Computations

 Plotting

Teaching and Learning with Maple (page 148) - Student and |+ Table of Student and Instructor Resources

Instructor resources for using Maple in an academic setting - Student Packages and Tutors

Clickable Math (page 160) - Solve math problems using some of |+ Step-by-Step examples
the interactive methods available in Maple

5.2 Algebra

Maple contains a variety of commands that perform integer operations, such as factoring and modular arithmetic, as
described in Integer Operations (page 82). In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see Linear Algebra (page 119).

Polynomial Algebra
A Maple polynomial is an expression in powers of an unknown. Univariate polynomials are polynomials in one unknown,

for example, X — 2x + 13. Multivariate polynomials are polynomials in multiple unknowns, such as X Y — % xy2 + 7x.

113
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The coefficients can be integers, rational numbers, irrational numbers, floating-point numbers, complex numbers,
variables, or a combination of these types.

b

2
> +7 —
ax X 2

2 1
+7x——05>
ax X >

Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic operators excluding the division operator (/).
(The division operator accepts polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The quo and rem commands find the quotient and remainder of a
polynomial division. See Table 5.1. (The iquo and irem commands find the quotient and remainder of an integer division.
For more information, see Integer Operations (page 82).)

Table 5.1: Polynomial Arithmetic Operators

Operation Operator |Example
Addition s (P 41) + (3P - 5x+2)
P +3+38 —5x
Subtraction — >(P+1) - (383 - 5x+2)
K —1-3x3 +5x
Multiplication' * >(P+1)-(3°-5x+2)
(*+1) (35 —5x+2)
D1v1s1pn: Quotient and quo > quo(2:% +x— 3,3x + 5,%)
Remainder
rem ) 7
3
> rem(2x2 +x—-33x+ 5,x)
8
9
Exponentiation” A >(2+1)°
3
(x2 + 1)
"You can specify multiplication explicitly by entering *, which displays in 2-D Math as - . In 2-D
Math, you can also implicitly multiply by placing a space character between two expressions. In
some cases, the space character is optional. For example, Maple interprets a number followed by a
name as an implicit multiplication.
’In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the expand command.
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> expand(3x2-(3x+5) - (x2—2))
9x + 142 +2

If you need to determine whether one polynomial divides another, but do not need the quotient, use the divide command.
The divide command tests for exact polynomial division.

> divide(x4y2+x3y2—x2y2+13 P+13x—13 +y-x2+x-y—y,x2+x— 1 )
true

Important: You must insert a space character or a multiplication operator ( - ) between adjacent variables names.
Otherwise, they are interpreted as a single variable.

For example, x does not divide the single variable xy.

> divide(xy, x)

false
But, x divides the product of x and y.
> divide(x y,x); divide(x-y, x)
true
true

For information on polynomial arithmetic over finite rings and fields, refer to the mod help page.

Sorting Terms

To sort the terms of a polynomial, use the sort command.

> pl:=x2 +x° —x+x*
pl :=x2 +x3 —x+x4

> sort(pl)

AP P -
Note: The sort command returns the sorted polynomial, and updates the order of the terms in the polynomial.
The terms of p1 are sorted.
>pl

AP+ —x

To specify the unknowns of the polynomial and their ordering, include a list of names.
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> sort(a2x3+x2 +xa+a+b, [a])

Y +xata+rP+b

> sort(a2x3+x2 +xa+a+b, [x,b])
A+ fax+b+a

By default, the sort command sorts a polynomial by decreasing tofal degree of the terms.
> ‘192::x3 —i—y3 +x2y2:
> sort(p2,[x,y])

$* y2 +5° + y3

The first term has total degree 4. The other two terms have total degree 3. The order of the final two terms is determined
by the order of their names in the list.

To sort the terms by pure lexicographic order, that is, first by decreasing order of the first unknown in the list option,
and then by decreasing order of the next unknown in the list option, specify the 'plex' option.

> sort(p2, [x,y], plex)
IR
For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 282).

The first term contains x to the power 3; the second, x to the power 2; and the third, x to the power 0.
Using context menus, you can perform operations, such as sorting, for polynomials and many other Maple objects.

To sort a polynomial:

—

. Right-click (Control-click, for Macintosh) the polynomial.
2. The context menu displays. From the Sorts menu, select:
* Single-variable, and then the unknown

* Two-variable (or Three-variable), Pure Lexical or Total Degree, and then the sort priority of the unknowns.

See Figure 5.1.
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Figure 5.1: Sorting a Polynomial Using a Context Menu
Maple sorts the polynomial.

In Worksheet mode, Maple inserts the calling sequence that performs the sort followed by the sorted polynomial.
> X +y3 —f-xzy2 :
>sort( x"3+yA3+x"2%yr2, [y, x| plex)

y3 + y2 x2 + x3

You can use context menus to perform operations on 2-D Math content including output. For more information, see
Context Menus (page 54) (for Document mode) or Context Menus (page 69) (for Worksheet mode).

Collecting Terms

To collect the terms of polynomial, use the collect command.
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2
> collect[Zaxy+cx2y— zy2 +az— 13by + l’y]
x

(—z—i—%]y2+(2ax+cx2—l3b)y+az

Coefficients and Degrees
Maple has several commands that return coefficient and degree values for a polynomial. See Table 5.2.

Table 5.2: Polynomial Coefficient and Degree Commands

Command |Description Example

coeff Coefficient of specified degree term 1 3 3
> coef/(zx —2x+5,x )

1

2
Icoeff Leading coefficient 1 3
> lcoeff( o¥ —2x+5)
1
2
tcoeff Trailing coefficient 1 3
> tcoeff( ER —2x+5)
5
coeffs Sequence of all coefficients, in one-to-one 13
correspondence with the terms > coeffs ( Y —2x +5]
Note: It does not return zero coefficients 1
_2 —
5, -2, )
degree (Highest) degree
> degree( %x3 —2x+5]
3
ldegree Lowest degree term with a non-zero 1 3
coefficient > ldegree( > —Zx)

1

Factorization

To express a polynomial in fully factored form, use the factor command.
> factor(x4 -1 )

x—1)(x+1)(Z+1)

The factor command factors the polynomial over the ring implied by the coefficients, for example, integers. You can
specify an algebraic number field over which to factor the polynomial. For more information, refer to the factor help
page. (The ifactor command factors an integer. For more information, see Integer Operations (page 82).)
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To solve for the roots of a polynomial, use the solve command. For information on the solve command, see Solving
Equations and Inequations (page 86). (The isolve command solves an equation for integer solutions. For more inform-

ation, see Integer Equations (page 97).)

Other Commands

Table 5.3 lists other commands available for polynomial operations.

Table 5.3: Select Other Polynomial Commands

Command Description

content Content (multivariate polynomial)

compoly Decomposition

discrim Discriminant

ged Greatest common divisor (of two polynomials)
gedex Extended Euclidean algorithm (for two polynomials)

CurveFitting[Polynomiallnterpolation]

— Curve Fitting)

See also the CurveFitting Assistant (Tools — Assistants

Interpolating polynomial (for list of points)

lem Least common multiple (of two polynomials)

norm Norm

EPROM Pseudo-remainder (of two multivariate polynomials)
primpart Primitive part (multivariate polynomial)

randpoly Random polynomial
PolynomialTools[IsSelfReciprocal] Determine whether self-reciprocal

resultant Resultant (of two polynomials)

roots Exact roots (over algebraic number field)

sqrfree Square-free factorization (multivariate polynomial)

Additional Information

Table 5.4: Additional Polynomial Help

Topic

Resource

General polynomial information

?polynom help page

PolynomialTools package

?PolynomialTools package overview help page

Algebraic manipulation of numeric polynomials

?SNAP (Symbolic-Numeric Algorithms for Polynomials) package
overview help page

Efficient arithmetic for sparse polynomials

?SDMPolynom (Sparse Distributed Multivariate Polynomial data
structure) help page

Polynomial information and commands

Maple Help System Table of Contents:
Mathematics— Algebra— Polynomials section

5.3 Linear Algebra

Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the Task Browser (Tools — Tasks —

Browse), expand the Linear Algebra folder.
Creating Matrices and Vectors

Creating Matrices

You can create a Matrix using
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* The Matrix command
* The angle bracket shortcut notation

* The Matrix palette (see Figure 5.2).

When creating a Matrix using the Matrix command, there are several input formats available. For example, enter a list
of lists. The dimensions of the matrix are inferred from the number of entries given.

>Matrix( [l,n, 0], e2, sin(¢), 87 , (0,0, Se]D
1 T 0
& sin(¢) ——
0 0 S5e

Alternatively, use the angle bracket shortcut, <>. Separate items in a column with commas, and separate columns with
vertical bars, |.

> <1,n,062, sin(?), % 0,0, Se>
1 & 0
7 sin(¢z) 0
87
0 -5

For information on the Matrix command options, see Creating Matrices and Vectors with Specific Properties (page 123).

Use the Matrix palette to interactively create a matrix without commands:

W Makrix
Rows: 2 C
Columns: 2 C

| Choose... |

Type: | Custom values V-’Z'

Shape: | Any V-’Z'
Data bype: | Ay V-’Z'
| Imsert Matrix |

Figure 5.2: Matrix Palette

In the Matrix palette, you can specify the matrix size (see Figure 5.3) and properties. To insert a matrix, click the Insert
Matrix button.
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W Matrix

Rows:
Caolumns:

Choose, ..

!!

Type:
Shape:

Data bype:

- HEE

3 3 {5hift: x10; Control; x1007%

Figure 5.3: Matrix Palette: Choosing the Size

After inserting the matrix:

1. Enter the values of the entries. To move to the next entry placeholder, press Tab.

2. After specifying all entries, press Enter.

1 & 0
o | @ sin(z) O
0 % Se

Creating Vectors

You can create a Vector using angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, <a, b, ¢>. The number of elements is inferred from

the number of expressions.
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>(1,2,3)

To create a row vector, specify a vertical-bar-delimited (|) sequence, <a | b | ¢>. The number of elements is inferred
from the number of expressions.

> (112]3)
[123]
For information on the Vector command options, refer to the Vector help page.

You can also create vectors using the Matrix palette. If either the number of rows or number of columns specified is
1, then you have the option of inserting a matrix, or inserting a vector of the appropriate type. See Figure 5.4.

W Matrix

—

[<f#] e

Rows:

Calumns: 27
| Choose. .. |

Type: E\lCustom values V_.fﬁ'

Shape: E\l.ﬂmy v_.fﬁ'

Data bype: [ Any )

7

==== Insert Vector[row] -

= Insert Matrix —

U Insert Veckor[row]
N I

Figure 5.4: Insert Matrix or Insert Vector

Viewing Large Matrices and Vectors

Matrices 10 x 10 and smaller, and vectors with 10 or fewer elements, display in the document. Larger objects are
displayed as a placeholder.

For example, insert a 15 x 15 matrix.

In the Matrix palette:
1. Specify the dimensions: 15 rows and 15 columns.
2. In the Type drop-down list, select a matrix type, for example, Random.

3. Click Insert Matrix. Maple inserts a placeholder.

15 x 15 Matrix
Data Type: anything
Storage: rectangular

Order: Fortran_order

To edit or view a large matrix or vector, double-click the placeholder. This launches the Matrix Browser. See Figure 5.5.



5.3 Linear Algebra
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Browse Matrix

1 2 3 4 5 & 7

1 |44 0 33 -29 20 -4 35 i

292 -41 -43 el -4t 27 -26

3 |73 -79 68 a1 35 15 -36

4 -39 el o8 35 -54 15 =0

5 g2 45 -43 30 -17 63 -94

& |11 -10 -85 20 -23 ] -97

76l -5 -85 39 78 -51 -33 3

g |28 47 19 -35 23 =1 -36 ]

9 |48 -S4 25 26 -67 35 -69

1o |63 -T2 17 -7 28 -33 &9

11 |27 -79 31 13 -31 -19 -15

12 |38 75 39 32 -36 -55 2

13 |2 -35 92 45 -33 71 -33

14 |34 -19 -2 -G a1 -50 29

o - . § . m—

<] I | [#]

Figure 5.5: Matrix Browser

To modify the entries using the Matrix Browser:
1. Select the Table tab.
2. Double-click an entry, and then edit its value. Press Enter.

3. Repeat for each entry to edit.

4. When you have finished updating entries, click Done.

You can view the matrix or vector as a table or as an image, which can be inserted into the document. For more inform-

ation, refer to the MatrixBrowser help page.

To set the maximum dimension of matrices and vectors displayed inline:

 Use the interface command with the rtablesize option.

For example, interface(rtablesize = 15).

For more information, refer to the interface help page.

Creating Matrices and Vectors with Specific Properties

By default, matrices and vectors can store any values. To increase the efficiency of linear algebra computations, create
matrices and vectors with properties. You must specify the properties, for example, the matrix shape or data type, when

defining the object.

The Matrix palette (Figure 5.2) supports several properties.

To specify the matrix type:

 Use the Shape and Type drop-down lists.
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To specify the data type:

» Use the Data type drop-down list.

For example, define a diagonal matrix with small integer coefficients.
In the Matrix palette:

1. Specify the size of the matrix, for example, 3 x 3.

2. In the Shapes drop-down list, select Diagonal.

3. In the Data type drop-down list, select integer[1].

4. Click the Insert Matrix button.
5

. Enter the values in the diagonal entries.

-23 0 0
> 0 17 0§
0 0 32

You cannot specify properties when defining vectors using the angle-bracket notation. You must use the Vector con-
structor.

To define a column vector using the Vector constructor, specify:
* The number of elements. If you explicitly specify all element values, this argument is not required.
* A list of expressions that define the element values.

» Parameters such as shape, datatype, and fill that set properties of the vector.

The following two calling sequences are equivalent.

> Vector([0,0,0])

> Vector(3,'shape ='zero')

To create a row vector using the Vector constructor, include row as an index.
> Vector[row](3,fill= 1)
[111]
> Vector[row]([127,0,34], 'datatype ="integer[ 1]')
[ 127 0 34 |

The Matrix palette does not support some properties. To set all properties, use the Matrix constructor.
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To define a matrix using the Matrix constructor, specify:
* The number of rows and columns. If you explicitly specify all element values, these arguments are not required.
* A list of lists that define the element values row-wise.

» Parameters such as shape, datatype, and fill that set properties of the matrix.
For example:
> Matrix([[1,2,3],[4,5,6]])

123
456

The Matrix palette cannot fill the matrix with an arbitrary value. Use the fill parameter.
> Matrix(3,4,[[1,2,3],[4,5,6]),fill=2 + I)

1 2 3 241
4 5 6 2+1
2+412412+12+1

For more information on the constructors, including other calling sequence syntaxes and parameters, refer to the storage,
Matrix, and Vector help pages.

See also Numeric Computations (page 131).
Accessing Entries in Matrices and Vectors

Matrices

To select an entry in a Matrix, enter the matrix name with a sequence of two non-zero integer indices, row first.

>M = (-4.3,-6.7,1.92.9,-1.2,9.6/9.3,-8.0,-9.2)

-43 29 93
M:=| -6.7 -1.2 -8.0
1.9 9.6 -92
> M][1,3]
9.3

To select an entire row, enter a single index; to select an entire column, enter first the entire range of rows, 1..-1, then
the column index.
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> M[2]
[—6.7 -12 —8.0]
>M[1..-1,1]
-43
-6.7
1.9

Similarly, you can access submatrices. Enter the indices as a list or range.

> M[2.3,1.2]

-6.7 -1.2
1.9 9.6

Vectors
To select an entry in a vector, enter the vector name with a non-zero integer index.
> a:=<85.3,47.1,59.9,38.1>

85.3
47.1
59.9
38.1

>a[1]

85.3
Negative integers select entries from the end of the vector.
>a[ —1]

38.1

To create a Vector consisting of multiple entries, specify a list or range of integers in the index. For more information,
refer to the set and range help pages.

>a[[1,2]]
85.3
47.1
>a[2.4]
47.1
59.9

38.1
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Linear Algebra Computations

Maple has extensive support for linear algebra. You can perform many matrix and vector computations using context
menus. Matrix operations such as multiplication and inverses can be done with the basic matrix arithmetic operators.
The LinearAlgebra package provides the full range of Maple commands for linear algebra and vector space computa-
tions, queries, and linear system solving.

Matrix Arithmetic

The matrix and vector arithmetic operators are the standard Maple arithmetic operators up to the following two differ-
ences.

» The scalar multiplication operator is the asterisk (*), which displays in 2-D Math as - . The noncommutative matrix
and vector multiplication operator is the period (.).

* There is no division operator (/) for matrix algebra. (You can construct the inverse of a matrix using the exponent

-1)

Table 5.5 lists the basic matrix operators.

93 43
19 37

48 20
19 37

>A:: . =

:C = (23,6) :

Table 5.5: Matrix and Vector Arithmetic Operators

Operation Operator |Example
Addition + >A4B
141 63
38 74
Subtraction — >A4—B
45 23
0 0
Multiplication . >AC
2397
659
Scalar Multiplicationl * > 124
1116 516
228 444
>4.C
92
24
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Operation Operator |Example
Exponentiation® " >4
986548 613868
271244 187092
>B~!
37 5
1396 349
19 12
1396 349

You can specify scalar multiplication explicitly by entering *, which displays in 2-D Math as - .
In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by placing a space
character between them. In some cases, the space character is optional. For example, Maple interprets
a number followed by a name as an implicit multiplication.

%In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 5.6.

Define two column vectors.
>d=<1,2,3>:¢e:=<4,5,6>:

Table 5.6: Select Matrix and Vector Operators

Operation Operator Example
Transpose Aol > ST
[123]
Hermitian Transpose INVAL %H
P 7oH I -21
3+4712-1
-13—41
21 2+1
Cross Product &x* > with(LinearAlgebra):
3-D vect 1
( vectors only) > d&re
-3
6
-3
1Exponential operators display in 2-D Math as superscripts.
2After loading the LinearAlgebra package, the cross product operator is available as the infix
operator &x . Otherwise, it is available as the LinearAlgebra[CrossProduct] command.

For information on matrix arithmetic over finite rings and fields, refer to the mod help page.
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Point-and-Click Interaction
Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.

 Perform standard operations: determinant, inverse, norm (1, Euclidean, infinity, or Frobenius), transpose, and trace
» Compute eigenvalues, eigenvectors, and singular values

» Compute the dimension or rank

» Convert to the Jordan form, or other forms

» Perform Cholesky decomposition and other decompositions

For example, compute the infinity norm of a matrix. See Figure 5.6.

18735.6985 349723 234987
9859.459 79812414089

Copy Special »
Paste ChrlY

Evaluate and Display Inline  Ctrl4+=

Explore

Apply a Command

Approxirmate ]
Assign to a Mame

Browse

Eigenwalues, etc »

Map Command Onka
1

Euclidean

Marm
Flots
Select Elements infinity

Saolvers and Forms Frobenius

r v v v w

Standard Operations

Canversians

Curve Fitting

Export As

In Place Options

Language Canversions

Map Integer Functions Onka

* v T T Ww w

Queries

2-D Math 3
Figure 5.6: Computing the Infinity Norm of a Matrix

In Document mode, Maple inserts a right arrow and the name of the computation performed, followed by the norm.

187356985 3497232534987 | infinity-nom
—
PE59.459  TO8124.14089

5.0798359990 10°

Vector operations available in the context menu include the following.
» Compute the dimension

* Compute the norm (1, Euclidean, and infinity)
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* Compute the transpose

¢ Select an element

For more information on context menus, see Context Menus (page 54) (for Document mode) or Context Menus (page 69)
(for Worksheet mode).

LinearAlgebra Package Commands

The LinearAlgebra package contains commands that construct and manipulate matrices and vectors, compute standard
operations, perform queries, and solve linear algebra problems.

Table 5.7 lists some LinearAlgebra package commands. For a complete list, refer to the LinearAlgebra/Details help
page.

Table 5.7: Select LinearAlgebra Package Commands

Command Description

Basis Return a basis for a vector space

CrossProduct Compute the cross product of two vectors
DeleteRow Delete a row or rows of a matrix

Dimension Determine the dimension of a matrix or a vector
Eigenvalues Compute the eigenvalues of a matrix

Eigenvectors Compute the eigenvectors of a matrix
FrobeniusForm Reduce a matrix to Frobenius form
GaussianElimination Perform Gaussian elimination on a matrix
HessenbergForm Reduce a square matrix to Hessenberg form
HilbertMatrix Construct a generalized Hilbert matrix

IsOrthogonal Test if a matrix is orthogonal

LeastSquares Compute the least-squares approximation to A . x=b
LinearSolve Solve the linear system A .x=Db

MatrixInverse Compute the inverse of a square matrix or pseudo-inverse of a non-square matrix
QRDecomposition Compute the QR factorization of a matrix
RandomMatrix Construct a random matrix

SylvesterMatrix Construct the Sylvester matrix of two polynomials

For information on arithmetic operations, see Matrix Arithmetic (page 127).

For information on selecting entries, subvectors, and submatrices, see Accessing Entries in Matrices and
Vectors (page 125).

Example: Determine a basis for the space spanned by the set of vectors {(2, 13, -15), (7, -2, 13), (5, -4, 9)}. Express
the vector (25, -4, 9) with respect to this basis.

> with(LinearAlgebra):
>yl =<2,13, —=15>:v2:=<7,—=2,13>:v3:= <5, —4,9>:

Find a basis for the vector space spanned by these vectors, and then construct a matrix from the basis vectors.
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> basis = Matrix(Basis([vI,v2,v3]));

2 7 5
basis = 13 -2 -4
-15 13 9

To express (25, -4, 9) in this basis, use the LinearSolve command.
> LinearSolve(basis, <25, —4,9>)
170 |

91

285
91

786
91

Numeric Computations

You can very efficiently perform computations on large matrices and vectors that contain floating-point data using the
built-in library of numeric linear algebra routines. Some of these routines are provided by the Numerical Algorithms
Group (NAG®). Maple also contains portions of the CLAPACK and optimized ATLAS libraries.

For information on performing efficient numeric computations using the LinearAlgebra package, refer to the Effi-
cientLinearAlgebra help page.

See also Creating Matrices and Vectors with Specific Properties (page 123) and Reading from Files (page 317).

Student LinearAlgebra Package

The Student package contains subpackages that help instructors teach concepts and allow students to visualize and
explore ideas. These subpackages also contain computational commands.

In the Student[LinearAlgebra] subpackage, the environment differs from that of the LinearAlgebra package in that
floating-point computations are generally performed using software precision, instead of hardware precision, and
symbols are generally assumed to represent real, rather than complex, quantities. These defaults, and others, can be
controlled using the SetDefault command. For more information, refer to the Student[LinearAlgebra][SetDefault]
help page.

For information on using Maple as a teaching and learning tool, see Teaching and Learning with Maple (page 148).

5.4 Calculus

The Task Browser (Tools—Tasks—Browse) contains numerous calculus task templates. For a list of tasks, navigate
to one of the related folders, such as Calculus, Differential Equations, Multivariate Calculus, or Vector Calculus.

This section describes the key Maple calculus commands, many of which are used in task templates or available in the
context menus.

For a complete list of calculus commands, refer to the Mathematics (including Calculus, Differential Equations,
Power Series, and Vector Calculus subfolders) and Student Package sections of the Maple Help System Table of
Contents.



132 « 5 Mathematical Problem Solving

Limits
To compute the limit of an expression as the independent variable approaches a value:

1. In the Expression palette, click the limit item Mz )

2. Specify the independent variable, limit point, and expression, and then evaluate it. Press Tab to move to the next
placeholder.

For example:

x—0

)

The limit Command

By default, Maple searches for the real bidirectional limit (unless the limit point is o or -0). To specify a direction,
include one of the options left, right, real, or complex in a call to the limit command. See Table 5.8.

Table 5.8: Limits

Limit Command Syntax Output
undefined

lim (i > limil[l,x=0) 7
x—=>0\ x X

lim ij > limit[i x=0,"7i ht'j %
r->0t\ x x’ 118

lim [+ > limit| L, x=0,left -
LS imit| —,x=0, lef

Using the limit command, you can also compute multidimensional limits.

2
> limit( L, {x=1,y=o })
y
0
For more information on multidimensional limits, refer to the limit/multi help page.

Numerically Computing a Limit

To numerically compute a limit:

* Use the evalf(Limit(arguments)) calling sequence.
Important: Use the inert Limit command, not the limit command. For more information, refer to the limit help page.
The Limit command accepts the same arguments as the limit command.

For example:

> evalf(Limit( %,x: 1.225] j

0.3020605357

For information on the evalf command, see Numerical Approximation (page 279).
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The Limit command does not compute the limit. It returns an unevaluated limit.

sin(x)

> Limit( —_— T x= 1.225)
cos(x) + tan(x)

sin(x)
‘ 1m - < .
x—1.225 cos(x) + tan(x)

For more information on the Limit command, refer to the Limit help page.

Differentiation
Maple can perform symbolic and numeric differentiation.

To differentiate an expression:

d o
1. In the Expression palette, click the differentiation item dx 7 or the partial differentiation item &x

f .
2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate x sin(ax) with respect to x:
> d (xsin(ax))
dx

sin(ax) + xcos(ax) a
You can also differentiate using context menus. For more information, see Context Menus (page 32).

To calculate a higher order or partial derivative, edit the derivative symbol inserted. For example, to calculate the
second derivative of x sin(ax) + x* with respect to x:
5 2
>— (x sin(ax) +x )
d
X

2 cos(ax) a — xsin(ax) @ +2

To calculate the mixed partial derivative of xsin(3y) + ny:
62

- 5
> oy ox (xsm(3y) +yx )

3cos(3y) + 5x¢
Note: To enter another @ symbol, you can copy and paste the existing symbol, or enter d and use symbol completion.

The diff Command

Maple computes derivatives using the diff command. To directly use the diff command, specify the expression to dif-
ferentiate and the variable.
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> xsin(ax) + ¥

xsin(ax) + ¥ 3.1

> diff ((5.1),x)
sin(ax) + xcos(ax)a+2x (5.2)
For information on equation labels such as (5.1), see Equation Labels (page 75).

You can calculate a higher order derivative by specifying a sequence of differentiation variables. Maple recursively
calls the diff command.

> diff ((5.1),x,x)

2cos(ax) a — xsin(ax) a® + 2 (5.3)
To calculate a partial derivative, use the same syntax. Maple assumes that the derivatives commute.
> diff (xsin(3y) + W x,xy)

1
2 x

3cos(3y) +

To enter higher order derivatives, it is convenient to use the syntax diff(f, x$n). This syntax can also be used to compute
the symbolic n'™ order derivative.

For example:
> diff (cos(t),t$n)
cos(t + L n n)
2

Differentiating an Operator

You can also specify a mathematical function as a functional operator (a mapping). For a comparison of operators and
other expressions, see Distinction between Functional Operators and Other Expressions (page 267).

To find the derivative of a functional operator:

+ Use the D operator.

The D operator returns a functional operator.

For example, find the derivative of an operator that represents the mathematical function F : x—x cos(x).
First, define the operator F.

1. In the Expression palette, click the single-variable function definition item /=2 =¥,
2. Enter placeholder values.

» To move to the next placeholder, press the Tab key. Note: If pressing the Tab key inserts a tab, click the Tab icon
in the toolbar.

> F:=x — xcos(x):

Now, define the operator, G, that maps x to the derivative of x cos(x).
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> G:=D(F)

G :=x—cos(x) — xsin(x)

F and G evaluated at g return the expected values.

-5 el 3)

For more information on the D operator, refer to the D help page. For a comparison of the diff command and D oper-
ator, refer to the diffVersusD help page.

Directional Derivative

To compute and plot a directional derivative, use the Directional Derivative Tutor. The tutor computes a floating-
point value for the directional derivative.

To launch the tutor:

* From the Tools menu, select Tutors, Calculus - Multivariate, and then Directional Derivatives. Maple launches
the Directional Derivative Tutor. See Figure 5.7.

] - - = - = [~ ]
@ Multivariate Calculus - irectional Derivative
File  Help
Plok Wwyindow
. Options

f= |x"2+y"2

Paink:

[|x )Y 1=[1 o1 ]
Direction:

[ ;2 ]

# of Frames: 10

Values

Ackual Value |2.6833

[ Cisplay |l Anirnate ” Plok Options ] l Close l

Maple Cormmand

Directionallerivative | x*2+v*2, [x, w1 = [1, 11, [1, 2], output =
plot):

Figure 5.7: Directional Derivative Tutor
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To compute a symbolic value for the directional derivative, use the Student[MultivariateCalculus]|[DirectionalDe-
rivative] command. The first list of numbers specifies the point at which to compute the derivative. The second list of
numbers specifies the direction in which to compute the derivative.

For example, at the point [ 1, 2], the gradient of 2+ y2 points in the direction [2, 4], which is the direction of greatest
increase. The directional derivative in the orthogonal direction [ -2, 1] is zero.

> with(Student[ MultivariateCalculus]):

> DirectionalDerivative(x2 +y2, [xy]=[1,2],[1,2] );
2J5

> DirectionalDerivative(x2 +y2, [xy]=[1,2],[—2,1 ]),
0

Series
To generate the Taylor series expansion of a function about a point, use the taylor command.

> taylor(sin(4 x)cos(x),x=0)

38 3
4_7
X 3x+30

421 X+ O(x6)

Note: If a Taylor series does not exist, use the series command to find a general series expansion.

For example, the cosine integral function does not have a taylor series expansion about 0. For more information, refer
to the Ci help page.

> taylor(Ci(x),x=0)

Error, does not have a taylor expansion, try series()

To generate a truncated series expansion of a function about a point, use the series command.

> series(Ci(x),x=0)

_ a2 1 o4 6
v + In(x) 1 x + 96 +O(x)

By default, Maple performs series calculations up to order 6. To use a different order, specify a non-negative integer
third argument.

> expansion ;= series(Ci(t) ,t=0,4)

expansion ;==Y + In(t) — % 2+ O(t4)

To set the order for all computations, use the Order environment variable. For information about the Order variable

and the O(t4) term, refer to the Order help page.

The expansion is of type series. Some commands, for example, plot, do not accept arguments of type series. To use
the expansion, you must convert it to a polynomial using the convert/polynom command.
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For information on Maple types and type conversions, see Maple Expressions (page 261).
For information on plotting, see Plots and Animations (page 187).

Integration

Maple can perform symbolic and numeric integration.

To compute the indefinite integral of an expression:

. . . o . [f dx
1. In the Expression palette, click the indefinite integration item
2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate x sin(ax) with respect to x:
> Jx sin(a x) dx

sin(ax) —xcos(ax) a

2
a

Recall that you can also enter symbols, including J and d, using symbol completion.

* Enter the symbol name (or part of the name), for example, int or d, and then press the completion shortcut key.

For more information, see Symbol Names (page 23).

You can also compute an indefinite integral using context menus. For more information, see Context Menus (page 32).
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To compute the definite integral of an expression:

[

1. In the Expression palette, click the definite integration item -z

2. Specify the endpoints of the interval of integration, integrand expression, and variable of integration, and then
evaluate it.

For example, to integrate ¢ “‘In(¢) over the interval (0, ):

> [ e “In(¢) dt
0

-at :
im | -€ In(z) + Ei(l,at) +vy+ In(a)

{— o a

Maple treats the parameter a as a complex number. As described in Assumptions on Variables (page 110), you can
compute under the assumption that a is a positive, real number using the assuming command.

> J e “'In(¢) df assuminga > 0
0

_ Y+ In(a)
a

To compute iterated integrals, line integrals, and surface integrals, use the task templates (Tools — Tasks — Browse)
in the Multivariate and Vector Calculus folders.

The int Command

b
J f dx and J f dx use the int command. To use the int command directly, specify the following arguments.

a
» Expression to integrate

* Variable of integration

> xsin(ax)

xsin(ax) 5.4

> int((5.4),x)

sin(ax) —xcos(ax) a
2 (5.5)

For a definite integration, set the variable of integration equal to the interval of integration.
T
> int[ (5.4),x=0 ..;)

T
> (5.6)



5.4 Calculus « 139

Numeric Integration

To perform numeric integration:

* Use the evalf(Int(arguments)) calling sequence.
Important: Use the inert Int command, not the int command. For more information, refer to the int help page.

In addition to the arguments accepted by the int command, you can include optional arguments such as method, which
specifies the numeric integration method.

> evalf | Int ! ,x=0.2,'method = Dexp
I'(x)

1.626378399
For information on the evalf command, see Numerical Approximation (page 279).

For information on numeric integration, including iterated integration and controlling the algorithm, refer to the evalf/Int
help page.

Differential Equations

Maple has a powerful set of solvers for ordinary differential equations (ODEs) and partial differential equations (PDEs),
and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see Other Specialized Solvers (page 93).
Calculus Packages
In addition to top-level calculus commands, Maple contains calculus packages.

VectorCalculus Package

The VectorCalculus package contains commands that perform multivariate and vector calculus operations on Vector-
Calculus vectors (vectors with an additional coordinate system attribute) and vector fields (vectors with additional
coordinate system and vectorfield attributes), for example, Curl, Flux, and Torsion.

> with(VectorCalculus) :

> BasisFormat( false) :

> SetCoordinates('cartesian|x,y,z]"):

> VectorFieldl := VectorField({-y,x, z))

-y
VectorFieldl :=| x

z

Note: For information on changing the display format in the VectorCalculus package, see the VectorCalculus|[Basis-
Format] help page.

Find the curl of VectorFieldl.
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> Curl(VectorFieldl ),

Find the flux of VectorField1 through a sphere of radius r at the origin.

> Flux(VectorFieldl,Sphere({0,0,0),7))

o

Compute the torsion of a space curve. The curve must be a vector with parametric function components.

> simplijj/( Torsion( <t, tz, t3> , t) ) assuming t::real
3
94 +94+1
For information on the assuming command, see The assuming Command (page 111).

For more information on the VectorCalculus package, including a complete list of commands, refer to the VectorCal-
culus help page.

To find other calculus packages, such as VariationalCalculus, refer to the index/package help page.

Student Calculus Packages

The Student package contains subpackages that help instructors teach concepts and allow students to visualize and
explore ideas. These subpackages also contain computational commands. The Student calculus subpackages include
Calculus1, MultivariateCalculus, and VectorCalculus. The Student[VectorCalculus] package provides a simple
interface to a limited subset of the functionality available in the VectorCalculus package.

For information on using Maple as a teaching and learning tool, and some computational examples, see Teaching and
Learning with Maple (page 148).

5.5 Optimization

Using the Optimization package, you can numerically solve optimization problems. The package uses fast Numerical
Algorithms Group (NAQG) algorithms to minimize or maximize an objective function.

The Optimization package solves constrained and unconstrained problems.
* Linear programs

* Quadratic programs

* Nonlinear programs

* Linear and nonlinear least-squares problems

The Optimization package contains local solvers. In addition, for univariate finitely-bounded nonlinear programs with
no other constraints, you can compute global solutions using the NLPSolve command. To find global solutions generally,
purchase the Global Optimization Toolbox. For more information, visit

http://www.maplesoft.com/products/toolboxes.
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Point-and-Click Interface
The primary method for solving optimization problems is the Optimization Assistant.

To launch the Optimization Assistant:

* From the Tools menu, select Assistants, and then Optimization.

Maple launches the Optimization Assistant. See Figure 5.8.

Optimization Assistant
Sobver Problsm
(3 Local Defauk Objective Function
5
X p-y
() Nondrsar
Constraints and Bounds
[x e [0,5]
ye[0,5]
Oiptions T+y<é
(3 Minimize (%) Maximize
Feasibiity Tolerance defauk

Indtial Values Edi

Solution

Chjecrive valus: 134.491161539748162
Optinality Tolerance defat x = 4,53559292539129

¥y = 1.46440707460871

Tteraticn Limi defaul
Infirdte Bourd default
O Quk, Return | Solution | [ el J[Csobee J[ Pt [ ok |

Figure 5.8: Optimization Assistant

To solve a problem:
1. Enter the objective function, constraints, and bounds.
2. Select the Minimize or Maximize radio button.

3. Click the Solve button. The solution is displayed in the Solution text box.

You can also enter the problem (objective function, constraints, and bounds) in the calling sequence of the Optimiza-
tion[Interactive] command.

For example, find the maximum value of x3y - y2 subject to the constraints x +y < 6,x € [0,5],y € [0,5].

> Optimization[Interactive](x3y — yz, {x+y<6,x=0.5y=0 5})
[134.491161539748162, [x =4.53559292539129189, y = 1.46440707460870746]
* When the Optimization Assistant opens, select Maximize, then Solve.

After finding a solution, you can plot it. To plot a solution:

* In the Optimization Assistant window, click the Plot button. The Optimization Plotter window is displayed. See
Figure 5.9.
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Note: When you close the Optimization Assistant, you can choose to return the solution, problem, command used,
plot, or nothing, using the drop-down in the bottom right corner of the assistant window.

@ Optimization Plotter

i3]
o
f]

11

430

380

280

180

]
]

[
S

Ranges

Range of x vi = 0 i[5 exkrema at 4,53559
Range of \,rgv"= 0 S extrema at 1,46441
Range of ﬁijiect-ive values = default .. default extrema of 134.491
Plot Using Problem Damain

Plot Constraints [ | as Surfaces

Figure 5.9: Optimization Assistant Plotter Window

For information on the algorithms used to solve optimization problems, refer to the Optimization/Methods help page.

Large Optimization Problems

The Optimization Assistant accepts input in an algebraic form. You can specify input in other forms, described in
the Optimization/InputForms help page, in command calling sequences.

The Matrix form, described in the Optimization/MatrixForm help page, is more complex but offers greater flexibility
and efficiency.

For example, solve the linear program:

Maximize ¢'x subject to Ax < b, where x is the vector of problem variables.

1. Define the column vector, ¢, of the linear objective function.
> with(LinearAlgebra) :

> ¢ :=RandomVector| column](20, outputoptions = [ 'datatype'=float']) :

2. Define the matrix A, the coefficient matrix for the linear inequality constraints.

> A = RandomMatrix(19, 20, outputoptions = [ 'datatype' = float']):
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3. Define the column vector b, the linear inequality constraints.

> b :=RandomVector| column](19, outputoptions = [ 'datatype' = float']):

4. The QPSolve command solves quadratic programs.
> Optimization| LPSolve](c, [ A4, b], maximize, assume = nonnegative)

1.. 20 Vector

column

Data Type: float
43.2673034492019, ype: floatg

Storage: rectangular

Order: Fortran_order

This example uses a random data set to demonstrate the problem. You could also read data from an external file as
Matrices, and use that data. For details and an example, see Reading from Files (page 317).

Note: For information on creating matrices and vectors (including how to use the Matrix palette to easily create
matrices), see Linear Algebra (page 119).

For additional information on performing efficient computations, refer to the Optimization/Computation help page.
MPS(X) File Support

To import linear programs from a standard MPS(X) data file, use the ImportMPS command.

Optimization Package Commands

Each Optimization package command solves the problem using a different optimization method. These are described
in Table 5.9, along with the general input form for each command.

Table 5.9: Optimization Package Commands

Command Description

LPSolve Solve a linear program (LP), which involves computing the minimum (or maximum) of a linear
objective function subject to linear constraints; input is in equation or Matrix form

LSSolve Solve a least-squares (LS) problem, which involves computing the minimum of a real-valued
objective function having the form %(fl (x)2 +_f2(x)2 +...+fq(x)2), where x is a vector of

problem variables, possibly subject to constraints; input is in equation or Matrix form

Maximize Compute a local maximum of an objective function, possibly subject to constraints

Minimize Compute a local minimum of an objective function, possibly subject to constraints

NLPSolve Solve a non-linear program (NLP), which involves computing the minimum (or maximum) of
a real-valued objective function, possibly subject to constraints; input is in equation or Matrix
form

QPSolve Solve a quadratic program (QP), which involves computing the minimum (or maximum) or a
quadratic objective function, possibly subject to linear constraints; input is in equation or Matrix
form

For a complete list of commands and other Optimization package information, refer to the Optimization help page.
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5.6 Statistics

The Statistics package provides tools for mathematical statistics and data analysis. The package supports a wide range
of common statistical tasks including quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the Statistics package provides a wide range of symbolic and numeric tools
for computing with random variables. The package supports over 35 major probability distributions and can be extended
to include new distributions.

Probability Distributions and Random Variables

The Statistics package supports:

» Continuous distributions, which are defined along the real line by probability density functions. Maple supports
many continuous distributions, including the normal, Student-t, Laplace, and logistic distributions.

» Discrete distributions, which have nonzero probability only at discrete points. A discrete distribution is defined by
a probability function. Maple supports many discrete distributions, including the Bernoulli, geometric, and Poisson
distributions.

For a complete list of distributions, refer to the Statistics/Distributions help page.

You can define random variables by specifying a distribution in a call to the RandomVariable command.
> with(Statistics) :

> X := RandomVariable( Poisson(1)) :

Find the probability distribution function for X. (For information on statistics computations, see Statistical
Computations (page 145).)

> PDF(X,1)

i Xke_)”Dirac(t —k)
k=0 k!
Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the Distribution command.

t<0

> U:= Distribution| PDF= |t — t<3

0
1
3
0 otherwise

To construct a piecewise-continuous function in 1-D Math, use the piecewise command, for example, t ->
piecewise(t < 0, 0, t < 3, 1/3, 0).

Define a new random variable with this distribution.
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> Z:=RandomVariable(U): PDF(Z,t)

0 t<0
1
— t<3
3
0 otherwise
Calculate the mean value of the random variable.
> Mean(Z)
3
2

Statistical Computations

In addition to basic functions, like mean, median, standard deviation, and percentile, the Statistics package contains
commands that compute, for example, the interquartile range and hazard rate.

Example 1 - Interquartile Range

Compute the average absolute range from the interquartile of the Rayleigh distribution with scale parameter 3.

> InterquartileRange(Rayleigh(3))

/36 JIn(2) — -181n[%J

To compute the result numerically:
* Specify the 'numeric' option.
> InterquartileRange(Rayleigh(3), 'numeric')
2.719744818

Example 2 - Hazard Rate

Compute the hazard rate of the Cauchy distribution with location and scale parameters a and b at an arbitrary point
t.

> HazardRate(Cauchy(a, b),t)
1

(t— )2 1 arctan( t;a)
o1 a1
b 2 T

You can specify a value for the point t.
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> HazardRate( Cauchy(a,b), % j

p—

1 2
[ - — a) arctan

nh| 1+

A2 ) ||IL

b 2 n
You can also specify that Maple compute the result numerically.
> HazardRate( Cauchy(10,1), %, 'numeric']

0.003608801460

For more information, refer to the Statistics/DescriptiveStatistics help page.

Plotting

You can generate statistical plots using the visualization commands in the Statistics package. Available plots include:

* Bar chart

* Frequency plot
* Histogram

* Pie chart

* Scatter plot

o . 2
For example, create a scatter plot for a distribution of points that vary from sm(

by a normally distributed sample.
> N :=200:
> U:=Sample(Normal(0,1),N):

> X = <seq(x,x=1..N)>:

2
> Y= <seq(sin( ;x ] + Ulx] ,x=1 ..N]>:

] by a small value determined
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> ScatterPlot( X, Y, title'= "Scatter Plot");

Scatter Plot

1 o

—T
T6Q 120 140 160
°

_05_- @ <>°¢

To fit a curve to the data points, include the optional fit equation parameter.

Using the plots|display] command, create a plot that contains:

* ascatter plot of the data points

T )

el
18Q “200

+ a quartic polynomial fitted to the data points: f(x) =ax* + bx> +cx* +dx +e

27‘cx)
N

> P = ScatterPlot(X, Y, fit= [a b e +dx + e,x], thickness=2):

« the function sin(

2
>0 ::plot(sin [ ;x J ,Xx=1..N, thickness =2, color:redJ :
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> plots| display (P, Q, 'title' = "Scatter Plot with Fitted Quartic Polynomial")

Scatter Plot with Fitted Quartic Polynomial

140 160 189 °200

For more information on statistical plots, refer to the Statistics/Visualization help page.
For an overview of plotting, see Plots and Animations (page 187).
Additional Information

For more information on the Statistics package, including regression analysis, estimation, data manipulation, and data
smoothing, refer to the Statistics help page.

The Data Analysis Assistant provides an interactive way to perform data analysis. For more information, refer to the
Statistics[InteractiveDataAnalysis] help page.

5.7 Teaching and Learning with Maple

Table 5.10 lists the available resources for instructors and students. For additional resources, see Available
Resources (page 46).

Table 5.10: Student and Instructor Resources

Resource Description
Student Packages, Tutors, and The Student package contains computational and visualization (plotting and
Demonstrations animation) functionality, and point-and-click interfaces for explaining and exploring

concepts (Tools—Tutors). For more information, refer to the Student help page.

Maple's Demonstrations provide interactive visual illustrations of Precalculus
concepts (Tools—Demonstrations). Use the provided Demos, or learn how these
are created and using Maple's embedded components to create your own. For more
information on how the Demonstrations were created, refer to the
Demonstrations/Details help page.

The Demonstrations are connected to more complete teaching material provided
in the Teacher Resource Center.
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Resource Description

Teacher Resource Center The Maple Teacher Resource Center contains resources and tips for teachers using
Maplesoft products to help in the classroom. Available resources include:

* Classroom content for subjects including Precalculus, Calculus, and Engineering
* Training videos

» E-books

(http://www.maplesoft.com/teachercenter)

Maple Portal The Maple Portal includes material designed for all Maple users as well as specific
portals for students and educators. The Maple Portal includes:

* How Do ... topics that give quick answers to essential questions

 Tutorials that provide an overview of topics from getting started to plotting and
working with matrices

» Navigation to portals with specialized information for students, math educators,
and engineers

Access the portal from the Help menu (Help — Manuals, Resources, and More
— Maple Portal).

Mathematics and Engineering Dictionary The Maple Help System has an integrated dictionary of over 5000 mathematics
and engineering terms. You can search the dictionary by entering a term in the Help
System search field.

Maple Application Center The Maple Application Center contains tutorials and applications that help
instructors begin using Maple and use Maple in the classroom. Browse the many
resources in the Education and Education PowerTools categories.

(http://www.maplesoft.com/applications)

Student Help Center The Maple Student Help Center contains tutorials and applications that help students
learn how to use Maple, explore mathematical concepts, and solve problems.
Auvailable resources include:

* Study guides - Complete lessons with examples for academic courses, including
precalculus and calculus. For example, the Interactive Precalculus Study Guide
contains worked problems, each solved as in a standard textbook, using Maple
commands and custom Maplet graphical interfaces.

» Free course lessons for many subjects including precalculus to vector calculus;
high school, abstract, and linear algebra; engineering; physics; differential
equations; cryptography; and classical mechanics.

+ Applications for students, written by students, providing examples in many
subject areas.

» Student FAQs with answers from experts.

(http://www.maplesoft.com/academic/students)

Student Packages and Tutors

The Student package is a collection of subpackages for teaching and learning mathematics and related subjects. The
Student package contains packages for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:
» Teach concepts without being distracted by the mechanics of the computations.

* Create examples and quickly update them during a lesson to demonstrate different cases or show the effect of the
variation of a parameter.

* Create plots and animations to visually explain concepts, for example, the geometric relationship between a math-
ematical function and its derivatives (Tools— Tutors—Calculus - Single Variable—Derivatives). Sec Figure 5.10.


http://www.maplesoft.com/teachercenter
http://www.maplesoft.com/applications
http://www.maplesoft.com/academic/students
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@ Calculus 1 - Derivative
File Help
. Plat Windaw Enter a function and an interval [a,b]
6. | Fix) = w*cos(x)
a=|0 b = | 2*%Pi
4.1
¥
3 Derivatives
0 | Fix) = cost-cksing=)
Display F'{=) in the plak
=3l | FUx) = |-2%sinfx)-x*cos(x)
[] Display F'{x) in the plot
=i o]
| Display | [ Plat ©ptions ] [ Close ]
Maple Command
|DerivativePlot (X*cosix),0 .. 2%P1i, 'order'=[1],'wiew'=[0.

|6.28, -4.24 .. 7.24]):

Figure 5.10: Calculus 1 Derivatives Tutor

Students can:

* Perform step-by-step computations, for example, compute a derivative by applying differentiation rules using com-
mands or a tutor (Tools—Tutors—Calculus - Single Variable— Differentiation Methods). See Figure 5.11.

* Perform computations.

* Visually explore concepts.
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@ Calculus 1 - Differentiation Methods
File Edit Rule Definition  Apply Rule  Understood Rules  Help
Enter a function
Funckion | sinxiix™3 Wariable x
%[MW The power rule has been
d XB 4 applied.
——sin(x X3-sm x T X3
(o) 2 -simin) (5-(2))
= xﬁ
d [w] Shava Hints
[ —sm(x)] -3 sinix) x
xﬁ
[ Zonskant ” Identity l
[ Sun ” Difference l
[ Produck ][ Cuokient ]
[ Power ” Chain Rule l
[ Inktegral ][ Retarite ]
[ Exponential ” Matural Logarithm l
<krig= v 1 ;:hyperboliw v
<krig= <archyperbolic: ||
=in -
cos %
Ean
[ Undo ] [ Mext Step ] [ all Steps ] [ Close ] CsC
sec
[{a]d

Figure 5.11: Calculus 1 Differentiation Methods Tutor

Tutors provide point-and-click interfaces to the Student package functionality.

To launch a tutor:
1. From the Tools menu, select Tutors.
2. Select a subject, for example, Calculus - Multivariate.

3. Select a tutor, for example, Gradients.

Maple inserts the Student[MultivariateCalculus|| GradientTutor]() calling sequence (in Worksheet mode), and launches
the Multivariate Calculus Gradient Tutor.

By rotating the three-dimensional plot, you can show that the gradient points in the direction of greatest increase of
the surface (see Figure 5.12) and show the direction of the gradient vector in the x-y plane by rotating the plot (see
Figure 5.13).
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@ Multivariate Calculus - Gradient

File Help .

i "
Plot \Window
Options

F= xm3fixr2+y2+1]

[ X Y ]=[ [21 1] ]
Values
ﬂ
Afx, y]=[2, 1], =7, grad(f) 4
9

Display H Gradient Field Plat ” Plat Options l[ Close ]

Maple Command

Gradient | "3/ (x*Z24+y*24+1), [%x, ¥] = [2, 1], output = plot, axes = hoxed,
scaling = unconstrained) !

Figure 5.12: Multivariate Calculus Gradient Tutor

@ Multivariate Calculus - Gradient

File Help

Plok Window
Options

= x™3/x 2+y"2+1)

[ X Y ]=[ [21 1] ]
Values
x 10
Afx, y]=[2, 1], =7, grad(f) 4
z 9

Display H Gradient Field Plat ” Plat Options l[ Close ]

Maple Command

Gradient | "3/ (x*Z24+y*24+1), [%x, ¥] = [2, 1], output = plot, axes = hoxed,
scaling = unconstrained) !

Figure 5.13: Multivariate Calculus Gradient Tutor Showing x-y Plane
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When you close the tutor, Maple inserts the 3-D plot.

> Student| MultivariateCalculus [ GradientTutor]( );

Many Student package commands can return a value, mathematical expression, plot, or animation. This allows you
to compute the final answer, see the general formula applied to a specific problem, or visualize the underlying concepts.

For example, the Student[VectorCalculus][LinelInt] (line integral) command can return the following.
* Plot that visually indicates the vector field, path of integration, and tangent vectors to the path
* Unevaluated line integral

* Numeric value of the line integral

> with(Student| VectorCalculus)):
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> Linelnt(VectorField( <y, —x>), Circle( < 0,0>,1), 'output ='plot)

S 7 NN\
a4 NN
avs NN
Va4 NN
/7 NN\
/7 N A
!l 7 A
11 Vo
11 Vo
[ ] !
11 X [
| ‘ |
A A /o
A A /]
N A / /
NN /7 /
NN 7/ /
NN a4
NN s
NANANNSN SN~~~ A S
The path of integration, vector(s) tangent to the path, and vector-field

arrows

> Linelnt(VectorField( <y, —x>), Circle( < 0,0>,1), 'output ="integral')

2n
I (—sin(t)2 — cos(t)z) de (5.7
0

To evaluate the integral returned by the output = integral calling sequence, use the value command.
> value((5.7))
-2rn (5-8)

By default, the LineInt command returns the value of the integral.
> Linelnt(VectorField( <y — x, —x —y>), Circle( <0,0>,r))

~2mi?
For more information on the Student package, refer to the Student help page.
Calculus Problem Solving Examples

Maple is a powerful application with many resources to guide you. The following examples provide you with scenarios
to learn about using Maple resources and the Maple program.

When using Maple to solve a problem, consider the following process.
1. Formulate your problem.

2. Obtain Maple resources that allow you to solve it.
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Problem

Scenario A:

Your company is designing a bottle for its new spring water product. The bottle
must contain 18 ounces of water and the height is fixed. The design includes an

undulating curved surface. You know the amplitude and equation of the curve,
but you must find the radius. You require the Volume of Revolution.

Scenario B:

You want to teach your students the concept of a Volume of Revolution.
Specifically, you want to plot and compute the volume of a solid generated by

rotating f(x),a < x < b, about an axis or a line parallel to an axis.

- Tutors
Check for
Existing Tools ———
p Task
P, Templates
// . Help Pages
Brob| / Check for —
roblem — i B
Instructions ~__ Example
Worksheets
. Applications
\ Checkfor
Other Ready- — Maple
to-Use Resources ~ application
Center

Figure 5.14: Flowchart of solving a problem

Check for Existing Tools: Tutor
Begin by examining the Tools menu for a Tutor to a Volume of Revolution problem.

To access a Tutor for the Volume of Revolution:

1. From the Tools menu, select Tutors, and then Calculus-Single Variable. Notice that a Volume of Revolution tutor
exists.

2. Click the Volume of Revolution menu item. The following Maple command is entered in your document.
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> Student| Calculus ][ VolumeOfRevolutionTutor]( );

The Volume of Revolution Tutor is displayed. See Figure 5.15. Use this tutor to enter a function and an interval,
view and manipulate the corresponding plot, and view the full Maple command associated with your entries and selec-
tions.
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@ Calculus 1 - Volume of Revolution
File Help

Flok Windaw Enter 1 or 2 functions and an inkerval

Flxd = 1+, 10%Cos{10%x)

gl =
a=0 b=&
Riermann surm
Method; midpoint V
Tumber of partitions: &

Waolume of the Solid

]

m(l+ _lt]cos[lli)_‘c))2 dx
0
= 1892510790

Display
Wolume () Disks (%) Region () Mone
Line of Revolution

(¥} Harizantal () wertical

Distance of rotation line

fram coordinate axis = o
i Display | Plat Opticns l [ Close ]
Maple Command
VolumelfRevolution(l+.10%zos(10*%x) , 0..6, 'axis'shorizontal, 'distancefromaxis' = 0,
'showvolume' =true, 'showsum'=false, 'showregion'=trues, 'wethod'=midpoint, 'partition's= v

Figure 5.15: Volume of Revolution Tutor
After you Clese the tutor, the plot is inserted into your worksheet.

Check for Existing Tools: Task Template

1. From the Tools menu, select Tasks, and then Browse. The Browse Tasks dialog opens, displaying a list of tasks
in the left pane. The tasks are sorted by subject to help you quickly find the desired task.

2. Expand the Calculus - Integral— Applications — Solids of Revolution folder.

3. From the displayed list, select Volume. The Volume of Revolution task is displayed in the right pane of the Browse
Tasks dialog.

4. Select the Insert into New Worksheet check box.

5. Click Insert Default Content. Before inserting a task, Maple checks whether the task variables have assigned values
in your worksheet. If any task variable is assigned, the Task Variables dialog opens allowing you to modify the
names. Maple uses the edited variable names for all variable instances in the inserted task. The content is inserted
into your document. See Figure 5.16.
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Y Volume of Revolution

Calculate the volume of revolution for a solid of rewvalution when a function i rotated about the horizontal or vertical asis.

Enter the function as an expression and specify the range:

> sin(x) cos(x) + 1,0 ;

sin{x) cos(x) + 1,0..= Pi (i N

Calculate the wolume of revolution:

= Student| Calewdus 1| Volume OfRevolution (1))
4 9 .2
P1+ e Fr 2)

Display the floating-point value using the evalf command:

[:» evalf ((2))
56893245131 3

Figure 5.16: Inserted Task Template

6. When a Task Template is inserted, parameters are marked as placeholders, denoted by purple font. To navigate
between placeholders, press the Tab key. After updating any parameters, execute the command by pressing Enter.

Check for Instructions: Help Page and Example Worksheet
The help system provides command syntax information.

To access a help page:
1. From the Help menu, select Maple Help.

2. In the search field, enter volume of revolution and click Search. The search results include the command help
page, the dictionary definition, and the associated tutor help page.

3. Review the calling sequence, parameters, and description in the Student[Calculus1][VolumeOfRevolution] help
page.

4. Copy the examples into your worksheet: from the help system Edit menu, select Copy Examples.

5. Close the Help Navigator.

6. In your document, from the Edit menu, select Paste. The examples are pasted into your document.

7

. Execute the examples and examine the results.

To access an example worksheet:
1. In the worksheet, enter index/examples. The Example Worksheet Index opens.
2. Expand the Calculus topic.

3. Click the examples/Calculus1IntApps link. The Calculusl: Applications of Integration worksheet opens. See
Figure 5.17.

4. Expand the Volume of Revolution topic.

5. Examine and execute the examples.
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Calculus 1: Applications of Integration

[ The Student[Calculus1] package contains four routines that can be used to both work with and wisualize the concepts of function averages,
arc lengths, and volumes and surfaces of revolution. This worksheet demonstrates this functionality.

For further mformation about any command i the Caleulus] package, see the corresponding help page. For a general overwiew, see
Calculusl,

Getting Started

While any comnand in the package can be referred to using the long form, for example, Student[Calculusl][DerivativePlot], it iz easier,
| and often clearer, to load the package, and then use the short form command names.

> restart
| = with{Student| Caleulus1])
| The following sections show how the routines worke In some cases, examples show to use these wisualization routines in conjunction with the
| single-steppmg Caleulus] routines.

P Function Average

P Volume of Revolution
P~ Arc Length

P Surface of Revolution

Main: Visualization
Previous: Integration

Figure 5.17: Example Worksheet

Check for Other Ready-To-Use Resources: Application Center

The Maple Application Center contains free user-contributed applications related to mathematics, education, science,
engineering, computer science, statistics and data analysis, finance, communications, graphics, and more.

To access a free application for volume of revolution:
1. Go to the Maplesoft web site, http://www.maplesoft.com.
2. In the menu of the main web page, click Community, and then Application Center.

3. In the Application Search section, enter Calculus 2 in the Keyword or phrase field.

Calculus 2

Any Application Type|w |

B 2dvanced Search

4. Click Search.
5. From the search results page, under Displaying applications, click the Click here link.
6. From the list of archived applications, select Calculus II: Complete Set of Lessons.

7. Click on the Download Maple Document link.


http://www.maplesoft.com
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Toolkit

= Download Maple
= Dgcurnent

EQ vigw HTML Versian

Tell a Colleague ahout
this Application

ﬂ Contactthe Author
@ Contribute Your Work

Q Evaluate Maple

8. Download the .zip file.
9. Extract the L2-volumeRevolution.mws file.

10. Execute the worksheet and examine the results.

5.8 Clickable Math

For years, Maple has led the way in making math software easy to use. With its collection of Clickable Math tools,
including palettes, interactive assistants, context-sensitive menus, tutors, and more, Maple has set the standard for
making it easy to learn, teach, and do mathematics.

Two key features of the Clickable Math tool collection are Drag-to-Solve and Smart Popups.

Smart Popups
Smart Popups are menus that are invoked when you select an output equation, expression or a subexpression.

With Smart Popups you can:

* select operations to apply to just one part of your equation or mathematical expression, leaving the rest unchanged.
* Preview the result of the operation before going ahead.

» Explore your expression to deepen your understanding of the problem.

* Easily determine if your subexpression can be factored, what its plot looks like, what mathematical identities could

be applied, and more.

Drag-to-Solve

The Drag-to-Solve feature enables you to solve your equations step-by-step by dragging terms to where you want them
to be.

With Drag-to-Solve you can:
 Easily take complete control over each individual step of your calculation.

» Let Maple apply the appropriate addition, subtraction, division, or multiplication operation to both sides of your
equation, to avoid mechanical errors.

» Keep the full record of steps produced by Maple to document your work.

For more information on Smart Popups and Drag-to-Solve, as well as examples, see the worksheet,expressions,click-
ablemath help page.

Examples

This chapter is designed to show several ways to solve the same problem in Maple. Throughout these examples, you
will need to insert new document block regions. This is done through the Format menu, by selecting Create Document



5.8 Clickable Math

Block. Also, these examples only use the keyboard keys needed for a Windows operating system. Refer to Shortcut

Keys by Platform (page xiii) for the keys needed for your operating system.

Example 1 - Graph a Function and its Derivatives

On the interval [ -, ], graph £, /', and /" for f(x) =x

We solve this problem using the following methods:
» Solution by Context Menus (page 161)
 Solution by Tutor (page 163)

* Access the Tutor from a Task Template (page 165)

Solution by Context Menus

cos(x).

Action Result in Document

1. Enter the expression x cos(x). xcos(x)

Make a copy of the expression and calculate the derivative: differentiate w.r.t. x .
xcos(x) ————— > cos(x) — xsin(x)

2. Insert a new document block region by selecting from the

Format menu Create Document Block.

. Highlight the original expression. Ctrl + drag the expression
to the new document block.

. Right-click the expression and select Differentiate — With
Respect To — x.

Make a copy of the derivative and calculate the second
derivative:

5. Insert a new document block, and Ctrl + drag the derivative
to the document block.

6. Right-click the derivative and select Differentiate — With
Respect To — x.

cos(x) — xsin(x)

differentiate w.r.t. x

-2sin(x) — xcos(x)

Plot the original expression:

7. Insert a new document block, and Ctrl + drag the original
expression to the new block.

8. Right-click the expression and select Plots — Plot Builder.

9. In the Interactive Plot Builder: Select Plot Type dialog,
change the x Axis range to -Pi to Pi, and then click Plot.

xcos(x)

~a o
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Action

Result in Document

Add the first and second derivatives to the plot: xcos(x)
10. Select and then Ctrl + drag the derivative of the expression

N
onto the plot region. Do the same for the second derivative.

INER

= A

Enhance the plot by adding a legend using context menus:

11. Right-click in the plot region and select Legend — Show

Legend.

xcos(x) Curve 2

Curve 3

12.In the legend, double-click Curve 1. Notice that the Text

icon is selected in the toolbar, . Delete the text and

select the Math icon in the toolbar, . This allows
you to enter 2-D Math in a text region. Enter the original
expression, x cos(x).

13.Repeat for Curve 2 and Curve 3.
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Action Result in Document
Add a title: X cos(x)
14.Right-click in the plot region and select Title — Add Title.
.
15.In the legend, replace the text New title with the text "Plot
the expression " Plot the expression x cos(x)and its derivatives
3 -4
16. Click the Math icon, and enter the expression x cos(x).
Click the Text icon once again and enter " and its )
derivatives".
o pnaN/ 0 o\ m\ pr o«
4 2 7 4 2 4
-14 X
,2 -4
-3 4
xcos(x) cos(x) — xsin(x)

—— -2sin(x) — xcos(x)

Solution by Tutor

The Student Calculus 1 package contains a tutor called Derivatives, which displays a plot of the expression along
with its derivatives. In this example, we solve the same problem as previously, using this tutor

Action

Result in Document

1.

Load the Student Calculus 1 package. From the
Tools menu, select Load Package — Student
Calculus 1.

. Ctrl + drag the expression x cos(x) to a blank
document block region.

Loading Student:-Calculus1
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Action

Result in Document

3. Right-click the expression and select Tutors —
Calculus - Single Variable — Derivatives. Note:

@ Calculus 1 - Derivative

) . ) File  Help
The Tutors menu is now available in the context :
menu because we loaded the Student Calculus 1 Flek Windaw Enter a function and an interval [,b]
package in step 1.
) 3 | Fix) = |x*cos(x)
In the Derivative Tutor, the color swatch shown beside " a=pi b=l
the original expression is the color used for the curve in
the plot region. Similarly for /” (x) and f” (x). —
4. Change the lower endpoint to -Pi. Select the check T PN A
box to display /" (x) in the plot. Click Display to T4 T a1\ 4 \z N4 | Fixd = cosixjctsing)
make these changes take effect. 5] Display F'(xc} in the plat
B | 00 = |-2¥sin(x)-x*cos(x)
-3 Display F'{x) in the plot
[ Display i [ Flat Options ] [ Close ]
Maple Carmmand
DerivativeFPlot (x*cos (%) ,-FP1 .. Pi, 'order'=[1,
2], 'wview'=[-3.14 .. 3.14, -3.77 .. 3.771:
5. You can change the expression and modify plot
options from within this tutor. For each change made, derivative tutor
click Display to view the altered plot. When complete, x cos(x)
click Close to display the resulting plot in the
document.
3 -
v 2
I ) 1 1 1 1
-m jmn W T L4 L 31 T
4 2 7 4 2 4
-1 4 X
- 2 -
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Access the Tutor from a Task Template

Maple also comes with a Task Template to solve this

its Derivatives.

. In the table of contents of the Task Browser dialog, select

Calculus -Differential > Derivatives — Graph f(x) and

problem without using any commands.
Action Result in Document
1. Launch the Task Template Browser by selecting Tools — =105 Calculus - Differential
Tasks — Browse. -3 Limits
2

) Derivatives

Detivatives by Definition
Difference (Mewton) Quokient
Differentiation - Formal Rules
Expression

Functional Operator

aGraph f{x) and Its Derivatives

the task template into the current document.

. Click Insert Minimal Content at the top of the dialog to insert

Graph of / /%, and /¥ in a Specified Interval

Enter the function 7(x) to be evaluated and the interval on which to plot it
i(x)= |

Interval: [ | . |

1

[ Launch Differentiation Tukor ]

. Enter the new expression x*cos(x) in the f(x) region.

. Enter the interval [ -7, n]. To insert the symbol for pi, you

can use command completion or select ©t from the Common
Symbols palette.

Enter the function f(x) to be evaluated and the interval on which to plot it

’x- cos(x)

Interval: [ ‘ -m

£(x)

I ]

[ Launch Differentistion Tukor ]
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Action

Result in Document

6. Click Launch Differentiation Tutor to launch the same tutor

as in the previous solution.

. When complete, click Close. A plot of the expression and its
derivatives displays in the plot region of the inserted task
template.

J>.|;| B
Nis

£ Ml::]

Example 2 - Solve for x in a Quadratic Equation

Solve for x in the equation (x — 7)2 + (x— 1)2 = 4( (x — 1)2 + (x— 4)2).

We solve this problem using the following methods:

* Step-by-step Solution Using Smart Popups (page 166)
* Solution through Equation Manipulator (page 167)
* [Instant Solution (page 169)

Step-by-step Interactive Solution (page 169)

Graphical Solution (page 170)
Step-by-step Solution Using Smart Popups

Use Smart Popup menu options to solve for x.

Ensure that Smart Popups are enabled by selecting the Toggle
the display of clickable math popup icon in the Maple
worksheet toolbar

Copy the equation

(x— 7)2 + (x— 1)2:4((x— 1)2 + (x—4)2) to a new
document block region and press Enter

=724+ x=1)=4((x—12>+x—4)?)

=724 =12 =4(x—1)>+4(x—4)? (5.9)

Highlight the Maple output expression. A Smart Popup window
opens.

From the available options, select the solve option to solve the
equation.

swap sides

4(x—1) 44 (x—4) = (x—7)°

solve

({x=1). (x=3))

Plot both sides

\
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The solution to the equation is displayed. (x — 7)2 (- 1)2 _ 4( (x — 1)2 F(x— 4)2)

=72+ (x—1)2=4(x—1)>+4(x—4)> (10

solve (x-7)"2+(x-1)"2 = 4*(x-1)"2 +4*(x-4)"2

[[x=1], [x=3]] (5.11)

You can also use Smart Popups to plot the expression. (x — 7)2 (- 1)2 _ 4( (x — 1)2 +(x— 4)2)

=72+ (x—1)P=4(x—1)2+4(x—4> 612

subtract 4*(x-1)"2+4%*(x-4)"2 from both sides

(k=72 =3(x—1)—4(x—4)7>=0 (5.13)

normal (x-7)"2-3%(x-1)"2-4*(x-4)"2

-6 +24x—18=0 (5.14)

2D Plot -6*x"2+24*x-18

(5.15)

Solution through Equation Manipulator

Maple provides a dialog that allows you to single-step through the process of manipulating an expression. This manip-
ulator is available from the context menu.
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Action

Result in Document

1. Enter the equation

=72+ (x—1)2=4((x—1)> + (x—4)?) inanew
document block region.

=724+ x=1)=4((x—12>+x—4)?)

2. Right-click this equation and select Manipulate Equation.
The Manipulate Equation dialog displays.

(B Equation Mankpibator

group terms on a specified side. With the left side already
selected, click Do.

[ shaw steps stacked vertically

E1l :

EZ

History

Operations
Unda/Reda
Addition

fGroup berms on | left

ﬂs’dc

(x=T7) "2+ ({x-1]"2 =
GF [x-1)*Z+a (¥-4)*2;

:= lh=({E1l} - rhs(El)

= 0;

Fower

Square both sidas

(o7 + (x=1) =4 {x-1)% £ 4 [x-4)°
] e stepes starked vertcaly
Histary
Bl = “24ix-1]"2 =
A% (i)t Bl ¥ =) 42
Opi B
Lirsbeqfieds P
Souare both sides )
Addtin Tabe e oot of both sdes De
G teimis on bt w | e (£ mecn et e prower |2 [i]
Esponarkists both sides wirg bass |2 [ ]
add [He7r2 w| beequation Lo
Mecslansous Opbiatid
Pl stion Apply e | 1o both sides: [Loe]
Claar denomngtors [ ] Aty [sepdly w10 [ftside v =]
wh no EsURQLIoNs | .
Huktiphy scustion by 7"2+011°2) [ [ ] e | T (=)
Rabarn Pk Estun Reps Cancel
Group all of the terms to the left: 3] Equation Manipulator
3. In the Addition region, the Group terms row allows you to | [ (x-7)% 4 (x-17=4 (x-12 + 4 (x-4)7 = (x-7)7-3 (x-1)7-4 (x-4)> =0

Take square roct of both sides

Raise both sides to power | 3

Expand the left side of the equation:

4. In the Miscellaneous Operations region, we can manipulate
the equation by applying a command from the drop-down
menus. Since we want to expand the left side of the equation
only, click the first drop-down menu in the second row and
select expand. Click Do.

Apply

Miscellaneous Operations

V ta both sides

left side

exp

Apply |expand V to

Complete the square on the |left side V

b

Factor the equation:

5. From the same drop-down menu, select factor and click Do.

Apply |Factor (sl to

left side

*lE
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Action

Result in Document

6. Click Return Steps to close the dialog and return all of the
steps to the Maple document.

=724+ x=1)=4((x—12>+(x—4)?)

manipulate equation
_—

x—7)2 4+ (x—1) =4(x—-1)2+4(x—4)?

x—72=3x—-1)2—4(x—4)7>=0

-6 +24x—18=0
-6(x—1)(x—3)=0

7. Ctrl + drag the factored form of the original equation to a new
document block region.

8. Right-click and select Solve — Obtain Solutions for — x.

solutions for x
il

6(x—1)(x—3)=0 1,3

Instant Solution

To apply an instant solution to this problem, use context menus.

Action

Result in Document

1. Ctrl + drag the equation

(x— 7)2 + (x— 1)2:4((x— 1)2 + (x—4)2) to a new
document block region.

=724+ x—=1)=4((x—1>+(x—4)?)

2. Right-click the expression and select Solve — Obtain
Solutions for — x.

solutions for x

=772+ x—12=4(x—=1)2+ (x—4)?)
1,3

Step-by-step Interactive Solution

This equation can also be solved interactively in the document, by applying context-menu operations or commands

one step at a time.

Action

Result in Document

1. Ctrl + drag the equation

(x— 7)2 + (x— 1)2 =4((x - 1)2 + (x—4)2) to a blank
document block region.

=724+ x=1)=4((x=1>+x—4)?)

Group all terms on the right:

2. Right-click this equation and from the context menu select
Move to Right.

=724+ x—1)=4((x—12>+x—4)?)

.'h
e 0=3(x—1)2 +4(x—4)> — (x = 7)

Expand the expression on the right-hand side:

3.Right-click on the result and from the context menu select
Expand.

0=3(x—1)2+4(x—4)2 = (x—7)2 "

0=6x" —24x+ 18

Use Maple's factor command on the resulting right-hand side:
4. Right-click on the result and select Right-hand Side.

5. Right-click on the result and select Factor.

right hand side factor
e =

0=6x" —24x+ 18 63> —24x + 18

6(x—1)(x—3)

Solve for x:

6. Right-click on the result and select Solve — Obtain Solutions
for — x.

solutions for x

6(x—1)(x—3) 1,3
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Graphical Solution

Now that we have seen several methods to solve this problem, we can check the answer by plotting the expression.

Action

Result in Document

1. Ctrl + drag the equation

(x=72+ (x—1)?*=4((x — 1)* + (x — 4)?) toanew
document block region and press Enter.

=724+ x=1)=4((x—12>+(x—4)?)

=72+ (=1 =4x—-1)2+4(x—4)?

2. Right-click the output and select Move to Left.

with the self-documenting arrow positioned at the left.

First, manipulate the equation to become an expression:

Note the difference in the alignment when using context menus
on output rather than input. The result is centered in the document

x=7>2+(x—1)2=4(x—1)>+4(x—4)?

move to left (x—7)2 3 (x— 1)2 —4(x—4)2=0
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Action Result in Document
3. Right-click the output and select Left-hand Side. (x— 7)2 (- 1)2 . 4)2 ~0
left hand side
_—
x—7)2=3(x—1)2—4(x—4)?
4. Right-click the output and select Expand. (=723 (x—1)2—4(x—4)?
exp__and
-6x% +24x— 18
Now that the equation is in its simplest form, plot the result: >
-6x" +24x—18 —
5. Ctrl + drag the output to a new document block.
6. Right-click the expression and select Plots — 2-D Plot. r T T \
-10 -5 0 10
X
-100
-200 -
-300 A
-400 -
-500
-600 -
=700 -
-800
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Action

Result in Document

Change the x and y axis ranges using context menus:

7. By default, plots generated using the context menus have an
x-axis range of -10 to 10. To change the range, right-click the
plot and select Axes — Properties. In the Horizontal tab of
the Axes Properties dialog, de-select Use data extents and
change the Range min and 'Range max to 0 and 5,
respectively.

Click the Vertical tab and de-select Use data extents. Change
the Range min and Range max to -5 and 10, respectively.

8. Click OK to apply the changes and return to the plot.

The interception points of this graph with the x-axis are 1 and 3,
the same solutions that we found previously.

10 A

Graphical Solution Using Smart Popups

Copy the equation

(x— 7)2 + (x— 1)2=4((x— 1)2 + (x—4)2) to a new
document block region and press Enter

=724+ x=1)=4((x—12>+(x—4)?)

=7+ =12 =4x—1)2+4(x—4)2 616

Select the right side of the equation. A Smart popup window is
displayed.

W W3
x— 1"+ 4(x—4)°

Select the Subtract menu option.

Diwidh
[r— a mce 5 Subtract
o4y =0 rx=1) (x—T)2 =3 (x—1)2 —4 (x—4)°
Flx—1)"+4 (x—4)° :
2D Plot
normal
BX — 40 x+68... \/

Complete the square in x,
5
50

2 2_ _
[x—=T)" +(x—1) —8[:( 3

i

The results of the calculation are displayed in the worksheet.

=772+ x—12=4(x— 1%+ (x—4)?)

=72+ x—1=4x—1)+4(x—4> 61D
subtract 4*(x-1)"2+4%(x-4)"2 from both sides
(x—7)2=3(x—1)2—4(x—4)>=0 (5.18)
Select the left side of the equation. A smart popup window is
displayed
The results of the calculation are displayed in the worksheet. =72+ (= 1)2=4((x = )% + (x— 4)?)
=7+ =12 =4x—1)2+4(x—42 619
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subtract 4*(x-1)"2+4*(x-4)"2 from both sides
x=72=3(x—-1)?—4(x—4)%=0 (5.20)
normal (x-7)"2-3%(x-1)"2-4*(x-4)"2
-6x> +24x—18=0 (5.21)
(5.22)
Once again, select the left side of the equation. A smart popup || 6:2 + 245 — 18
window is displayed. - =
The resulting plot is displayed in the worksheet. (x — 7)2 +(x— 1)2 _ 4( (x — 1)2 +(x— 4)2)
=72+ =12 =4Gx—1)12+4x—4)?> 623
subtract 4*(x-1)"2+4%(x-4)"2 from both sides
x—=7?%-3(x—-1)2—-4(x—4)%=0 (5.24)
normal (x-7)"2-3*(x-1)"2-4*(x-4)"2
~6x% +24x —18=0 (5.25)

2D Plot -6*x"2+24*x-18

Example 3 - Solve a Quadratic Trig Equation

Find all of the solutions to the equation 6 cos® (x) — cos(x) — 2 =0 in the interval [0, 2 n],

We solve this problem using the following methods:
* Graphical Solution (page 174)

» Solution by Task Template (page 175)

* Analytic Solution (page 176)
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Graphical Solution

Action

Result in Document

1. Ctrl+ dragthe equation 6 cosz(x) — cos(x) — 2 =0toablank
document block and press Enter.

6 cosz(x) —cos(x) —2=0

6 cos(x)2 —cos(x) —2=0

2. Right-click the output and select Left-hand Side.

left hand side
6 cos(x)2 —cos(x) —2=0 — 2,

6cos(x)2 —cos(x) —2

3. Right-click the output and select Plots — Plot Builder.

[¥] Interactive Plot Builder: Select Plot .

Select Plot Type and Functions

j Edit Functions

Select Plot

2-D plot

2-D polar plat

3-D conformal plot of a complex-valued function
2-D conformal plot of a complex-valued function
2-D complex plok

3-D complex plok

Select Variable Purposes, Ranges, and Flot Options

O

On "Plot’ return plok command

4. Modity the plot range to x =0 to 2*Pi.

Select Variable Purposes, Ranges, and Plot Options

O

On "Plat’ return plok command
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Action

Result in Document

5. Click Plot to display the plot in the document.

6. From the graph, we can see all of the solutions within the
interval [0, 27t]. To approximate the values, click the plot,
select the type of coordinates that you want to view from the

selection menu (ﬁ‘: ¥ ) in the toolbar, and then use the point
probe tool to view the coordinates of the mouse pointer.

INE

[SIE R

Solution by Task Template

Action

Result in Document

Expand the Algebra folder and select Solve
Analytically in a Specified Interval.

1. From the Format menu, select Tasks — Browse.

= - Algebra

------- Complete the Square
#-15) Complesx Arithmetic
Conic - Analysis and Graph

Solve a Set of Equations Symbolically
Solve an Equation Numerically

Solve an Equation Symbalically

Solve an Inequality

Solve Analytically in Specified Interval

2. Click Insert Minimal Content.

Solve Analytically in a Specified Interval

Enter an expression:

> 12 sin(x) — 5 sin(x) — 3

12 si.n(;rjl2 — Sanfx) — 3 (15)

Find the rootz in a
specified interval:

> Student| Calvwlusi |[Roots]( (15, 0.2 )
3N R NaR
[arc:sm[ ?J, —arcsm[ ?J =+ T EII'CS]II[ ?J

{16}
NaR
+ —arcsm[—|+ 2
3)
Express the roofs mn | 3 evalf( (16} )
floating-point form: ([0 3480620730, 2 293530575, 3 481429564, {17

5943348398 |
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Action

Result in Document

reference the results.

3. Replace the current equation with the one from this

example, 6 cosz(x) — cos(x) — 2 =0, andthenexecute
the commands. Notice that equation labels are used to

Solve Analytically in a Specified Interval

Enter an expression:

> 6 cnsz(x) —cos(x) —2=0

ﬁcus(x]z— cos(x) — 2=10 {15}
Find_the roots ma | Student| Caloulus! || Roots((15), 0.2 m)
specified mterval: 23 3 4 7
[arccus[?J, SmS T —arccus[?J (16)
+ 271:]

Express the roots in
foating-pomt form:

> evalf((16))
[0.8410686706, 2.094395103, 4133790204,  (17)
5.442116637]

Analytic Solution

Action

Result in Do

cument

document block region.

1. Ctrl+ dragthe equation 6 cosz(x) — cos(x) —2=0toablank

6 cosz(x) —cos(x) —2=0

2. Right-click the expression and select Left-hand Side.

6cosz(x) -cos(x) -2=0

left hand sid
u%cos(x)z —cos(x) —2

3. Right-click the output and select Factor.

6cos(x)2 —cos(x) —2

factor
=

2cos(x) + 1) (3cos(x) —2)

5. Right-click and select Solve — Solve.

4. Ctrl + drag the first factor to a blank document block region.

(2cos(x) + 1) _solve, {x=£n}

3

region.

7. Right-click and select Solve — Solve.

[0,7].

6. Ctrl + drag the second factor to a blank document block

Notice that you have not found all of the solutions, as with the
above methods. These are all of the solutions in the interval

(3cos(x) —2) _slve, {x=arccos(%)}

Example 4 - Find the Inverse Function

If £(x) =¥ + 1,x > 0, find and graph the rule for /= ! (x), its functional inverse.

We solve this problem using the following methods:

» Implement the Definition Graphically (page 177)

* Solution by Tutor (page 179)
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Implement the Definition Graphically
The graph of the inverse function is the set of ordered pairs formed by interchanging the ordinates and abscissas.
Action Result in Document
1. In a blank document block, enter [xz + l,x] and press [x2 + l,x]
Enter.
[x2 + l,x]
2. Right-click the output and select Plots — Plot Builder. | l
& P (%] Interactive Plot Builder: Select Plot Typ-e
Select Plok Type and Functions
v
Select Plat
2-D parametric plot
2-D plot
2-D polar plok
3-D conformal plot of a complex-valued Function
2-D conformal plot of a complex-valued Function
2-D complex plot
3-D complex plot
Select Variable Purposes, Ranges, and Plot Options
Parameter k4 V -3 ko |3
On Plot’ return plat command F]
3. Inthe Plot Builder : Select Plot Type dialog, ensure that
2-D parametric plot is selected in the Select Plot region.
N
4. Adjust the domain for x to the interval [0, 1].
5. Click Plot to return the plot to the document. 1
0.8
0.6+
0.4+
0.2+
G T 1 T 1 T 1
1 1.2 1.4 1.6 1.8 2
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Action

Result in Document

6. Ctrl + drag the expression % + 1 onto this grap<ns1:XMLFault xmlns:ns1="http://cxf.apache.org/bindings/xformat"><ns1:faultstring xmlns:ns1="http://cxf.apache.org/bindings/xformat">java.lang.OutOfMemoryError: Java heap space</ns1:faultstring></ns1:XMLFault>